Author Topic: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit  (Read 33940 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13193
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« on: April 01, 2012, 12:56:30 am »
According to a TON of websites the new version (1.5.0 and greater) of WINE fixes the install of Apple iTunes 10.x

Before we get to the WINE 1.5.1 installation, let me explain .. iTunes 10.6 definitely installed, and ran, it also has no problem as a player, but seemed unable to access the iTunes Store (or do any other "online" activity) .. this may be fixable, but (FOR NOW) is beyond the scope of this tutorial .. I may add something later if I manage to get the "online" side if it working

I also must add that I haven't tested iTunes with an iPod, iPad, or iPhone .. quite simply I don't own one, and have no intention of changing that ;)

For now this is SOLELY a tutorial about installing WINE 1.5.1 .. with a few hints that may help with iTunes at the end.

These instructions should work for pretty much any recent version of Ubuntu .. I've tested it on 11.10 64bit, but it should work on earlier versions and 32bit architecture .. It should also work in PeppermintOS (Two), but for those that have followed my tutorial for installing PeppermintOS on an Acer Aspire One with an 8GB SSD, it's probably best not to bother, the build dependencies alone will probably use too much space on your SSD .. if however you have plenty of room, a larger SSD, or a HDD then feel free :)

OK, we will be adding a PPA (so we can get the build dependencies for the latest version of WINE), installing some required packages, installing the build dependencies, downloading the WINE 1.5.1 source code, then compiling and installing.

The first thing you'll want to do is REMOVE any earlier versions of wine and wine-gecko .. best place to do this is in your package manager.
(if you don't know how .. ask)

Add the ppa:ubuntu-wine/ppa PPA so that we can pull in the build dependencies for the latest version (wine1.3 .. which FYI will *actually* be wine1.4 after adding the PPA, but it will still be *called" as* wine1.3):
Code: [Select]
sudo add-apt-repository ppa:ubuntu-wine/ppa
then update the package cache:
Code: [Select]
sudo apt-get update

Install some required packages:
Code: [Select]
sudo apt-get install linux-headers-generic build-essential flex bison qt3-dev-tools qt4-qmake

Pull in the build dependencies (I know it says wine1.3, but that doesn't matter at this point):
Code: [Select]
sudo apt-get build-dep wine1.3

Download the WINE 1.5.1 source code to your Home directory:
Code: [Select]
cd ~
then
Code: [Select]
wget http://sourceforge.net/projects/wine/files/Source/wine-1.5.1.tar.bz2

Unpack the archive you just downloaded:
Code: [Select]
tar -xjvf wine-1.5.1.tar.bz2

Change directory to the wine-1.5.1 directory:
Code: [Select]
cd wine-1.5.1

Run configure:
Code: [Select]
./configure
and wait till it finishes and leaves you back at an $ prompt .. (info - just above the $ prompt it should now be telling you to run "make")

Run make:
Code: [Select]
make

At this point, go lie down for a bit, or go to the pub as it will take about an hour to compile

When it eventually finishes compiling and leaves you back at an $ prompt ..

Install it with:
Code: [Select]
sudo make install

Once installed, run
Code: [Select]
winecfg
to configure it.

Now you can check you have version 1.5.1 by running
Code: [Select]
wine --version

OK that's it .. you should now be running WINE 1.5.1 :)

See below for a couple of hints



If uninstalling an earlier version of wine also removed winetricks .. DO NOT reinstall it through your package managers (that will also reinstall the earlier version of wine) .. instead install it like this:-
Code: [Select]
cd ~
then
Code: [Select]
wget http://winetricks.org/winetricks
then
Code: [Select]
chmod +x winetricks 
You'll then find it in your home folder .. run it from there.

If you're intent on trying iTunes before I've worked it out .. one thing I HAVE discovered is that after you install iTunes and attempt to run it in WINE, you will get a warning that the ODBC versions don't match .. the fix is to use winetricks to install mdac28

The WineHQ pages about installing iTunes suggest when you run winecfg you set the system to Windows 7 not XP

And when launching iTunes you will get a message about it not being able to read or write to the CD drive .. but this doesn't stop it from launching.

As I said, ATM this is NOT a tutorial for getting iTunes working in WINE 1.5.1 .. that *may* come later :)

Can I ask that if anyone DOES get iTunes working before I get round to trying .. could you please post how you did it .. thanks in advance.
« Last Edit: April 01, 2012, 05:36:11 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline johnaaronrose

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 0
  • Gender: Male
  • I've just joined!
    • View Profile
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #1 on: April 04, 2012, 06:38:38 am »
When I entered sudo apt-get build-dep wine1.3, I got:
john@JohnDesktop:~$ sudo apt-get build-dep wine1.3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to find a source package for wine1.3

Help please!
Regards,
John

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13193
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #2 on: April 04, 2012, 10:56:01 am »
Which version of Ubutnu are you running, and which architecture.  ?

If you're not sure, send the output from:
Code: [Select]
cat /etc/*-release
and
Code: [Select]
uname -a
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline johnaaronrose

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 0
  • Gender: Male
  • I've just joined!
    • View Profile
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #3 on: April 04, 2012, 12:11:45 pm »
I should have stated them on my post. I'm using a clean install of Ubuntu Desktop Lucid 64 bit.
Regards,
John

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13193
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #4 on: April 04, 2012, 01:35:40 pm »
That''s odd .. If you have an active internet connection, and added that PPA, wine1.3 *should* be available, as it's in that PPA:
https://launchpad.net/~ubuntu-wine/+archive/ppa?field.series_filter=lucid

Check you have the "Universe" and "Multiverse" repositories enabled .. this can be done by starting the synaptic package manager, then going to Settings>Repositories .. now on the first tab, tick all the boxes (except the one for cdrom:  if present) .. click "Close"

Now Close Synaptic, and open a terminal and run:
Code: [Select]
sudo apt-get update && sudo apt-get upgrade

When that's done .. try that command again and let me know what happens.

Check you have the "universe" repositories enabled .. this cann be done by starting the synaptic package manager
« Last Edit: April 04, 2012, 01:49:39 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #5 on: April 04, 2012, 01:42:10 pm »
There's a typo in your command Mark.

Should read

Code: [Select]
sudo apt-get update && sudo apt-get upgrade

:)
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13193
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #6 on: April 04, 2012, 01:50:11 pm »
Thanks .. fixed in original posting :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline johnaaronrose

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 0
  • Gender: Male
  • I've just joined!
    • View Profile
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #7 on: April 04, 2012, 06:41:01 pm »
Mark,

Universe & Multiverse already enabled. Searching for wine with Origin selected in Synaptic shows that wine1.3 (with version shown as 1.4) is installed. Tried the sudo apt-get build-dep wine1.3 again and it told me that 'Unable to lock admin'. So I closed Synaptic. Tried sudo apt-get build-dep wine1.3 again and it did the same as before. So I thought I'd try unchecking the '-' against Source code entry. That gave me:
john@JohnDesktop:~$ sudo apt-get build-dep wine1.3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Could not open file /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_main_source_Sources - open (2: No such file or directory)
Thus, things even worse!

Checked the '-' against Source code entry. Then did sudo apt-get update && sudo apt-get upgrade and things back to normal i.e. getting:
john@JohnDesktop:~$ sudo apt-get build-dep wine1.3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to find a source package for wine1.3

I think that the reason for the problem is that the wine ppa contents were modified on 16 March 2012. More specifically I do not know.

« Last Edit: April 04, 2012, 06:49:07 pm by johnaaronrose »
Regards,
John

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13193
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #8 on: April 04, 2012, 07:30:00 pm »
OK, try purging that PPA, which will undo any changes made by the PPA, and disable it:
Code: [Select]
sudo apt-get install ppa-purge
then
Code: [Select]
sudo ppa-purge ppa:ubuntu-wine/ppa

Then update the package cache:
Code: [Select]
sudo apt-get update

Run a system update:
Code: [Select]
sudo apt-get upgrade

Now have a look in Synaptic to see if there is a wine1.3 package .. if there is, again try:
Code: [Select]
sudo apt-get build-dep wine1.3
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline johnaaronrose

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 0
  • Gender: Male
  • I've just joined!
    • View Profile
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #9 on: April 05, 2012, 10:04:49 am »
Mark,

Done as instructed. "sudo apt-get build-dep wine1.3" gave the usual "E: Unable to find a source package for wine1.3".  However, even though wine ppa purge worked, as did other instructions, wine 1.3 package is still showing installed version as 1.4  on Synaptic: checked it with Software Sources & ppa giving wine repository is no longer checked.

No reply from Scott Ritchie re the wine ppa contents possibly having an error.

PS it's a little bit irritating that this forum does not automatically result in getting an email alert when a post is made on  a 'contribut' topic (i.e. without using Notify each time) or am I missing something?
« Last Edit: April 05, 2012, 10:07:40 am by johnaaronrose »
Regards,
John

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13193
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #10 on: April 05, 2012, 10:36:51 am »
You had notifications set to only email you when this topic was "moderated" notto email you when there was an unread reply .. I've fixed that for you (hopefully).

I'll load 10.04 into a VM and see if I can replicate the missing source package then get back to you.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline johnaaronrose

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 0
  • Gender: Male
  • I've just joined!
    • View Profile
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #11 on: April 06, 2012, 07:29:35 am »
Mark,

I got sudo apt-get build-dep wine1.3 to download & install 240MB of packages by adding the deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu lucid main repository (by sudo gedit /etc/apt/sources.list.d/ubuntu-wine-ppa-lucid.list, as adding the repo using Software Sources & +Add... button did not enable the +Add Source.. button!).

Rest of instructions worked (it did ask about downloading an appropriate version of wine-gecko, to which I assented & it did that OK). winetricks was not removed & is showing as version 0.0+20120308~ppa1: so I guess that that is latest (i.e. wine 5.1 does not incorporate a later version: I always get the feeling that wine & winetricks do not have any dev in common). winecfg About menu item & wine --version show wine as version 5.1. Interestingly Synaptic does not show wine 1.5.1: why is this?

Now on to see if Basic4android will work properly under Wine 1.5.1 - it being the reason why I wanted to install Wine 1.5.1.
« Last Edit: April 06, 2012, 08:48:18 am by johnaaronrose »
Regards,
John

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13193
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #12 on: April 06, 2012, 11:03:18 am »
A bit odd that .. but glad to hear you got it installed .. and thanks for the update :)

Synaptic won't list it because Synaptic is a package manager .. WINE 1.5.1 wasn't installed as a package (.deb), it was compiled, so Synaptic is unaware of its existence on the system.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline johnaaronrose

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 0
  • Gender: Male
  • I've just joined!
    • View Profile
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #13 on: April 06, 2012, 02:50:21 pm »
Mark,

I'd forgotten about compiling an app (Wine in this case) leads to it not showing up in Synaptic as that only shows packages (i.e. installed from repos & downloaded .debs). I actually had a major problem with Gambas because Gambas' author (Benoit Misasini - hopefully got spelling right) asked me to check if a bug had been cleared on his dev version (i.e. source available on Subversion: downloaded & compiled by me) before a .deb had been created. If I remember correctly, this lead to Gambas being installed on /usr/local (rather than /usr where a .deb 'installs' to): this caused strange runtime results. I had to uninstall the compiled version. As a result, kendek (credit to him) now has a Gambas Pre-release ppa on Launchpad containing the latest Gambas version (he updates it approx weekly).

PS Basic4android still didn't behave using Wine 1.5.1. This is bug 30085 in Wine: my guess is that it's caused by Wine's usage of .Net2.0 (incl Sp1 & SP2). have you had experience of .Net2 using Wine?
Regards,
John

Offline Koviko

  • Jr. Member
  • **
  • Posts: 3
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Installing WINE 1.5.1 in Ubuntu 32bit and 64bit
« Reply #14 on: April 06, 2012, 03:09:31 pm »
Firstly, great tutorial. Very clear, especially for someone new to compiling applications from source. I'm running into a slight issue.

On the step where you says to check the version with "wine --version", I get the error "bash: /usr/bin/wine: No such file or directory". Since winecfg worked, I ran "which winecfg" to see where it was. Both wine and winecfg are in /usr/local/bin/, not /usr/bin/.

Is there a way to make it so that the command "wine" points to that location? Or should I create a symlink to the file in /usr/bin/?

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal