Author Topic: Internet Connection Sharing - Support Question  (Read 9700 times)

0 Members and 1 Guest are viewing this topic.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Internet Connection Sharing - Support Question
« on: April 04, 2012, 01:59:53 pm »
Currently installing the Beta 2 version of Ubuntu Server 12.04. I haven't managed to get my 5-port switch yet, so the NAS ain't got network access. However it sits right next to my laptop, so I've tried sharing a wired connecting between the two through ICS by switching the IPv4 settings to "Share with other computers". No luck unfortunately. Works with the X360 quite fine though.

Help please?
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13189
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #1 on: April 04, 2012, 02:43:11 pm »
First of all (as the server edition has no nice friendly GUI) read this:
http://www.ubuntugeek.com/ubuntu-networking-configuration-using-command-line.html

ignore vi as the editor (unless you know it), use nano instead.

First you need to see if the network interface is working:
Code: [Select]
sudo lshw -C network
and
Code: [Select]
ifconfig
and check the contents of
Code: [Select]
nano /etc/network/interfaces

IIRC, the "client" (eg. your server box) in an ICS setup needs to be configured to get its address through DHCP .. is my memory correct ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #2 on: April 04, 2012, 02:52:38 pm »
From what I can see, through ICS it's not getting to the gateway. It detects the connection coming from the laptop, just won't pass through it. Limme go run the commands and I'll return with some outputs.

Yeah it's needs DHCP IIRC. 
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13189
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #3 on: April 04, 2012, 02:58:45 pm »
You haven't disabled DHCP in the router have you ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #4 on: April 04, 2012, 02:59:54 pm »
No, I haven't. It's still functional. I reserved addresses .0.2 - .0.100 on the pool though.
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1421
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #5 on: April 04, 2012, 05:55:09 pm »
Have you tried to set your NAS up with fixed IP address (same subnet as your laptop)?
also is your laptop firewall activated by any chance?
As for not having the GUI on the server that should not be a problem
as you could install Webmin (which I find invaluable) http://www.webmin.com/
then access it via your laptops browser
« Last Edit: April 04, 2012, 06:02:04 pm by SeZo »

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #6 on: April 04, 2012, 10:42:58 pm »

Code: [Select]
sudo lshw -C network

(click to show/hide)

Quote from: Mark Greaves

ifconfig

eth0   Link encap: Ethernet     HWaddr 00:16:76:80:13:b5
           inet6 addr: fe80::21:76ff:fe80:13b5/64  Scope:Link
           UP BROADCAST RUNNING MULTICAST   MTU:1500    Metric:1
           RX packets: 0  errors:0  dropped:0  overruns:0  carrier:0
           collisions:0  txqueuelen:1000
           RX bytes:0  (0.0 B)     TX bytes:1836  (1.8 KB)
           Interrupt: 21  Based  address:0x1000

lo       Link encap: Local Loopbacl
          inet addr:127.0.0.1  Mask: 255.0.0.0
          inet6 addr:  ::1/128  Scope:Host
          UP LOOPBACK RUNNING MTU:16436  Metric:1
          RX packets:4  errors:0  dropped:0  overruns:0  frame:0
          TX bytes: 240  (240.0 B)   TX  bytes: 240  (240.0 B)

nano /etc/network/interfaces

auto lo
iface lo  inet  loopback


I should point out at this time, that I'm running the NAS on Ubuntu 9.10 just now, as I don't have a P/S2 keyboard to select "English" when the Ubuntu Server disc starts up, and there's no count-down timer on it either to automatically select that otherwise I'd have been able too.

I also can't access the BIOS with a P/S2 keyboard either which is crap. :-|
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13189
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #7 on: April 04, 2012, 11:47:51 pm »
Quick question .. you have rebooted the laptop since changing the eth0 to "shared to ther computers" haven't you ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #8 on: April 04, 2012, 11:49:02 pm »
Yup
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13189
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #9 on: April 05, 2012, 12:12:01 am »
Try setting IPv6 to ignore at both end of the ICS connection

and as SeZo suggests .. try turning off the firewall if it's active.

You can check if it's active with
Code: [Select]
sudo ufw ststus

turn it off with
Code: [Select]
sudo ufw disable

turn it on with
Code: [Select]
sudo ufw enable
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #10 on: April 05, 2012, 07:57:14 pm »
Firewall was disabled, and IPv6 was on "Ignore" by default on both. :-/
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #11 on: April 06, 2012, 03:16:14 am »
???
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13189
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #12 on: April 06, 2012, 11:30:26 am »
I don't know what else to tell you on this as I don't use ICS, nor have I got a Karmic PC .. it might however be a good idea to check if the ethernet card works at all (though the output suggests it does) by plugging it directly into the router and seeing if you get a connection.

or, you could ignore the GUI method, and move straight on to the CLI method, which is documented here:
https://help.ubuntu.com/community/Internet/ConnectionSharing

but you'd still want to verify the network card works first .. otherwise you could be wasting your time.

Meanwhile, I'll keep scouring the interweb .. and if I come across anything (though there seems to be a distinct lack), I'll let you know.

I am however a bit baffled that ifconfig seems to show you getting an IPv6 address (but no IPv4), even though you say IPv6 was set to ignore .. I seem to vaguely remember that doesn't "disable" IPv6, just as the name suggests "ignores" it.

My point is, that with no cable attached, my network card has NEITHER, so something is getting through for it to be assigned an IPv6 address .. ie. the system knows it's attached to something, so I'd *guess* the issue is at the laptop end, but you still need to verify the card in the box just to rule it out.
« Last Edit: April 06, 2012, 11:40:56 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1661
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #13 on: April 06, 2012, 02:25:22 pm »
Yep, network card works. ICS is a funny bugger init? I'll give the CLI commands a go, see if it makes any difference.

My initial plan was to use the "Upgrade" option on the disc when you inserted into the drive when in Ubuntu. But I clicked it a few times and nothing seemed to work. So I'll probs have to go and buy a P/S2 keyboard adapter / a keyboard itself.
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13189
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Internet Connection Sharing - Support Question
« Reply #14 on: April 06, 2012, 02:41:21 pm »
With older systems, a PS/2 keyboard is always handy .. as there may be no way to access the BIOS, or enter anything until the USB drivers are loaded by the OS otherwise  .. as you've obviously discovered.

Older MoBo's can't initialise USB KB's/Mice on their own.

Depending on the age of the MoBo, there *may* be an option to turn on support for USB K/B's and Mice  in the BIOS .. but you'd still need a PS/2 K/B to do that ??? .. and if you ever reset the BIOS, or the battery dies, you'd need the PS/2 K/B again, because it would default to disabled .. I never quite understood why the manufacturers did that  :o

For a while (IIRC) Dell were selling systems with USB Keyboards and Mice, that if you reset or updated the BIOS (or the battery died) defaulted to having the USB support switched off.
« Last Edit: April 06, 2012, 02:53:40 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal