Author Topic: Who remembers Betamax ?  (Read 17539 times)

0 Members and 1 Guest are viewing this topic.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1428
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #75 on: December 28, 2012, 05:59:00 pm »
It seems very erratic the way the card behaves. :-\
Quote
firstly I uncommented line options tuner type=0 then opened up xawtv and both machines tuned in perfect

Just ncommenting the tuner line (without unloading the module) would have left the tuner module loaded until your next boot.
So when you tested the tuning it was in fact with the loaded tuner module. But after the reboot the modification came into effect.
Is it now loaded?
Code: [Select]
lsmod | egrep '(bttv|tuner)'

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #76 on: December 28, 2012, 06:04:01 pm »
Hi Mark

Quote
You still haven't confirmed you've connected your TV/Capture card to your soundcard ?

I did answer that on an earlier post
Quote
No  I didn't think I had to I thought it would receive video and audio through the RF cable

Quote
Have you considered creating a Mint 13 or Ubuntu 12.04 LiveUSB with persistence .. booting to it .. and seeing if cheese works in that ?
No I haven't done that but I can can try to install to usb and run that if you think it will help

Quote
What was the problem with cheese in Peppermint ?

Cheese wont open in peppermint I've tried uninstalling and re-installing but it just wont open

To be honest I've been getting quite a lot of weird behaviour in both my Mint & Peppermint installs, I can't think of a time when I have been more disillusioned with Linux since I moved to it, I understand the problems are probably more my own doing and my lack of understanding rather than the fault of Linux but I seem to be having a hard time with it lately, I've even considered reinstalling both operating systems again from scratch but I don't want to go though all the setting up again if I can avoid it 


If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #77 on: December 28, 2012, 06:15:06 pm »
Hi SeZo

Quote
Is it now loaded?
Code: [Select]
lsmod | egrep '(bttv|tuner)'

I'm still at work, but I'll try what you suggest when I get home and report back
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #78 on: December 28, 2012, 07:15:16 pm »
Code: [Select]
graeme@Linux1 ~ $ lsmod | egrep '(bttv|tuner)'
tuner_simple           22016  1
tuner_types            18998  1 tuner_simple
tuner                  26797  1
bttv                  112147  0
videobuf_dma_sg        18714  1 bttv
videobuf_core          25097  2 bttv,videobuf_dma_sg
btcx_risc              13400  1 bttv
rc_core                21266  1 bttv
tveeprom               17009  1 bttv
v4l2_common            15767  3 tuner,msp3400,bttv
videodev               95841  4 tuner,msp3400,bttv,v4l2_common
i2c_algo_bit           13197  2 bttv,i915
graeme@Linux1 ~ $ lsmod | egrep '(bttv|tuner)'

Also here is the error output when I try to open xawtv
Code: [Select]
graeme@Linux1 ~ $ xawtv
This is xawtv-3.102, running on Linux/i686 (3.5.0-17-generic)
xinerama 0: 1600x900+0+0
vid-open-auto: using analog TV device /dev/video0
WARNING: No DGA direct video mode for this display.
WARNING: keeping fbuf pitch at: 6400, as no base addr was detected
WARNING: couldn't find framebuffer base address, try manual
         configuration ("v4l-conf -a <addr>")
v4l2: WARNING: framebuffer base address mismatch
v4l2: me=(nil) v4l=(nil)
Alsa devices: cap: (null) (/dev/video0), out: default
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  149 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  483
  Current serial number in output stream:  484
graeme@Linux1 ~ $


If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1428
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #79 on: December 28, 2012, 09:23:31 pm »
Quote
X Error of failed request:  BadAlloc (insufficient resources for operation)

Hmm. that is an X server error.
Try removing acceleration on your intel graphics (from your lspci.txt)
Quote
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)

Create a file '/etc/X11/xorg.conf.d/20-intel.conf'
Open a terminal and run:
Code: [Select]
sudo gedit /etc/X11/xorg.conf.d/20-intel.conf

a BLANK file should open.

add the following:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "NoAccel" "true"
EndSection

SAVE the file, and exit gedit.

Yes, you lose the acceleration this way ;)
You can always remove this file if it does not work.

Now to test .. REBOOT then try xawtv

« Last Edit: December 28, 2012, 09:25:22 pm by SeZo »

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #80 on: December 28, 2012, 09:35:16 pm »
Hi Sezo

Sorry if I've jumped the gun but while I was waiting on a reply, I uninstalled xawtv, Cheese, tvtime & vlc, I then rebooted and re-installed xawtv, and it's now opening up and tuning into the VHS on channel 60 PAL-DK, picture quality is good but I have no sound, I'm not able to tune in the Betamax but I only tried one scan

In view of that should i still try to remove graphics acceleration as you suggested in your last post ?

Many thanks

Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1428
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #81 on: December 28, 2012, 09:49:41 pm »
It is up to you, though it might get rid of the framebuffer error.

If you can tune in the betamax then find out the frequency for later:
Code: [Select]
v4l2-ctl --get-freq

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #82 on: December 28, 2012, 10:13:25 pm »
Ok I got the Betamax tuned into Channel 26 and I've taken a note of the frequencies for both machines

I still have no sound and I get this error when I try to record


Code: [Select]
graeme@Linux1 ~ $ xawtv
This is xawtv-3.102, running on Linux/i686 (3.5.0-17-generic)
xinerama 0: 1600x900+0+0
vid-open-auto: using analog TV device /dev/video0
WARNING: No DGA direct video mode for this display.
WARNING: keeping fbuf pitch at: 6400, as no base addr was detected
WARNING: couldn't find framebuffer base address, try manual
         configuration ("v4l-conf -a <addr>")
v4l2: WARNING: framebuffer base address mismatch
v4l2: me=(nil) v4l=(nil)
Alsa devices: cap: (null) (/dev/video0), out: default
oss: open /dev/dsp: No such file or directory

Many thanks

Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1428
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #83 on: December 28, 2012, 10:37:13 pm »
The audio problem seems to affect xawtv recording function as it tries to use OSS which is legacy now.
 is I think you need alsa-oss which provides /dev/dsp.

Code: [Select]
sudo apt-get install alsa-oss

You might still not get sound though as it is possible that the audio output on your card requires hard wired connection to your sound card
(instead of using the PCI bus as the video does.)

Get list of audio inputs:
Code: [Select]
arecord -l
« Last Edit: December 28, 2012, 10:52:55 pm by SeZo »

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #84 on: December 28, 2012, 10:44:25 pm »
graeme@Linux1 ~ $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
graeme@Linux1 ~ $
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1428
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #85 on: December 28, 2012, 10:57:40 pm »
There should be a distinct audio input  for your card if it was coming via the bus.
It might be worth to open up the case and see if there is a connector (internal) on your card for audio output.

Have you tried xawtv after (if) you have installed alsa-oss?

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #86 on: December 28, 2012, 11:28:13 pm »
Quote
There should be a distinct audio input  for your card if it was coming via the bus.

I'm not entirely sure what you mean there, but in pulse audio volume control settings i can see under "Input Devices" that i am getting an input, but I dont appear to be getting anything under "Output Devices"

Quote
It might be worth to open up the case and see if there is a connector (internal) on your card for audio output.

Ok I can have a look tomorrow to see if I have a connector
This might be a stupid question, but does it mean because I can't hear the output the it wouldn't record the output if I could get record to work ?

Quote
Have you tried xawtv after (if) you have installed alsa-oss?

yes and it has made no difference I can see

Anyway it's getting late but I can try again tomorrow if you still want to stick with it


many thanks


Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13209
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Who remembers Betamax ?
« Reply #87 on: December 29, 2012, 12:39:06 am »
Quote
does it mean because I can't hear the output the it wouldn't record the output if I could get record to work ?


Yes, probably, not necessarily, and no .. helpful eh ?  :o

Linux uses an Everything is a File system .. so all system resources are registered as files (devices go in /dev)

As the TV/Capture card doesn't appear to register itself as an audio device , it's my guess that it needs you to use the sound card as the "audio" capture device .. so you'd need to run a cable either from pins on the capture card itself to the CD audio input on the sound card, or to run a mini-jack to mini-jack from audio OUT on the capture card to audio IN on the sound card.

Then tell whatever recording software you're using to use /dev/video0 for video, and /dev/<whatever device file your sound card capture is> for audio.

It seems xawtv likes the audio capture device registered as /dev/dsp(n) .. which is what sound devices USED TO get registered as under the old OSS sound system (no longer used by default)

I'm gonna take a guess here, and assume that now you've installed alsa-oss SeZo will ask you for the output from:
Code: [Select]
arecord -l
again, and:
Code: [Select]
ls -a /dev | grep dsp
to see if installing that caused the sound card capture to get registered as /dev/dsp(n).
and just for good luck, throw in the output from:
Code: [Select]
ls -a /dev | grep video

But you really need to tell us if there are any pins on the capture card for audio OUT, or a jack plug on the back marked audio OUT

As I said I'm kinda out of my comfort zone with capture .. so if I'm totally off track, please ignore this .. though there's nothing in this post that will cause any problems, so it certainly wont hurt ;)

[EDIT]

Please re-read section 4.1 here:
http://www.faqs.org/docs/Linux-mini/BTTV.html#ss4.1
about connecting the audio leads to your soundcard.

[END EDIT
« Last Edit: December 29, 2012, 01:43:14 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #88 on: December 29, 2012, 07:16:38 am »
Hi mark thanks again for your help

Quote
Yes, probably, not necessarily, and no .. helpful eh ? 

emm no :)

Quote
As the TV/Capture card doesn't appear to register itself as an audio device , it's my guess that it needs you to use the sound card as the "audio" capture device .. so you'd need to run a cable either from pins on the capture card itself to the CD audio input on the sound card, or to run a mini-jack to mini-jack from audio OUT on the capture card to audio IN on the sound card.

I've checked the tv card and it has audio in and audio out jacks at the rear so it should be a simple matter to connect the tv card to the sound card that way if I can find a lead (I'm sure I have one somewhere)

Quote
I'm gonna take a guess here, and assume that now you've installed alsa-oss SeZo will ask you for the output from:

Your guess is correct :)

Quote
As I said I'm kinda out of my comfort zone with capture .. so if I'm totally off track, please ignore this .. though there's nothing in this post that will cause any problems, so it certainly wont hurt

I wouldn't know if you were off track but I trust your judgement :)

Here's the outputs you asked for

Code: [Select]
graeme@Linux1 ~ $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
graeme@Linux1 ~ $ ls -a /dev | grep dsp
graeme@Linux1 ~ $ ls -a /dev | grep video
video0
graeme@Linux1 ~ $

I'm quietly confident that connecting the tv card to the sound input will work, I once had to do this to a radio card and it worked fine, anyway I'll do that as soon as I can and report back then hopefully we can get the recording issue sorted out.

Once again a huge thanks to you and SeZo for all you effort and patience


Graeme
« Last Edit: December 29, 2012, 07:25:50 am by Emegra »
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Online Emegra

  • Hero Member
  • *****
  • Posts: 2393
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Who remembers Betamax ?
« Reply #89 on: December 29, 2012, 07:39:18 am »
I'm not sure if this helps but I tried connecting my speakers directly into the tv card audio output and I have sound :)
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal