Author Topic: Partial Upgrade  (Read 1936 times)

0 Members and 1 Guest are viewing this topic.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Partial Upgrade
« on: January 13, 2013, 08:44:55 am »
My PC did a 'partial upgrade' last night and removed a few programs (which I want to keep)
They were VLC, Transmission  Xscreensaver.
I took a screenshot of the libs that it said it was removing, I have also included the other screenshot of another p'partialupgrade' a few days ago..

I am also trying to install LibreOffice 3.6.4 (http://www.libreoffice.org/download/) but I'm not getting anywhere as I have noticed another program missing, the GUI Deb Installer, I have had a look in the Ubuntu Software Centre and it says it's installed but it's not showing in the drop-down menu when selecting files in nautilus, how can I get it back?

Is there a way I can stop these 'partial upgrades' from removing programs and other things I want to keep?

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #1 on: January 13, 2013, 09:11:50 am »
I am following the instructions but when I type;
Code: [Select]
sudo dpkg -i *.deb
I get this;
dpkg: regarding libreoffice3.6-debian-menus_3.6.4-3_all.deb containing libreoffice-debian-menus:
 libreoffice-debian-menus conflicts with libreoffice-bundled
  libreoffice-core provides libreoffice-bundled and is present and installed.
dpkg: error processing libreoffice3.6-debian-menus_3.6.4-3_all.deb (--install):
 conflicting packages - not installing libreoffice-debian-menus
Errors were encountered while processing:
 libreoffice3.6-debian-menus_3.6.4-3_all.deb

I have tried the best I can to remove anything to do with the previous install of LO by searching through Synaptic Package Manager but being carefull not to remove anything that would harm the system. There must be something I am missing but just can't see it...

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13792
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Partial Upgrade
« Reply #2 on: January 13, 2013, 11:33:27 am »
To remove all traces of your previous LO installation, including config files .. run:
Code: [Select]
sudo apt-get remove --purge libreoffice*
then try installing the new LO again.

Quote
I have noticed another program missing, the GUI Deb Installer, I have had a look in the Ubuntu Software Centre and it says it's installed but it's not showing in the drop-down menu when selecting files in nautilus, how can I get it back?

The Ubuntu Software Centre is now supposed to be the GUI installer for .deb files, but if you mean gdebi .. try uninstalling it, then reinstalling it:
Code: [Select]
sudo apt-get remove --purge gdebi
then
Code: [Select]
sudo apt-get install gdebi
« Last Edit: January 13, 2013, 11:38:37 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #3 on: January 13, 2013, 12:38:26 pm »
Code: [Select]
sudo apt-get remove --purge libreoffice*
I was going to try that command but didnít know to include the '*' and when I tried removing it in Synaptic Package Manager it said it was going to remove some important stuff so I stopped.

I have noticed the .Deb installer is also now hidden away (see screenshot)... Don't know why thereís two though....


Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #4 on: January 13, 2013, 12:52:58 pm »
I've installed and got this, is it anything that needs fixing?
pooky2483@pooky2483-ubuntu12:~/Downloads/LibO_3.6.4.3_Linux_x86-64_install-deb_en-US/DEBS/desktop-integration$ sudo dpkg -i *.deb
(Reading database ... 444008 files and directories currently installed.)
Unpacking libreoffice-debian-menus (from libreoffice3.6-debian-menus_3.6.4-3_all.deb) ...
Setting up libreoffice-debian-menus (3.6.4-3) ...
/usr/bin/gtk-update-icon-cache
gtk-update-icon-cache: Cache file created successfully.
/usr/bin/gtk-update-icon-cache
gtk-update-icon-cache: Cache file created successfully.
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'

Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for gnome-icon-theme ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for menu ...

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13792
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Partial Upgrade
« Reply #5 on: January 13, 2013, 01:03:46 pm »
Nope, as long as it opens it's own mime types (.odt, etc.) that's not a problem.

Quote
I have noticed the .Deb installer is also now hidden away (see screenshot)... Don't know why thereís two though....

As I said, the Ubuntu Software Centre is now the default .deb installer, and I don't know why it's listed twice either .. I suppose that's fixable (removing the second entry), but why bother.

.
« Last Edit: January 13, 2013, 01:21:26 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #6 on: January 13, 2013, 01:21:03 pm »
Thats ok then  :)

Just one more question... Why is the version in the repo still the old version and not updated to the new version as I posted a question/bug in Bugzilla and was told to update to the new version of LibreOffice...

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13792
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Partial Upgrade
« Reply #7 on: January 13, 2013, 01:23:08 pm »
Sometimes it takes a while for the new version to be packaged and included in the repos .. and sometimes they don't bother at all unless the new version addresses some kind of major issue.

Sometimes it's easier to stick with a known version than to add a new version that may introduce a raft of new issues .. they can't win, either way they'll upset some people.

LTS versions of Ubuntu, tend not to update to the latest versions, and stick with a known "good" versions, even if they have *minor* issues (at least the minor issues will be known) .. they don't want to bung a new version in the repo's and risk it breaking other stuff or creating MAJOR new issues when the LTS releases are liable to be used more in production environments.

non-LTS versions tend to be a bit more experimental .. indeed that's the whole point of non-LTS versions .. they are to test stuff out.

.
« Last Edit: January 13, 2013, 01:34:09 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #8 on: January 13, 2013, 01:33:41 pm »
Heck... take a while, they are way behind in the version.
One of the reasons why I wanted to change was since updating to the version now in the repo, the date function where, when you type a date such as 23rd, the 'rd' is turned into superscript (I know it's nothing much but it's something I liked) and in the version before the version I have just removed, that function worked perfectly.
This is/was a known bug which many people reported and had since been fixed in the new version.

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13792
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Partial Upgrade
« Reply #9 on: January 13, 2013, 01:37:22 pm »
See above .. I may have been adding "why" they don't update "software" so much in LTS releases ;)

Point is .. there's nothing stopping YOU from updating .. but if THEY do it automatically, it could introduce a bunch of new issues that will really p*ss people off, particularly in a production environment.

Security updates will be automatically added

Software updates will only be added if they either fix MAJOR bugs, or add MAJOR new features that enough people seem to want.

Other than that, software updates will be left for the next release.

Better the devil you know ;)

.
« Last Edit: January 13, 2013, 01:43:35 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #10 on: January 13, 2013, 01:41:58 pm »
On a different matter, check out the screenshot... what's with the 'squiggly writing'?
Could that be one of 1 things, you were hacked or it's to do with my end and I need to re-install something?

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13792
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Partial Upgrade
« Reply #11 on: January 13, 2013, 01:45:13 pm »
That's your end .. the Fekbook "Like" buttons display correctly for me.

[EDIT]

What makes you think we were "hacked" ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #12 on: January 13, 2013, 01:49:26 pm »
Dunno really, just one option!

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13792
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Partial Upgrade
« Reply #13 on: January 13, 2013, 01:51:51 pm »
Try clearing your web browser cache .. then restarting your browser.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Partial Upgrade
« Reply #14 on: January 13, 2013, 02:57:36 pm »
It's not any of the ideas I had, it's Ubuntu. I have just been helping Mrs pooky on her laptop and have noticed the same writing there too.
I'm thinking it's something to do with recent updates...

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal