Author Topic: Peppermint OS3 Alternate language keyboard switching  (Read 1995 times)

0 Members and 1 Guest are viewing this topic.

Offline nerobert

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Peppermint OS3 Alternate language keyboard switching
« on: January 15, 2013, 01:17:35 pm »
Good morning,
First, my thanks to Mark for introducing me to Peppermint OS3 via a post about the Linpus operating system that has been the bane of my life on my Acer Aspire One. I now have a great system.
I am trying to set up a switch between English and Russian keyboard layouts using 'alt_shift' same as had before but I have become lost in the weeds. I can't find how to do it.
I am trying to use a terminal window and commands like 'sudo apt-get install fbxkb' but I seem to be way off the mark.

Has anyone done this before and do they know the correct commands to enter in the window?
Many thanks,
Neil
(Alias - desperate of Telford!)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13587
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #1 on: January 15, 2013, 04:04:15 pm »
If you already have the language installed .. all you need to do is add the "Keyboard Layout Switcher" panel applet to the bottom panel.

Right-click the bottom panel, and select Add / Remove Panel Items .. Click the + Add button .. highlight the Keyboard Layout Switcher and click the + Add button.

Now before you close the next window .. have a look at your bottom panel, the keyboard switcher will be there by your clock .. if you want to move it, use the Up and Down buttons.



To use the Switcher .. just normal (left) click the icon on the panel and it should switch.

If it doesn't .. open a terminal (Ctrl+Alt+T), run this:
Code: [Select]
gedit /etc/default/keyboard
and post the contents of that file here.



I dunno if it will do the Alt+Shift keyboard shortcut  .. but *maybe* we can add that keyboard shortcut later if you really want it.

[EDIT]

OK, to add the Alt+Shift keyboard shortcut to toggle between Russian (ru) and UK English (gb)  keyboards .. you need to add the line:-

@setxkbmap -option grp:alt_shift_toggle "gb,ru"

to the file:-

/etc/xdg/lxsession/Peppermint/autostart 

Then log off and on again (or reboot) for the changes to be applied.

Here's a single command to add that:
Code: [Select]
echo '@setxkbmap -option grp:alt_shift_toggle "gb,ru"' | sudo tee -a /etc/xdg/lxsession/Peppermint/autostart
now log off/on.

If you have the Keyboard Layout Switcher panel applet installed .. you'll also see the flag change.

Reference source (needs modifying as above for Peppermint):
https://help.ubuntu.com/community/Lubuntu/Keyboard

.
« Last Edit: January 15, 2013, 05:47:35 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline nerobert

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
SOLVED: Peppermint OS3 Alternate language keyboard switching
« Reply #2 on: January 16, 2013, 05:17:20 pm »
Fantastic.
Done all that and now have easy switching between the two languages. The keyboard seems to be the right one and .... I have now got the Alt Shift working which is perfect for my needs and ... I can see the flag changes.
Many, many thanks. Great result.
Best wishes.
Neil

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13587
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #3 on: January 16, 2013, 05:32:13 pm »
You're welcome :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #4 on: January 30, 2013, 04:09:09 am »
Great- my question too, though I might have Ukrainian- there are in Ubuntu 12.4 like 10 different Cyrrillic keyboard versions

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #5 on: February 11, 2013, 03:14:35 pm »
Yes, you were right- I didn't add 5 repositories off the screen. Hope that didn't mess up my installation. I did that sudo apt get-update 10 times after every step. There Skype is. Could that have caused my language switching problem too?
R
 
Saved that code you listed in Gedit, and rebooted, but not getting a shred of Cyrillic. The Russian shows checked, that is, installed. It tried to  chose Ukrainian on installation, though it is supposedly Russian (but sold in Ukr), although when you test the keys with Ubuntu, it says Bulgarian, entirely wrong. Guess next step is uninstall and reinstall, but the function of that language selector is so strange that I wonder if I did something wrong. And, for anyone with a a different keyboard (these were popular is Russian world + Chinese too I presume since they have that built in), I would contend keyboard switching is part of an installation. You have all these keys on the keyboard, it's nice to be able to use them.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13587
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #6 on: February 11, 2013, 05:26:25 pm »
You'll have to explain the problem a little better :)

Is only Russian and English installed now ?

And can you post the contents of
Code: [Select]
gedit /etc/default/keyboard
and
Code: [Select]
gedit /etc/xdg/lxsession/Peppermint/autostart  
and
Code: [Select]
gedit ~/.config/lxkeymap.cfg

--
« Last Edit: January 18, 2014, 09:19:53 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #7 on: February 11, 2013, 05:44:13 pm »
Yes only English and Russian - I installed the Russian in the Language Support- it shows checked. I don't need any keystrokes- an icon is fine. The correct code on that additional inserted line is US instead of GB for me, right, or maybe not.!@#$ Tried EN first
Though doesn't look like I have Russian.

# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz
    -----------------------------------------

@lxpanel --profile Peppermint
@xscreensaver -no-splash
@xfce4-power-manager
@pcmanfm --desktop --profile peppermint
@/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
@mintinput1
@xdg-user-dirs-gtk-update
@setxkbmap -option grp:alt_shift_togg le "us,ru"
     -----------------------------------------------------
3rd one is empty


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13587
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #8 on: February 11, 2013, 06:13:24 pm »
You do realise there's a space where there shouldn't be one (in the word toggle) in:-

@setxkbmap -option grp:alt_shift_togg le "us,ru"

and you're still being very confusing .. first you say yes only English and Russian are installed .. then you say "doesn't look like I have Russian" .. which is it ?

and is US/RU what you want .. or GB/RU ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #9 on: February 11, 2013, 07:00:51 pm »
Well so I dumbass do. Removed extra space. Just can be too careful with this gobblygook. I set my system to US english- what I meant was, from your diagnostics, that it didn't look like there was Russian, but it installed over 30 seconds and the language shows checked, apparently they DON'T highlight it unless you make it the system default, really stupid. Or I screwed it up by clicking system-wide setting + can't undo it. And I don't understand just what that top unmovable "English" is doing there. Well's lets try a reboot.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13587
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #10 on: February 11, 2013, 07:40:08 pm »
If you want US/RU .. open a terminal and run:
Code: [Select]
sudo gedit /etc/default/keyboard

and make it read:-

Code: [Select]
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=""
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

SAVE the file .. REBOOT.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Peppermint OS3 Alternate language keyboard switching
« Reply #11 on: February 11, 2013, 11:51:25 pm »
Thanks, all good with that space removed. Now for the Chinese- no I would fall in that sometimes and spend 1/2 hour to get out. Some strange keystroke.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal