Author Topic: Image tearing in Mint 14  (Read 4042 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #30 on: February 02, 2013, 05:50:17 pm »
OK, xfwm4 it is then.

Gimme an hour or so .. having a curry ATM :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2392
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Image tearing in Mint 14
« Reply #31 on: February 02, 2013, 05:56:08 pm »
No problem Mark I'm going out for a few beers soon so I'll follow any instructions in the morning


Many thanks

Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #32 on: February 02, 2013, 06:13:22 pm »
[EDIT]

@ Emegra

If you're not interested in Win7 style window snapping .. there's an easier method of getting compositing and drop shadows, that will also not break keyboard shortcuts here:
http://linuxforums.org.uk/index.php?topic=10662.msg80989#msg80989
thanks to SeZo :)

[END EDIT]

These instructions are for Peppermint 3.

First, add the PPA:
Code: [Select]
sudo add-apt-repository ppa:fossfreedom/xfwm4
Now update your package cache:
Code: [Select]
sudo apt-get update
now install xfwm4, xfwm4-themes, and stiler:
Code: [Select]
sudo apt-get install xfwm4 xfwm4-themes stiler
Now we need to edit a couple of files so they show in the menus .. so run:
Code: [Select]
sudo gedit /usr/share/applications/xfce-wm-settings.desktop
When a file opens with a ton of stuff in it, make it read:-
Quote
[Desktop Entry]
Version=1.0
Type=Application
Name=xfwm4 Window Manager
Comment=Configure window behavior and shortcuts
Icon=xfwm4
Exec=xfwm4-settings %f
Categories=Settings;DesktopSettings;GTK;
StartupNotify=true
Terminal=false

SAVE the file, and exit gedit.

Now back in the terminal run:
Code: [Select]
sudo gedit /usr/share/applications/xfce-wmtweaks-settings.desktop
When a file opens with a ton of stuff in it, make it read:-
Quote
[Desktop Entry]
Version=1.0
Type=Application
Name=xfwm4 Window Manager Tweaks
Comment=Fine-tune window behaviour and effects
Icon=wmtweaks
Exec=xfwm4-tweaks-settings %f
Categories=Settings;DesktopSettings;GTK;
StartupNotify=true
Terminal=false

SAVE the file, and exit gedit.

OK, now go to:-
menu > Preferences > Desktop Session Settings
click the "Advanced Settings" tab
and change:-

Window Manager: openbox-peppermint
to
Window Manager: xfwm4

Click the "OK" button.

Log off, and on again (or reboot).

You should now be using the xfwm4 window manager .. go to:
menu > Preferences > xfwm4 Window Manager Tweaks
then click the "Compositor" tab.

Make sure ALL five of the boxes at the top are ticked.

Click "Close".

You're done .. cairo-dock should now work properly, and you shoud have window drop shadows :)



BTW .. You can change windows borders in
menu > Preferences > xfwm4 Window Manager
then click the "Style" tab .. and select which borders you want down the left hand side.

Window colour themes are still selected in:
menu > Preferences >  Customise Look & Feel


If you decide you DO want Win7 style snapping .. go to:
menu > Preferences > xfwm4 Window Manager
then click the "Advanced" tab.

Tick both boxes under "Windows Snapping"

If you want to know what Win7 style window snapping is .. watch this video:

<a href="http://youtube.googleapis.com/v/19X0gng_-qk" target="_blank" class="new_win">http://youtube.googleapis.com/v/19X0gng_-qk</a>
« Last Edit: February 02, 2013, 10:35:50 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1421
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Image tearing in Mint 14
« Reply #33 on: February 02, 2013, 07:03:27 pm »
If you are not quite ready for the switch to the XFCE window manager (instead of openbox) then you could try Compton
I am quite impressed with compton as a composite manager (works well with openbox+razor-qt on Arch)
It is a fork from xcompmgr-dana (which is a fork istelf from xcompmgr).
See here for Lubuntu
PPA for *buntu 12.10: https://launchpad.net/~richardgv/+archive/compton
or look here

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #34 on: February 02, 2013, 07:26:34 pm »
Dunno if it's just me, but I don't seem to be able to get the drop shadow effect with xcompmgr or compton in Peppermint 3
(BTW, that PPA also contains a version of compton for 12.04 .. which is what Peppermint 3 is based on)

Here's what I tried:
Code: [Select]
xcompmgr -c -r10 -F -f -D5 -C -o0.8 &
or
Code: [Select]
compton -c -r10 -F -f -D5 -C -o0.8 &
(among other settings)

Nothing ???

Though cairo-dock works .. so compositing is obviously enabled
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1421
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Image tearing in Mint 14
« Reply #35 on: February 02, 2013, 09:23:27 pm »
Dunno..
I am running with compton -c and it has shadows.
Also just for try installed on netbook which is openbox+LXDE+Arch and just works.
So decided to leave it on and put @compton -c into /etc/xdg/lxsession/LXDE/autostart

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #36 on: February 02, 2013, 10:04:04 pm »
OK, I was obviously trying to be too clever .. that works (drop shadows) :)

However ..

When I fire up cairo-dock .. I now get a gradiated shadow effect across the bottom (inch or so) of my screen .. I don't get that with xfwm4 ???

It's as if the black box you get without compositing, is now a gradiated semi-transparent shadow .. if you get my meaning (?)

Pity, because it would be nice to have the keyboard shortcuts back .. I can probably easily solve these keyboard shortcuts, I just need to take a looksee at default Xfce4 configs .. one day I may even get round to that ;)

To tell the truth I quite like the configurability of xfwm4 .. but can see compton is probably lighter, and it would certainly be an easier fix if it weren't for that weird shadow effect at the bottom of screen.

and just for completeness
xcompmgr -c
doesn't give me drop shadows at all .. go figure ???
« Last Edit: February 02, 2013, 10:07:32 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1421
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Image tearing in Mint 14
« Reply #37 on: February 02, 2013, 10:09:48 pm »
Quote
When I fire up cairo-dock .. I now get a gradiated shadow effect across the bottom of my screen ..

Try:
Code: [Select]
compton -cC

Quote
-C    When -c is specified, attempts to avoid painting shadows on panels and docks.


Source http://rpm.pbone.net/index.php3/stat/45/idpl/19807387/numer/1/nazwa/compton

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #38 on: February 02, 2013, 10:12:14 pm »
Sh*t .. removed the PPA .. Ill re add it :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #39 on: February 02, 2013, 10:20:27 pm »
OK .. that did the trick .. Cheers :)

I'll type that up for Emegra .. becuase the @compton -cC goes in /etc/xdg/lxsession/Peppermint/autostart in Peppermint.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #40 on: February 02, 2013, 10:27:59 pm »
OK, an easier way of adding compositing and drop shadows (which won't break keyboard shortcuts) ..
(be aware this will NOT give you Win7 style window snapping .. for that you'll have to use the xfwm4 instructions above)

Open a terminal and run:
Code: [Select]
sudo add-apt-repository ppa:richardgv/compton
then
Code: [Select]
sudo apt-get update
then
Code: [Select]
sudo apt-get install compton
then
Code: [Select]
sudo gedit /etc/xdg/lxsession/Peppermint/autostart
and when a file opens with a few lines already in it .. add a single NEW line at the bottom that reads:-

Quote
@compton -cC

SAVE the file .. then log off/on again (or reboot)

Thank SeZo for that ;)



Personally, I'm going to stick with xfwn4, and figure out the Xfce4 keyboard shortcut configs .. I like the rounded window corners, it's (GUI) config options, and the window snapping.

But SeZo's method is certainly easier, doesn't break anything, and is possibly lighter :)

--
« Last Edit: February 02, 2013, 11:07:15 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2392
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Image tearing in Mint 14
« Reply #41 on: February 03, 2013, 08:48:08 am »
Hi Guys

I followed SeZos method and it works perfectly thank you both, but you're not off the hook yet, as I mentioned on my first post I tried using Cairo Dock on my Grand-daughters PC but it's slow and sluggish by comparison to this PC, is there any things I can try to speed up the Cairo Dock effects or would i be wasting my time trying

EDIT Spoke too soon it did work perfectly until I tried different views, I tried parabolic and now I can't do anything, right click no longer gets me back to the configuration window, no apps will launch and I now have this horrible dock slached across my screen I can do nothing with. I tried uninstalling and re-installing but iwhen I re-installed it defaulted back to parabolic and back to square one ,I assume there must be a config file somewhere I can edit to turn off parabolic, any ideas ?



Many thanks

Graeme
« Last Edit: February 03, 2013, 09:48:40 am by Emegra »
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13187
  • Karma: 321
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Image tearing in Mint 14
« Reply #42 on: February 03, 2013, 11:38:35 am »
Code: [Select]
sudo killall cairo-dock
then
Code: [Select]
mv -v ~/.config/cairo-dock ~/.config/cairo-dock-old

Now fire up cairo-dock .. it should be back to defaults.



If your daughters PC is struggling with cairo-dock with its default settings, I'd guess her PC just aint up to iit .. have you tried the "cairo-dock (no OpenGL)" instead ?



Quote
iwhen I re-installed it defaulted back to parabolic and back to square one

Simply uninstalling something leaves the configuration files behind (so you can reinstall later with your tweaks still applied) .. you need to
sudo apt-get remove --purge <packagename>

or "Mark for COMPLETE Removal" (in Synaptic) to get rid of the configs too.

--
« Last Edit: February 03, 2013, 11:52:15 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2392
  • Karma: 53
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Image tearing in Mint 14
« Reply #43 on: February 03, 2013, 04:08:22 pm »
Quote
If your daughters PC is struggling with cairo-dock with its default settings, I'd guess her PC just aint up to iit .. have you tried the "cairo-dock (no OpenGL)" instead ?

I tried it in with no Open GL and that made a huge difference some effects are missing but that's ok, the problem now is that I can't get it to stop starting up with Open GL, I unchecked Cairo Dock (with Open GL) in the desktop sessions dialogue box but it still starts up with Open GL regardless and I can see nothing in the Cairo Dock configuration to change to no Open GL, this seems to be a problem with many things in Linux I've discovered , it just doesn't do what it says it will do or not do whatever is the case, in spite of unchecking the box to stop Cairo Dock opening at startup it still does it and in synaptic in spite of selecting "mark for complete removal" it obviously doesn't completely remove it, maybe it's just me.

Sorry if this sounds like a rant but I just get frustrated when I have to come on here seeking help to do what should be simple things

Anyway can you tell me please how I can get Cairo Dock to startup with no Open GL


Many thanks


Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1421
  • Karma: 118
  • Gender: Male
    • View Profile
    • Awards
Re: Image tearing in Mint 14
« Reply #44 on: February 03, 2013, 06:20:07 pm »
Quote
Anyway can you tell me please how I can get Cairo Dock to startup with no Open GL

You can specify which backend (open-gl or cairo) it will use:

Run with OpenGL backend
Code: [Select]
cairo-dock -o

Run with Cario backend
Code: [Select]
cairo-dock -c

It will just be the case of finding out where it is getting started from at boot time

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal