Author Topic: No audio over HDMI lubuntu 12.10  (Read 4335 times)

0 Members and 1 Guest are viewing this topic.

GEARHEAD_TI

  • Guest
No audio over HDMI lubuntu 12.10
« on: February 16, 2013, 03:53:34 pm »
Hello all,

new problem of the day:

No audio over nvidia hdmi, I have looked at alsamixer and it recognises there is audio on my gfx card but I cannot change the volume, it is always set to 00.

I am trying to set this box up as an XBMC unit for my TV.

I went through a few tutorials I found online and still no luck.

Having to make this breif as my daughter is trying to type on my keyboard so sorry for any typos.

oh and the card is an NVIDIA 8400GS to be precise this one:
http://www.ebay.co.uk/itm/Palit-Nvidia-GeForce-8400GS-SUPER-1GB-DDR3-HDMI-Graphics-Card-PCI-E-/251225189313?pt=UK_Computing_Computer_Components_Graphics_Video_TV_Cards_TW&hash=item3a7e302bc1

Cheers,

GEARHEAD


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14435
  • Karma: 357
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No audio over HDMI lubuntu 12.10
« Reply #1 on: February 16, 2013, 04:27:46 pm »
What's the output from:
Code: [Select]
aplay -l

and if you run:
Code: [Select]
alsamxer
then hit F6 .. what's listed ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

GEARHEAD_TI

  • Guest
Re: No audio over HDMI lubuntu 12.10
« Reply #2 on: February 16, 2013, 04:29:24 pm »
Hi Mark

aplay -l:

xbmc@xbmc-lounge:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

alsamixer and F6:

0 HDA Intel
1 HDA nvidia

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14435
  • Karma: 357
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No audio over HDMI lubuntu 12.10
« Reply #3 on: February 16, 2013, 04:40:08 pm »
What happens if you fire up:
Code: [Select]
alsamixer
Hit F6 .. then select 1 HDA nvidia
?

Also if you run:
Code: [Select]
pavucontrol
and go to "Output Devices" .. can you select the HDMI output there ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

GEARHEAD_TI

  • Guest
Re: No audio over HDMI lubuntu 12.10
« Reply #4 on: February 16, 2013, 05:58:53 pm »
alsamixer-can't change the volume but it is visible (there appear to be 4 volumes that can't be changed)

installed pavucontrol and it tells me there is something wrong with the pulse server (it may not be installed)

do i need to instal pulse audio?

GEARHEAD

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14435
  • Karma: 357
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No audio over HDMI lubuntu 12.10
« Reply #5 on: February 16, 2013, 07:05:49 pm »
Code: [Select]
sudo apt-get install --reinstall pulseaudio pulseaudio-utils pavucontrol

The I think you need to reboot.

--
« Last Edit: February 16, 2013, 07:08:25 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

GEARHEAD_TI

  • Guest
Re: No audio over HDMI lubuntu 12.10
« Reply #6 on: February 16, 2013, 09:52:15 pm »
ok, so reinstalled pulse audio and extras, only shows the "built in analogue stereo" as the only output.

Had a play around to see if I could find any additional options but to no success.

Will continue having a look until you reply at another time :)

GEARHEAD

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14435
  • Karma: 357
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No audio over HDMI lubuntu 12.10
« Reply #7 on: February 16, 2013, 09:57:18 pm »
Which nvidia drivers are you using ?

what's the output from:
Code: [Select]
sudo lshw -C display

is there NO audio through HDMI at all .. or is there only no audio from XBMC ?



Can you also run this command:
Code: [Select]
wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh
hit "Enter" to select <OK>
hit the "Left Arrow" key to select <UPLOAD / SHARE> .. and hit "Enter"
hit "Enter" to select <YES>
hitr "Enter" to select <EXIT>

Then post the link that's reported in the terminal.

--
« Last Edit: February 16, 2013, 10:25:13 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

GEARHEAD_TI

  • Guest
Re: No audio over HDMI lubuntu 12.10
« Reply #8 on: February 18, 2013, 10:57:51 am »
Hi Mark,

I have just discovered that there is a pre-made xbmc distro (xbmcbuntu) that I completely forgot about.

I will install that and see if this helps (I have installed it once already but it somehow copied across the previous config from lubuntu)

I will report back and let you know what the new results are :)

GEARHEAD

GEARHEAD_TI

  • Guest
Re: No audio over HDMI lubuntu 12.10
« Reply #9 on: February 19, 2013, 09:52:05 am »
OK, final conclusion to this.....for some reason the bios on this machine has an audio controller that can disable audio to different areas of the machine.

Moral of the story, its not always a problem with linux, just the way HP designs this shizzle.

Cheers guys,

GEARHEAD

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14435
  • Karma: 357
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No audio over HDMI lubuntu 12.10
« Reply #10 on: February 19, 2013, 10:43:11 am »
Oh well, at least you solved it :)

and got to try XBMCbuntu at the same time ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

GEARHEAD_TI

  • Guest
Re: No audio over HDMI lubuntu 12.10
« Reply #11 on: February 21, 2013, 02:23:05 pm »
Yeah, I am quite impressed with XBMCbuntu, good speed, works really well out of the box and very refined, lots of customization directly from the Desktop Environment, gets the drivers for everything on install.

Have to say 9.5/10.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal