Author Topic: CYBERMAX MD41257 fails to boot on 50% of start ups. Solved  (Read 1917 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13999
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups.
« Reply #15 on: March 18, 2013, 10:06:04 pm »
Quote
a) some kind of weird acpi issue .. try adding acpi_osi=Linux as a kernel boot parameter.      How do I change the boot parameter?


OK, the following instructions are for a single boot ONLY .. so you'll have to do this EVERY time you boot .. but if it works, we can automate the procedure.
(I'm not automating it now in case it stops your PC from booting, or causes other issues .. any problems and a reboot will clear the setting)

Turn ON your laptop, and as soon as your BIOS POST screen disappears, press the SHIFT key and hold it, until you are presented with the GRUB menu .. SIMILAR to this:
(you won't have long to hit the shift key, and the timing can be a little awkward, so it may even be easier to hit AND HOLD the Shift key DURING the BIOS POST .. ie. immediately after turning on your PC)


Select the 'default' Ubuntu kernel (usually the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:


Press DOWN ARROW until you get to the line that starts with:

Quote
linux /boot


and press the END key to position the cursor at the end of the that line... it *usually* ends with “quiet splash”.

Now you can enter additional kernel boot options... so add the acpi_osi=Linux option instead of nomodeset in the above screenshot .. so it now reads:

Quote
quiet splash acpi_osi=Linux

(doesn't matter if it moves down a line, as long as there is a space between splash and nomdeset)

Now hit Ctrl+X to boot.

and test doing this for a few boots to see if it makes any difference.

BTW, if this works, it will only work for a single boot and will need re-applying at the next boot .. but if it solves the issue, we'll make it permanent :)



Quote
Disk manager says there are 7 bad sectors on the HD how do I fix them?


Disk Manager ? .. if you mean Disk Utility ..

You can't .. they are damaged .. but depending on what EXACTLY Disk Utility is saying, they may already have been marked as not to be written to any more.

The bad news .. when a HDD starts getting bad sectors the drive is usually going to get worse.

If you can boot a LiveUSB without issue EVERY time .. I'd say the problem is the hard drive.
« Last Edit: March 18, 2013, 10:07:36 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 685
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups.
« Reply #16 on: March 19, 2013, 11:06:00 am »
Changing the line in the boot sequence seems to have solved the issue as has booted 6 times now with no problem.  How do we make it permanent?

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13999
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups.
« Reply #17 on: March 19, 2013, 11:55:49 am »
OK, you need to edit /etc/default/grub .. then update GRUB.

First backup /etc/default/grub .. just in case:
Code: [Select]
sudo cp -v /etc/default/grub /etc/default/grub.backup

Now open /etc/default/grub for editing:
Code: [Select]
sudo gedit /etc/default/grub

Find the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

visually check the line to make sure it's correct.

SAVE the file and close gedit.

Back in the terminal run:
Code: [Select]
sudo update-grub

Done :)

--
« Last Edit: March 19, 2013, 11:58:11 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 685
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups.
« Reply #18 on: March 19, 2013, 12:03:24 pm »
I will let you know what happens over the next few days.

Thanks.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13999
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups.
« Reply #19 on: March 19, 2013, 12:07:15 pm »
Yeh please do, it will be interesting to know if that worked :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 685
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups.
« Reply #20 on: March 21, 2013, 12:05:24 pm »
Well so far fingers crossed the laptop boots all the way every time.  So it looks like it was a problem with acpi.......... I will leave it till next week before closing.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 685
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups.
« Reply #21 on: April 16, 2013, 04:53:50 pm »
AS there have been no problems since my last post I think we can call this solved.

Thanks.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13999
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: CYBERMAX MD41257 fails to boot on 50% of start ups. Solved
« Reply #22 on: April 16, 2013, 04:58:44 pm »
Great news .. cheers for marking the topic solved :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal