Author Topic: Problem re-installing Audacity after tyring to remove a broken install of MATE  (Read 3387 times)

0 Members and 1 Guest are viewing this topic.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
MORE problems trying to RE-INSTALL Audacity.

I get this after trying to install Audacity;

Depends: audacity-data (= 2.0.1-1~ppa1) but 2.0.3-0ubuntu1~precise1 is to be installed
          Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.6ubuntu0.12.04.1+medibuntu1 is to be installed
          Depends: libavformat-extra-53 (>= 4:0.8-1~) but 4:0.8.6ubuntu0.12.04.1+medibuntu1 is to be installed
          Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.6ubuntu0.12.04.1+medibuntu1 is to be installed
          Depends: libc6 (>= 2.15) but 2.15-0ubuntu10.4 is to be installed
          Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
          Depends: libglib2.0-0 (>= 2.12.0) but 2.32.3-0ubuntu1 is to be installed
          Depends: libgtk2.0-0 (>= 2.8.0) but 2.24.10-0ubuntu6 is to be installed
          Depends: libportaudio2 (>= 19+svn20101113-2~) but 19+svn20111121-1 is to be installed
          Depends: libstdc++6 (>= 4.4.0) but 4.6.3-1ubuntu5 is to be installed
          Depends: libwxbase2.8-0 (>= 2.8.12.1) but 2.8.12.1-6ubuntu2 is to be installed
          Depends: libwxgtk2.8-0 (>= 2.8.12.1) but 2.8.12.1-6ubuntu2 is to be installed

I don't know what to write to install them...

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
pooky2483@pooky2483-ubuntu12:~$ sudo apt-get install audacity
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 audacity : Depends: audacity-data (= 2.0.1-1~ppa1) but 2.0.3-0ubuntu1~precise1 is to be installed
E: Unable to correct problems, you have held broken packages.
pooky2483@pooky2483-ubuntu12:~$

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libkface-data mate-netspeed libkvkontakte1 libkface1 kipi-plugins-common
  libopencv-legacy2.3 python-mate-menu mozo mate-user-share mate-text-editor
  mate-bluetooth libmediawiki1 libopencv-video2.3 digikam-data
  libmatebluetooth mate-sensors-applet mate-window-manager mate-system-tools
  libmatesensorsappletplugin libkgeomap-data libkgeomap1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pooky2483@pooky2483-ubuntu12:~$


It happens when I get a distribution update...
« Last Edit: June 17, 2013, 10:47:22 pm by pooky2483 »

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Sorted it;
I copied http://linuxforums.org.uk/index.php?topic=10638.msg80551#msg80551

Changed gimp for audacity
sudo apt-get remove --purge audacity-data
sudo apt-get install audacity

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13592
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Sorry pooky .. I was kinda busy then .. glad to hear you got it sorted :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Sorry pooky .. I was kinda busy then .. glad to hear you got it sorted :)

No probs, I don't expect you and you alone to come to the rescue every time I or someone else has a problem.

I did a search on my own posts for 'broken packages' to see how I fixed it before but couldn't find how we sorted it out before. The bit where you said install the 'libs' separately. But couldn't find it and still don't know how, I tried different ways, such as 'sudo apt-get install' (then the lib) but that didn't work for some reason.

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal