Author Topic: Rockbox install  (Read 1328 times)

0 Members and 1 Guest are viewing this topic.

Offline willie

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Rockbox install
« on: April 07, 2013, 02:00:10 pm »
I'm trying to install the Rockbox utility, but at the 'install' stage I'm getting an error message “Could not open Ipod: permission denied”. I understand I need to get permission by using sudo or by logging in as root. I've searched the Rockbox site and forums but can't find a relevant thread / answer -- probably because it's more of a simple linux issue... but still apparently too complex for me... I don't know how to do this.

Would one of you chaps be good enough to point me in the right direction.

Thanks

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13749
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Rockbox install
« Reply #1 on: April 07, 2013, 03:07:17 pm »
I take it you have rbutil installed ?

Which distro/version are you using ? .. if Ubuntu/Mint ..

try running it as root from a terminal:-

If it's a command line utility:
Code: [Select]
sudo rbutil

if it's a GUI application:
Code: [Select]
gksudo rbutil

If you haven't already got rbutil installed (in Linux) .. it's in the getdeb repos.

If you're using something other than Ubuntu/Mint .. let us know what.

--
« Last Edit: April 07, 2013, 03:11:45 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline willie

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Rockbox install
« Reply #2 on: April 07, 2013, 04:05:11 pm »
I have installed the relevant download from this page:

http://www.rockbox.org/wiki/RockboxUtility

I'm able to start the 'graphical interface' – http://www.rockbox.org/wiki/GraphicalInstall

I selected my media device manually because the 'auto detect' didn't work – the guide says “If the Utility can't find the player in linux, try running it as root”, I don't know how to to this.

It's then at the next 'install' stage that I  get the error message “Could not open Ipod: permission denied”.

I've tried sudo RockboxUtility and now sudo rbutil and gksudo and get a 'command not found' message.

I'm using Ubuntu 12.04 32bit

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13749
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Rockbox install
« Reply #3 on: April 07, 2013, 04:47:52 pm »
I take it you've downloaded a tar.bz2 from the above links called RockboxUtility-v1.3.1.tar.bz2 ?

then unpacked a file called RockboxUtility ?

If that's what you've done .. to run the application as root ..

Let's say RockboxUtility is on your desktop.

Open a terminal (Ctrl+Alt+T) and run:
Code: [Select]
gksudo ~/Desktop/RockboxUtility

if it's somewhere other than your desktop .. either put it on the desktop, or adjust the path in the above command.



[EDIT]

Another option would be to permanently install the Rockbox Utility, by downloading and installing the correct .deb for your architecture from here

32bit -
http://ftp.heanet.ie/mirrors/www.getdeb.net/getdeb/ubuntu/pool/apps/r/rbutil/rbutil_1.3.1-1~getdeb1_i386.deb

64bit -
http://ftp.heanet.ie/mirrors/www.getdeb.net/getdeb/ubuntu/pool/apps/r/rbutil/rbutil_1.3.1-1~getdeb1_amd64.deb

But you *may* still have to run it as root.
« Last Edit: April 07, 2013, 04:57:58 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline willie

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Rockbox install
« Reply #4 on: April 07, 2013, 05:17:25 pm »
Yep, that's what I did, although I unpacked it into Home and was getting the 'command not found'. I guess I was 'looking' in / from the wrong directory. Now unpacking it to desktop and following your instructions nothing happens in the terminal, it just returns the command line.  :-\

By double clicking the RockboxUtility file the user interface opens, it was here I had the original permission error message.

I've just ejected the media device and reconnected it and now it says "Mountpoint does not exist".

I'm now thinking it is an issue with Rockbox, or more likely something I'm doing wrong. I may start afresh point by point.

I'll also have a look at your edit

Thanks


Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13749
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Rockbox install
« Reply #5 on: April 07, 2013, 05:35:12 pm »
What is the output from:
Code: [Select]
uname -a
?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline willie

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Rockbox install
« Reply #6 on: April 07, 2013, 05:41:37 pm »
First... I've installed the .deb and can open the 'user interface' from the icon in the side bar, but still have the same issue with 'ipod permission' and 'mountpoint' -- I think identifying the mount point is the problem.

uname -a returns

Linux neil-Latitude-D810 3.2.0-39-generic #62-Ubuntu SMP Wed Feb 27 22:05:17 UTC 2013 i686 i686 i386 GNU/Linux



Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13749
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Rockbox install
« Reply #7 on: April 07, 2013, 07:47:56 pm »
OK, first see if starting it with elevated privileges helps:
Code: [Select]
gksudo RockboxUtility

If that doesn't help .. do you know where it's being mounted ?

With the iPlod plugged in .. What's the output from:
Code: [Select]
mount
and
Code: [Select]
sudo fdisk -l
?
« Last Edit: April 07, 2013, 07:58:30 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline willie

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Rockbox install
« Reply #8 on: April 07, 2013, 09:45:38 pm »
You are a star.

I had previously tried gksudo with no joy, but with the .deb version it worked fine, launched the utility, detected the ipod and installed successfully.

Yet it didn't work from the icon launcher.

Can't see why that would be.

Thanks for your perseverance in helping. I forget stuff quicker than I can learn it these days.  ;)

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13749
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Rockbox install
« Reply #9 on: April 07, 2013, 10:29:20 pm »
You're welcome :)

You can add "gksudo" to the launcher if you'd like ?

just run:
Code: [Select]
sudo gedit /usr/share/applications/rbutil.desktop

Find the line:-
Code: [Select]
Exec=RockboxUtility

and change it to:-
Code: [Select]
Exec=gksudo RockboxUtility

SAVE the file.

Now it should prompt for a password when launched.

--
« Last Edit: April 07, 2013, 10:35:52 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal