Author Topic: wifi connection to BT Home Hub  (Read 2097 times)

0 Members and 1 Guest are viewing this topic.

Offline forsate

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
wifi connection to BT Home Hub
« on: April 16, 2013, 10:26:10 am »
I use a dual-bootable Dell Inspiron 530 (Windows Vista SP2 and OpenSUSE 12.3) connected by wifi to BT Home Hub 3 through an Edimax Nano adapter, which uses a RealTek rtl8192cu driver.  Everything works well for Vista but connecting with OpenSUSE is almost uselesS.  Occasionally I do manage to establish an internet connection, but when I do it usually drops off after a short time and cannot be reestablished.  In all cases dmesg shows that the connection on wlan0 authenticates and associates, which I have always understood to be a necessary and sufficient condition for the connection to be established.  Before I loaded the appropriate compat-wireless package I had been finding that the connection had been broken by wlan0 dissociating; this always showed up in dmesg.  The usual commands (iwconfig, ifstatus and the like) seem to indicate that all is well, although I do not have the expertise to understand all of the output.

This is a long-standing issue that I have raised in a number of forums (not this one - I have only recently come across it), but interest has always petered out, usually when I refer to BT Home Hub.  I suspect that the responders are all US-based and not familiar with this router.  Over time I have tinkered with OpenSUSE and other distros and the wifi connection has always been problematical to the extent that I have been using Linux less and less because of my inability to establish a reliable internet connection.  The best I ever achieved was using a Speedtouch wifi adapter and router (at one time my ISP was Virgin Media) before the wifi adapter packed up.

Can anyone help?  BT's own technical support claim that they do not support Linux.  Perhaps I need to press them harder on this, assuming that compliance with 802.11b/g/n should be independent of the OS.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13251
  • Karma: 323
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: wifi connection to BT Home Hub
« Reply #1 on: April 16, 2013, 12:30:08 pm »
Hi forsate, and welcome to the forum :)

You may want to try opting out of the BT FON wifi (where your router acts as a wifi hotspot for other BT customers) .. it plays havoc with wireless.
http://btsupport.custhelp.com/app/answers/detail/a_id/12958

You may want to read this topic:
http://linuxforums.org.uk/index.php?topic=10570.0
particularly towards the end.

Effectively your HomeHub3 has 2 wireless access points.

1 = Your wireless LAN
2 = A shared BT FON wifi hotspot for other BT customers

This often confuses the wireless connection.

When you opt out, (after a delay) BT should turn off the second access point in your HomeHub3



Have you tried the swenc=1 option for the rtl8192cu module (driver) ?

Or compiling the driver directly from Realtek ?

--
« Last Edit: April 16, 2013, 12:47:44 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline forsate

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: wifi connection to BT Home Hub
« Reply #2 on: April 16, 2013, 02:47:11 pm »
Thanks for getting back to me, Mark.  I'll take your points one at a time:
  • I've just opted out of BT wifi.  BT tell me I'll have to wait up to 48 hours to ensure that the hotspot is disabled.  That can only be a temporary arrangement, however, as my daughter and son-in-law visit regularly and use wifi to connect to their respective offices.
  • Not sure which bit of http://linuxforums.org.uk/index.php?topic=10570.0 you wanted me to take on board.
  • Tried setting the swenc=1 parameter.  It made no difference.  What is it supposed to do?
  • I had tried downloading the rtl8192cu driver from Realtek but it would never compile; there appeared to be something missing from it.  I've just checked the website and it appears that the last Linux kernel they catered for is 3.0.8, which is way behind what is used in OpenSUSE 12.3 (3.7).  Other forums I have been into tend to discount vendors' Linux drivers anyway, recommending compat-wireless.  Certainly that gets closest to making the thing work; all the way up to wlan0 association as I described in my original post but somehow failing to make the final step.

I'll get back to you on whether or not the BT wifi opt-out works, but in the meantime if you have any other suggestions on how to get round that obstacle for the reason I stated above I would be grateful.  But I guess I could set them up with access to the Home Hub by giving them the network password.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13251
  • Karma: 323
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: wifi connection to BT Home Hub
« Reply #3 on: April 16, 2013, 04:46:45 pm »
Quote
Not sure which bit of http://linuxforums.org.uk/index.php?topic=10570.0 you wanted me to take on board.


It was really just to show you it worked for someone .. but I suppose you could try without encryption or with WEP (temporarily), just to test.

Quote
Tried setting the swenc=1 parameter.  It made no difference.  What is it supposed to do?


It disables the hardware decryption and leaves decryption to software.

See:
Code: [Select]
modinfo rtl8192cu
for info

Quote
But I guess I could set them up with access to the Home Hub by giving them the network password.


Yeh, you'll have to .. or just cut them off  :o

Quote
I'll get back to you on whether or not the BT wifi opt-out works


Please do .. the more info on this problem the better :)

--
« Last Edit: April 16, 2013, 04:49:47 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline forsate

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: wifi connection to BT Home Hub
« Reply #4 on: April 18, 2013, 03:49:16 pm »
Many thanks for your helpful responses, Mark.

Opting out of BT wifi didn't make any difference, so I've switched it back on.  Whatever the impact on my problem, there is more for me to be gained by being able to use it in other contexts.  Apart from the issue of others being able to use it, it is useful to be able to use it for our own mobile devices away from Home.  One thought strikes me on this, however; how do BT know these devices belong to members of the BT wifi community?  We haven't told them, and how do they know who is using them?

Anyway, back to the original problem; have you any other thoughts on what I might try?

Forsate

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13251
  • Karma: 323
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: wifi connection to BT Home Hub
« Reply #5 on: April 18, 2013, 03:51:05 pm »
Have you tried WEP (or with security off altogether) instead of WPA .. just as a test ?

If you live in an area with multiple routers overlapping .. have you tried simply changing the wireless channel in the router ?
« Last Edit: April 18, 2013, 03:52:49 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline forsate

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: wifi connection to BT Home Hub
« Reply #6 on: April 22, 2013, 12:07:20 pm »
Changing the channels makes no difference.  I had wondered whether the Smart Wireless setting might have been confusing Linux if the Home Hub was changing channels in order to find the best one, but that does not seem to be the problem.

However, switching off encryption does allow me to make and maintain a connection - not that I would want to leave things in that state for longer than it takes to do some testing.  I haven't tried WEP; as I understand it WEP is not a good solution for permanent use.  I have now gone back to the BT recommended setting of WPA/WPA2.

I've taken a bit of time with this to ring the changes and convince myself that it is the WPA encryption that seems to be causing the problem.  Where do I go now?

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13251
  • Karma: 323
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: wifi connection to BT Home Hub
« Reply #7 on: April 22, 2013, 12:21:25 pm »
Just as a matter of interest .. have you tried installing wicd and using that to configure your connection(s) instead of NetworkManager (or whatever openSUSE uses) ?



WEP is certainly easier to crack than WPA/WPA2, so it all depends on how much you trust your neighbours, and what their skill level is .. WPA/WPA2 will NOT protect you from a determined attacker, only not using wireless at all can do that ;)

IMHO, 128bit WEP is sufficient for most home environments .. but depends on your level of paranoia :)

--
« Last Edit: April 22, 2013, 12:30:58 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal