Author Topic: Sane driving me insane  (Read 7557 times)

0 Members and 1 Guest are viewing this topic.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #60 on: April 25, 2013, 08:00:20 pm »
ip address= 192.168.2.3
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14302
  • Karma: 356
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sane driving me insane
« Reply #61 on: April 25, 2013, 08:07:02 pm »
Run:
Code: [Select]
sudo gedit /etc/sane.d/saned.conf

and remove (or comment out)  the line that reads:-

192.168.255.0/24

Save the file and close gedit

then run:
Code: [Select]
sudo gedit /etc/sane.d/net.conf

and remove (or comment out)  the 2 lines that read:-

localhost
 127.0.0.1


Save the file and close gedit.

run:
Code: [Select]
sudo service saned restart



on the CLIENT run:
Code: [Select]
gedit /etc/sane.d/net.conf

and post the contents.

--
« Last Edit: April 25, 2013, 08:09:35 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #62 on: April 25, 2013, 08:12:19 pm »
Code: [Select]
# This is the net backend config file.

## net backend options
# Timeout for the initial connection to saned. This will prevent the backend
# from blocking for several minutes trying to connect to an unresponsive
# saned host (network outage, host down, ...). Value in seconds.
 connect_timeout = 20

## saned hosts
192.168.2.3
# Each line names a host to attach to.
# If you list "localhost" then your backends can be accessed either
# directly or through the net backend.  Going through the net backend
# may be necessary to access devices that need special privileges.
# localhost
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14302
  • Karma: 356
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sane driving me insane
« Reply #63 on: April 25, 2013, 08:16:15 pm »
on the client run:
Code: [Select]
sudo gedit /etc/sane.d/net.conf

and change:-

connect_timeout = 20

to

connect_timeout = 60

making sure you also remove the space from the beginning of that line as well as changing it to 60

SAVE the file.

try xsane on the client again.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #64 on: April 25, 2013, 08:18:32 pm »
Quote
try xsane on the client again.

Still no devices available :(
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14302
  • Karma: 356
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sane driving me insane
« Reply #65 on: April 25, 2013, 08:22:47 pm »
on the client .. what is returned by:
Code: [Select]
telnet 192.168.2.3 6566
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #66 on: April 25, 2013, 08:23:43 pm »
Code: [Select]
chloe@Linux2 ~ $ telnet 192.168.2.3 6566
Trying 192.168.2.3...
telnet: Unable to connect to remote host: Connection refused
chloe@Linux2 ~ $
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14302
  • Karma: 356
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sane driving me insane
« Reply #67 on: April 25, 2013, 08:29:29 pm »
on the server, what's the contents of
Code: [Select]
gedit /etc/xinetd.d/saned
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #68 on: April 25, 2013, 08:31:05 pm »
Code: [Select]
service sane-port
{
port = 6566
socket_type = stream
server = /usr/sbin/saned
protocol = tcp
user = saned
group = saned
wait = no
disable = no
}
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14302
  • Karma: 356
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sane driving me insane
« Reply #69 on: April 25, 2013, 08:32:36 pm »
on the server what's the output from:
Code: [Select]
sudo service xinetd restart
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #70 on: April 25, 2013, 08:36:53 pm »
Code: [Select]
graeme@Linux3 ~ $ sudo service xinetd restart
[sudo] password for graeme:
xinetd stop/waiting
xinetd start/running, process 30433
graeme@Linux3 ~ $
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14302
  • Karma: 356
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sane driving me insane
« Reply #71 on: April 25, 2013, 08:41:19 pm »
still nothing ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #72 on: April 25, 2013, 08:45:37 pm »
Sorry Mark I didn't realise you were waiting on a response from me.

Unfortunately client still wont connect

In case it means anythink I read somewhere during this project that the client wont connect if you have more that one scanner program installed, I have 2 on the Client PC,

Could that be our problem ?
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14302
  • Karma: 356
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sane driving me insane
« Reply #73 on: April 25, 2013, 08:49:58 pm »
not as far as I know .. I have simple-scan and xsane.

there's something odd in that telnet output.

I received something like -

connection terminated by host

when i had the wrong permissions for saned

and telnet just connected and sat at a

>

prompt when it worked.

"Connection refused" sounds like a firewall .. are you running a firewall on the server ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online Emegra

  • Hero Member
  • *****
  • Posts: 2731
  • Karma: 55
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sane driving me insane
« Reply #74 on: April 25, 2013, 08:52:53 pm »
Quote
"Connection refused" sounds like a firewall .. are you running a firewall on the server ?

Not that I'm aware of, I've certainly never altered any firewall settings, so i assume the firewall is still in it's default state (if there is a firewall)
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal