Author Topic: Mint 14.1 Not recognizing my Andriod device.  (Read 5666 times)

0 Members and 1 Guest are viewing this topic.

Offline Toonman

  • Hero Member
  • *****
  • Posts: 873
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #15 on: April 28, 2013, 08:29:18 pm »
Yes it was.

dmesg | tail -n 40
[12643.821809] scsi 14:0:0:0: >Direct-Access     Seagate  FreeAgentDesktop 100D PQ: 0 ANSI: 4
[12643.823962] sd 14:0:0:0: >Attached scsi generic sg6 type 0
[12643.842769] sd 14:0:0:0: >[sdf] Spinning up disk...
[12647.976122] usb 2-3: >new high-speed USB device number 18 using ehci_hcd
[12648.109024] usb 2-3: >Dual-Role OTG device on non-HNP port
[12648.109145] usb 2-3: >can't set HNP mode: -32
[12648.224094] usb 2-3: >new high-speed USB device number 19 using ehci_hcd
[12648.357024] usb 2-3: >Dual-Role OTG device on non-HNP port
[12648.357133] usb 2-3: >can't set HNP mode: -32
[12648.472074] usb 2-3: >new high-speed USB device number 20 using ehci_hcd
[12648.493136] usb 2-3: >Dual-Role OTG device on non-HNP port
[12648.493272] usb 2-3: >can't set HNP mode: -32
[12648.608084] usb 2-3: >new high-speed USB device number 21 using ehci_hcd
[12648.629149] usb 2-3: >Dual-Role OTG device on non-HNP port
[12648.629271] usb 2-3: >can't set HNP mode: -32
[12648.632111] hub 2-0:1.0: >unable to enumerate USB device on port 3
[12648.900104] usb 6-1: >new full-speed USB device number 14 using uhci_hcd
[12649.044124] usb 6-1: >not running at top speed; connect to a high speed hub
[12649.067152] usb 6-1: >Dual-Role OTG device on non-HNP port
[12649.069150] usb 6-1: >can't set HNP mode: -32
[12649.180094] usb 6-1: >new full-speed USB device number 15 using uhci_hcd
[12649.322153] usb 6-1: >not running at top speed; connect to a high speed hub
[12649.346142] usb 6-1: >Dual-Role OTG device on non-HNP port
[12649.349121] usb 6-1: >can't set HNP mode: -32
[12649.516066] usb 6-1: >new full-speed USB device number 16 using uhci_hcd
[12649.548189] usb 6-1: >not running at top speed; connect to a high speed hub
[12649.574139] usb 6-1: >Dual-Role OTG device on non-HNP port
[12649.576154] usb 6-1: >can't set HNP mode: -32
[12649.688062] usb 6-1: >new full-speed USB device number 17 using uhci_hcd
[12649.718147] usb 6-1: >not running at top speed; connect to a high speed hub
[12649.741149] usb 6-1: >Dual-Role OTG device on non-HNP port
[12649.743138] usb 6-1: >can't set HNP mode: -32
[12649.744149] hub 6-0:1.0: >unable to enumerate USB device on port 1
[12651.244062] .ready
[12651.249831] sd 14:0:0:0: >[sdf] 625142448 512-byte logical blocks: (320 GB/298 GiB)
[12651.252792] sd 14:0:0:0: >[sdf] Write Protect is off
[12651.252805] sd 14:0:0:0: >[sdf] Mode Sense: 1c 00 00 00
[12651.255773] sd 14:0:0:0: >[sdf] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[12651.307753]  sdf: sdf2 < sdf5 >
[12651.330788] sd 14:0:0:0: >[sdf] Attached SCSI disk
Life is for living.  RIP Keith Floyd.   ;)

Offline Toonman

  • Hero Member
  • *****
  • Posts: 873
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #16 on: April 28, 2013, 08:30:37 pm »
Then

 mount
/dev/sda5 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/adammaureen/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=adammaureen)
/dev/sdf5 on /media/adammaureen/Seagate type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks2)
Life is for living.  RIP Keith Floyd.   ;)

Offline Toonman

  • Hero Member
  • *****
  • Posts: 873
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #17 on: April 28, 2013, 08:31:38 pm »
and finally

ls -a /run/user/adammaureen/gvfs
.  ..
Life is for living.  RIP Keith Floyd.   ;)

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1461
  • Karma: 119
  • Gender: Male
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #18 on: April 28, 2013, 08:39:00 pm »
I think what you want is the mtpfs package.

@Mark
Take a look at this article how you can use a PPA which has the latest Gvfs MTP backend

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13465
  • Karma: 332
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #19 on: April 28, 2013, 08:44:05 pm »
can you post the output from:
Code: [Select]
uname -a
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13465
  • Karma: 332
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #20 on: April 28, 2013, 08:45:59 pm »
@ Sezo

I'm currently looking at this:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1047527

Mint 14 is based on 12.10 right ?

and Mint doesn't update the kernel like Ubuntu ?

@ Toonman

Was it 12.04 where it worked ?
--
« Last Edit: April 28, 2013, 08:49:15 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Toonman

  • Hero Member
  • *****
  • Posts: 873
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #21 on: April 28, 2013, 08:53:03 pm »
uname -a
Linux adammaureen-EQUIUM-L350 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 i686 i686 i686 GNU/Linux
. 12.04


output

uname -a
Linux adammaureen-EQUIUM-L350 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 i686 i686 i686 GNU/Linux
Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13465
  • Karma: 332
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #22 on: April 28, 2013, 08:56:41 pm »
Was it Ubuntu 12.04 where it worked ? .. or 12.10 ?

and what's the make/model/Android version of the phone ?

--
« Last Edit: April 28, 2013, 09:05:23 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1461
  • Karma: 119
  • Gender: Male
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #23 on: April 28, 2013, 09:11:05 pm »
@Mark
Quote
Mint 14 is based on 12.10 right ?

Yes Mint 14 is based on 12.10
Quote
and Mint doesn't update the kernel like Ubuntu ?

 and comes with kernel 3.5. Although not used it for a while, but as I remember it the kernel updates are the same as in Ubuntu
but not offered unless you set the preferences to 5 in the update manager.

Offline Toonman

  • Hero Member
  • *****
  • Posts: 873
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #24 on: April 28, 2013, 09:27:39 pm »
Sorry. I am on call with work tonight.  I will have to come back tomorrow.

Thanks Guys.
Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13465
  • Karma: 332
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #25 on: April 28, 2013, 10:04:35 pm »
Quote
as I remember it the kernel updates are the same as in Ubuntu
but not offered unless you set the preferences to 5 in the update manager.

That's what I meant :)

According to that bug report, the bug appeared in kernel 3.3, and was fixed in 3.5.0-19 .. so I reckon just enabling the kernel updates, or running:
Code: [Select]
sudo apt-get update
then:
Code: [Select]
sudo apt-get upgrade
should bring in a later kernel.

If you see any messages about the kernel being "held back" .. run:
Code: [Select]
sudo apt-get dist-upgrade

Then reboot, and see which kernel you're now on with:
Code: [Select]
uname -a

Then check if you're still getting those errors in dmesg, and if things are working now.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Toonman

  • Hero Member
  • *****
  • Posts: 873
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #26 on: April 29, 2013, 07:12:02 am »


Linux adammaureen-EQUIUM-L350 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 i686 i686 i686 GNU/Linux

dmesg | tail -n 40
[   19.002755] init: plymouth-stop pre-start process (1559) terminated with status 1
[   24.245550] wlan0: authenticate with 90:c1:15:76:7e:fa
[   24.254752] wlan0: direct probe to 90:c1:15:76:7e:fa (try 1/3)
[   24.456076] wlan0: send auth to 90:c1:15:76:7e:fa (try 2/3)
[   24.461384] wlan0: authenticated
[   24.468061] wlan0: associate with 90:c1:15:76:7e:fa (try 1/3)
[   24.471527] wlan0: RX AssocResp from 90:c1:15:76:7e:fa (capab=0x431 status=0 aid=1)
[   24.472295] wlan0: associated
[   24.472752] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   27.020788] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[  102.652082] usb 2-3: >new high-speed USB device number 4 using ehci_hcd
[  102.785085] usb 2-3: >Dual-Role OTG device on non-HNP port
[  102.785206] usb 2-3: >can't set HNP mode: -32
[  102.900082] usb 2-3: >new high-speed USB device number 5 using ehci_hcd
[  103.032962] usb 2-3: >Dual-Role OTG device on non-HNP port
[  103.033082] usb 2-3: >can't set HNP mode: -32
[  103.148077] usb 2-3: >new high-speed USB device number 6 using ehci_hcd
[  103.169132] usb 2-3: >Dual-Role OTG device on non-HNP port
[  103.169263] usb 2-3: >can't set HNP mode: -32
[  103.284081] usb 2-3: >new high-speed USB device number 7 using ehci_hcd
[  103.305073] usb 2-3: >Dual-Role OTG device on non-HNP port
[  103.305197] usb 2-3: >can't set HNP mode: -32
[  103.308080] hub 2-0:1.0: >unable to enumerate USB device on port 3
[  103.576081] usb 6-1: >new full-speed USB device number 2 using uhci_hcd
[  103.714923] usb 6-1: >not running at top speed; connect to a high speed hub
[  103.739912] usb 6-1: >Dual-Role OTG device on non-HNP port
[  103.741913] usb 6-1: >can't set HNP mode: -32
[  103.852091] usb 6-1: >new full-speed USB device number 3 using uhci_hcd
[  103.990787] usb 6-1: >not running at top speed; connect to a high speed hub
[  104.013777] usb 6-1: >Dual-Role OTG device on non-HNP port
[  104.015774] usb 6-1: >can't set HNP mode: -32
[  104.128057] usb 6-1: >new full-speed USB device number 4 using uhci_hcd
[  104.158704] usb 6-1: >not running at top speed; connect to a high speed hub
[  104.183688] usb 6-1: >Dual-Role OTG device on non-HNP port
[  104.185692] usb 6-1: >can't set HNP mode: -32
[  104.296082] usb 6-1: >new full-speed USB device number 5 using uhci_hcd
[  104.326618] usb 6-1: >not running at top speed; connect to a high speed hub
[  104.351606] usb 6-1: >Dual-Role OTG device on non-HNP port
[  104.353605] usb 6-1: >can't set HNP mode: -32
[  104.354608] hub 6-0:1.0: >unable to enumerate USB device on port 1

It still is not working.



Mobile phone is Sony Experia Arc s Andriod 4.0

Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13465
  • Karma: 332
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #27 on: April 29, 2013, 11:22:01 am »
Well that doesn't appear to have updated the kernel at all .. do you know how to set the mint updater to accept kernel updates ?

If so, try making level 5 updates visible and see if there's a kernel update.

If there isn't, we'll manually install kernel 3.6
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Toonman

  • Hero Member
  • *****
  • Posts: 873
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #28 on: April 29, 2013, 07:15:49 pm »
Sorry, I dont know how to set the Kernel updates.
Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13465
  • Karma: 332
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Mint 14.1 Not recognizing my Andriod device.
« Reply #29 on: April 29, 2013, 07:51:36 pm »
Shall we just try manually installing the 3.6 kernel ?

[EDIT]

If so, run these commands in sequence:
Code: [Select]
mkdir ~/Desktop/kernel3.6
then
Code: [Select]
cd ~/Desktop/kernel3.6
then
Code: [Select]
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-quantal/linux-headers-3.6.0-030600-generic_3.6.0-030600.201209302035_i386.deb
then
Code: [Select]
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-quantal/linux-headers-3.6.0-030600_3.6.0-030600.201209302035_all.deb
then
Code: [Select]
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-quantal/linux-image-3.6.0-030600-generic_3.6.0-030600.201209302035_i386.deb
then
Code: [Select]
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-quantal/linux-image-extra-3.6.0-030600-generic_3.6.0-030600.201209302035_i386.deb
then
Code: [Select]
sudo dpkg -i *.deb

When that command finishes .. REBOOT .. then send the output from:
Code: [Select]
uname -a

then unplug the phone (if plugged in), replug the phone, then send the output from:
Code: [Select]
dmesg | tail -n 25
« Last Edit: April 29, 2013, 08:00:55 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal