Author Topic: Login Keyring  (Read 1623 times)

0 Members and 1 Guest are viewing this topic.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Login Keyring
« on: May 18, 2013, 03:08:03 am »
I am getting 'Unlock login Keyring' where I need to enter the password.
The problem is, I don't know what it is. I have tried current and previous passwords but they do not work.
What can I do?
This is on Mrs Pookys lappy (11.10)

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Login Keyring
« Reply #1 on: May 18, 2013, 04:13:25 am »
When are you seeing that message ?

Is wireless working ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Login Keyring
« Reply #2 on: May 18, 2013, 12:41:13 pm »
Yes, wireless is working. The message pops up on boot-up

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1505
  • Karma: 119
  • Gender: Male
    • View Profile
    • Awards
Re: Login Keyring
« Reply #3 on: May 18, 2013, 05:42:33 pm »
Dunno if this thread is of any help to you, but might worth to have a look.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Login Keyring
« Reply #4 on: May 18, 2013, 07:21:11 pm »
Yeh, but does wireless ONLY connect after you've entered the password ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Login Keyring
« Reply #5 on: May 19, 2013, 04:50:59 pm »
No, wireless connects regardless. I've not tried the link yet...

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Login Keyring
« Reply #6 on: June 02, 2013, 02:37:52 am »
Had a look at the link SeZo posted.
I don't know the password so I can't enter current password.
It's not the login password is it? as that's recently been changed.I actually think I've tried them too.


Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Login Keyring
« Reply #7 on: June 02, 2013, 10:14:15 am »
Run:
Code: [Select]
mv -v ~/.gnome2/keyrings ~/.gnome2/keyrings.old
The above will have removed the keyring(s) .. which will be recreated empty on next boot, so will prompt you for a new password for the keyring.

Now reboot.

If it prompts for a "keyring password" on next boot .. either leave it blank (and tell it that you want to use "unsafe storage"), or enter your CURRENT password.

--
« Last Edit: June 02, 2013, 10:30:37 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Login Keyring
« Reply #8 on: June 04, 2013, 12:43:15 pm »
I've followed your instructions and it has not asked for keyring password. I take that as it's now unsafe!
How do I rectify this and make it safe?

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Login Keyring
« Reply #9 on: June 04, 2013, 05:18:16 pm »
It's only using "unsafe" storage if it prompted you for a keyring password and you left it blank.

is that what you did ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 1618
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Login Keyring
« Reply #10 on: June 05, 2013, 12:35:45 am »
It didn't ask for one after the reboot.

Kubuntu 12.04LTS 64bit|KDE 4.13.2|QT 4.8.6|Linux 3.2.0-61-generic|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Login Keyring
« Reply #11 on: June 05, 2013, 12:49:35 am »
Don't worry about it then ;)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Keith

  • Sr. Member
  • ****
  • Posts: 456
  • Karma: 10
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: Login Keyring
« Reply #12 on: June 22, 2013, 08:27:34 pm »
I had the same problem of the keyring asking for its password on bootup and found this info on: https://one.ubuntu.com/help/faq/how-do-i-get-rid-of-the-keyring-password-prompt/:

There are two common scenarios where you will be prompted for your keyring password:
1. You are set to auto-login (no login prompt when you start your computer)
2. Your keyring password is different than your login password

For #1, if you want to remove the keyring password prompt, it is recommended you setup a login for Ubuntu and set the keyring password to be the same as your Ubuntu login password.

For #2 you can change the keyring password to be the same as your login password by:
1. Open Applications->Accessories->Passwords And Encryption Keys or on Ubuntu 11.04 press the "super key" (Windows key on most keyboards) and type "Passwords" then click on "Passwords and Encryption Keys"
2. Right-click on the "Passwords" folder and select "Change Password"
3. Set the new keyring password to be the same as your login password


I changed the keyring password to my login password and it was fine.  Hope this is useful.

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Login Keyring
« Reply #13 on: September 05, 2013, 05:18:46 pm »
I'm getting the different keyring password too- with 10.4.1 if I do

mv -v ~/.gnome2/keyrings ~/.gnome2/keyrings.old

and enter the new password, it doesn't demand the additional step of entering that one also, does it?

I don't want unsafe storage, I'm doing wifi in extremely high threat environment.

It's a real pain cause it just stopped asking for keyring, but afraid it is limiting Wifi

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Login Keyring
« Reply #14 on: September 05, 2013, 05:34:24 pm »
ACTUALLY I did this, entering the new password so they should be indentical:


The "Passwords and Keys" window should come up as shown below. Under the Passwords tab, select login, right-click on it, and then click on Change Password:

The "Change Keyring Password" box will come up. Type your old password, and then leave the new/confirm password fields blank. Then press OK, and the information box shown below will pop-up; read it, and then click on Use Unsafe Storage to not have to enter your password at each login:

enter image description here

Close the keyring manager. After you log out/reboot, you won't be asked for your password any more.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal