Author Topic: password on aa1 running peppermint 3[SOLVED]  (Read 1331 times)

0 Members and 1 Guest are viewing this topic.

Offline banko

  • Full Member
  • ***
  • Posts: 217
  • Karma: 1
  • I've just joined!
    • View Profile
    • Awards
password on aa1 running peppermint 3[SOLVED]
« on: May 20, 2013, 03:24:36 pm »
Hi Mark

Whats the easiest (best) way of having a password when i start the netbook?
Not the lock screen when suspended, just when starting the machine.

thanks

keith
« Last Edit: May 20, 2013, 08:01:34 pm by banko »

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: password on aa1 running peppermint 3
« Reply #1 on: May 20, 2013, 04:14:24 pm »
menu > System Tools > Users & Groups

Select your user in the left panel .. click the "Change" next to "Password: Not asked at login"

Take the tick out of "Don't ask for password on login"

Click the "OK" button.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline banko

  • Full Member
  • ***
  • Posts: 217
  • Karma: 1
  • I've just joined!
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3
« Reply #2 on: May 20, 2013, 06:52:15 pm »
when i click on user groups and get my user settings box, it already has "password asked at login" not what i was expecting, because it doesn't ask me a login.
sorry to be a pain,
any suggestions

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1524
  • Karma: 120
  • Gender: Male
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3
« Reply #3 on: May 20, 2013, 07:11:53 pm »
Do you get a lgin screen at boot?
Have you got it set for Autologin?
Check out this section in /etc/lightdm/lightdm.conf
Code: [Select]
cat /etc/lightdm/lightdm.conf

You should see something like this:
Code: [Select]
[SeatDefaults}
greeter-session=lightdm-gtk-greeter
user-session=Peppermint

The autologin section should be commented out

Offline banko

  • Full Member
  • ***
  • Posts: 217
  • Karma: 1
  • I've just joined!
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3
« Reply #4 on: May 20, 2013, 07:21:25 pm »
no login screen at boot
the answere to your question
eith@keith-AOA110 ~ $ cat /etc/lightdm/lightdm.conf

[SeatDefaults]
autologin-guest=false
autologin-user=keith
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-session=lightdm-gtk-greeter
user-session=Peppermint

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1524
  • Karma: 120
  • Gender: Male
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3
« Reply #5 on: May 20, 2013, 07:29:03 pm »
OK, then edit that section to make it look like this:
[SeatDefaults]
#autologin-guest=false
#autologin-user=keith
#autologin-user-timeout=0
#autologin-session=lightdm-autologin
greeter-session=lightdm-gtk-greeter
user-session=Peppermint

You could edit it with:
Code: [Select]
sudo gedit /etc/lightdm/lightdm.conf

Offline banko

  • Full Member
  • ***
  • Posts: 217
  • Karma: 1
  • I've just joined!
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3
« Reply #6 on: May 20, 2013, 07:38:29 pm »
after editing I had the following
 $ sudo gedit /etc/lightdm/lightdm.conf
[sudo] password for keith:

(gedit:5535): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.UVQ3WW': No such file or directory

(gedit:5535): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(gedit:5535): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.ONZFXW': No such file or directory

(gedit:5535): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(gedit:5535): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.PLYCXW': No such file or directory

(gedit:5535): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1524
  • Karma: 120
  • Gender: Male
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3
« Reply #7 on: May 20, 2013, 07:41:46 pm »
You can ignore those. It tries to save the recently used to the root user (which is pointless)
Save the changes and reboot :)

Offline banko

  • Full Member
  • ***
  • Posts: 217
  • Karma: 1
  • I've just joined!
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3
« Reply #8 on: May 20, 2013, 07:59:47 pm »
Many thanks SeZo
I don't know why but it always amazes me when these commands work
works perfect btw

keith

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1524
  • Karma: 120
  • Gender: Male
    • View Profile
    • Awards
Re: password on aa1 running peppermint 3[SOLVED]
« Reply #9 on: May 20, 2013, 08:06:32 pm »
 At least you now know how to enable autologin (reverse the changes):)

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal