Author Topic: No cups server after peppermint install  (Read 515 times)

0 Members and 1 Guest are viewing this topic.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2681
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
No cups server after peppermint install
« on: June 16, 2013, 10:12:07 pm »
Hi guys

I just installed Peppermint 4 and not surprisingly I've encountered a problem I've never had before which is I cant connect to a printer because it seems I have no CUPS server,

When I try to connect I get via Menu/System tools/Printing, i get a dialogue box saying "Printing service not available, Start the service on this computer or connect to another server" when I click "connect" another box opens up saying cups server: localhost, when I click on connect again I get an error message saying "There was an error during the CUPS operation: failed to start server"

I've checked CUPS is installed and according to synaptic it is, I also typed localhost:631 in my browser and I just get web page not found.

Any help would be much appreciated


Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14016
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No cups server after peppermint install
« Reply #1 on: June 17, 2013, 12:14:29 am »
OK, I've just uploaded a fix for this to the peppermint "testing" repo .. you can either wait till tomorrow when it'll be copied across to the "release" repo and you can get it as an update through the software updater .. or install avahi-daemon

Personally I'd wait for the update, as it doesn't require avahi-daemon to be running all the time.



Your other option is manually do what's contained in the update -

run:
Code: [Select]
sudo gedit /etc/init/cups.conf

find the section (near the top) that reads:-

Code: [Select]
start on (filesystem
          and started avahi-daemon
          and (started dbus or runlevel [2345]))
stop on runlevel [016]

and remove the whole "and started avahi-daemon" line .. so that section now reads:-

Code: [Select]
start on (filesystem
          and (started dbus or runlevel [2345]))
stop on runlevel [016]

SAVE the file, and REBOOT.

If you don't want to reboot, I guess:
Code: [Select]
sudo service cups restart
would also do the trick.

--
« Last Edit: June 17, 2013, 12:24:17 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2681
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: No cups server after peppermint install
« Reply #2 on: June 17, 2013, 05:49:08 am »
Hi Mark

Thanks for the reply

I can wait till tomorrow


Many thanks


Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal