Author Topic: wicd fix - could not connect to wicd's D-Bus interface  (Read 8017 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13592
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
wicd fix - could not connect to wicd's D-Bus interface
« on: July 23, 2013, 02:32:03 pm »
I tried installing wicd in Peppermint 4 this morning and it wouldn't start .. after a lot of Googling there seems to be a lot of it about  :o

If after installing wicd you get prompted for a password with this message:-

Wicd needs to access your computer's network cards

Then after entering your password you get an error stating:-

Could not connect to wicd's D-Bus interface
(and it wants you to check the error log)

Try this ..

Open a terminal and run:
Code: [Select]
sudo mv -v /etc/resolv.conf /etc/resolv.conf.backup
then
Code: [Select]
sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
then
Code: [Select]
sudo rm -v /var/lib/wicd/resolv.conf.orig
then
Code: [Select]
sudo service wicd start

Now see if "Wicd Network Manager" will start from your menus.

The above should work for any Ubuntu based OS .. dunno about others.



To undo -

run:
Code: [Select]
sudo mv -v /etc/resolv.conf /etc/resolv.conf.broken
then
Code: [Select]
sudo mv -v /etc/resolv.conf.backup /etc/resolv.conf

--
« Last Edit: July 23, 2013, 02:44:46 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline ctooth16

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: wicd fix - could not connect to wicd's D-Bus interface
« Reply #1 on: October 04, 2013, 05:55:38 pm »
Thank you so much! You fix worked perfectly and I was finally able to use wicd.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13592
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: wicd fix - could not connect to wicd's D-Bus interface
« Reply #2 on: October 04, 2013, 06:25:32 pm »
Hi ctooth16, and welcome to the forum :)

You're most welcome, and cheers for the feedback.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline RyanVN

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Installing Wireless Driver on OLD HP Compaq NC4400
« Reply #3 on: November 01, 2013, 11:39:35 am »
Hi all,

Linux Newbie as such, having just installed Linux Mint 13 on an old HP Compaq nc4400.

All working fine, except I'm "not allowed" to add the laptop onto the work domain, and so I cannot connect it to the LAN to gain an internet connection.

Therefore, I have downloaded the files as suggested in Post1, and have followed the commands. All seems ok, but the b43 driver is not appearing in the "Additional Drivers" window.

Need to get the wireless working!  :P


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13592
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: wicd fix - could not connect to wicd's D-Bus interface
« Reply #4 on: November 02, 2013, 02:27:54 am »
Hi RyanVN, and welcome to the forrum :)

Is there any output from:
Code: [Select]
modinfo b43
?

[EDIT]

I take it we're talking about an after-market USB wireless adapter ? .. as everything I can find online suggests the nc4400's built in Wireless isn't a Broadcom at all, but an Intel PRO/Wireless 3945ABG which doesn't need the b43 driver, it needs the iwl3945 driver.

What makes you think it's a Broadcom wireless adapter that needs the b43 driver ?

--
« Last Edit: November 02, 2013, 03:10:03 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline catoune

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: wicd fix - could not connect to wicd's D-Bus interface
« Reply #5 on: June 10, 2014, 04:03:46 pm »
Just to say a big THANKS !!!!!
works fine

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13592
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: wicd fix - could not connect to wicd's D-Bus interface
« Reply #6 on: June 10, 2014, 04:21:56 pm »
Hi catoune, and welcome to the forum...

You're most welcome .. thanks for taking the time to let us know it helped :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal