Author Topic: Sound issue in Game Fantastic Farm revised for mint 17 (Solved)  (Read 2033 times)

0 Members and 1 Guest are viewing this topic.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 689
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Hi All,

When I was using a 32bit system this was fixed by doing the following.

Easiest fix is to just add padsp at the beginning of the command line that launches the game... this will force the game to use pulse audio.

So if you have a desktop Launcher (shortcut) called "Fantastic Farm", right-click on it, select Properties

Then change the Command: line from:

Command: "/home/username/fantasticfarm/Fantastic Farm"

to

Command: padsp "/home/username/fantasticfarm/Fantastic Farm"

(don't forget the space after padsp... and change the username part)

Click Close

Now start the game from that launcher.

My wife decided that she want to play this game again.

I am now using a mint 13 64bit system and there is no sound in the game even when applying the fix that worked in the past.

Any suggestions.
« Last Edit: July 11, 2014, 08:42:31 am by Tramlink »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14048
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #1 on: August 01, 2013, 04:19:52 pm »
Run:
Code: [Select]
sudo updatedb
then what's the output from
Code: [Select]
dpkg -l | grep pulse

and just in case .. can you post a link to where I can download the game.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 689
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #2 on: August 08, 2013, 10:53:35 am »
userone@office2 ~ $ dpkg -l | grep pulse
ii  gstreamer0.10-pulseaudio                                    0.10.31-1ubuntu1.2                                  GStreamer plugin for PulseAudio
ii  libcanberra-pulse                                           0.28-3ubuntu3                                       PulseAudio backend for libcanberra
ii  libpulse-mainloop-glib0                                     1:1.1-0ubuntu15.3                                   PulseAudio client libraries (glib support)
rc  libpulse-mainloop-glib0:i386                                1:1.1-0ubuntu15.1                                   PulseAudio client libraries (glib support)
ii  libpulse0                                                   1:1.1-0ubuntu15.3                                   PulseAudio client libraries
ii  libpulse0:i386                                              1:1.1-0ubuntu15.3                                   PulseAudio client libraries
ii  libpulsedsp                                                 1:1.1-0ubuntu15.3                                   PulseAudio OSS pre-load library
ii  mate-media-pulse                                            1.2.1-5+precise                                     MATE media utilities (PulseAudio backend)
ii  mate-settings-daemon-pulse                                  1.2.0-4+precise                                     daemon handling the MATE session settings (PulseAudio version)
ii  pulseaudio                                                  1:1.1-0ubuntu15.3                                   PulseAudio sound server
ii  pulseaudio-module-bluetooth                                 1:1.1-0ubuntu15.3                                   Bluetooth module for PulseAudio sound server
ii  pulseaudio-module-gconf                                     1:1.1-0ubuntu15.3                                   GConf module for PulseAudio sound server
ii  pulseaudio-module-x11                                       1:1.1-0ubuntu15.3                                   X11 module for PulseAudio sound server
ii  pulseaudio-utils                                            1:1.1-0ubuntu15.3                                   Command line tools for the PulseAudio sound server
ii  vlc-plugin-pulse                                            2.0.8-0ubuntu0.12.04.1                              PulseAudio plugin for VLC
rc  wine1.5-amd64                                               1.5.6-0ubuntu1~pulse17                              Microsoft Windows Compatibility Layer (64-bit support)
rc  wine1.5-i386:i386                                           1.5.6-0ubuntu1~pulse17                              Microsoft Windows Compatibility Layer (32-bit support)
userone@office2 ~ $


Link to game http://www.kristanix.com/fantasticfarm/


My present command line reads   padsp "/home/userone/fantasticfarm/Fantastic Farm"

Thanks as always.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14048
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #3 on: August 08, 2013, 12:50:32 pm »
Hmm ..
Code: [Select]
padsp "/home/userone/fantasticfarm/Fantastic Farm" 
works for me in Peppermint 4

do you hear any audio when you run both:
Code: [Select]
aplay /usr/share/sounds/alsa/Front_Center.wav
and
Code: [Select]
padsp aplay /usr/share/sounds/alsa/Front_Center.wav



You could try resetting pulseaudio to defaults by renaming the pulseaudio config directory:
Code: [Select]
mv -v ~/.config/pulse ~/.config/pulse-old

if the above fails .. the pulse config directory may be in the old position .. so try:
Code: [Select]
mv -v ~/.pulse ~/.pulse-old
then
Code: [Select]
mv -v ~/.pulse-cookie ~/.pulse-cookie-old

Now in either case .. log OFF/ON again (or reboot) .. pulseaudio's config files/directory will get automagically recreated with the default settings.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2687
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #4 on: August 08, 2013, 01:59:16 pm »
Hi guys

hope you don't mind me hijacking this thread I just want to ask a quick question regarding pulseaudio, my Grand-Daughters sound doesn't work at all and it hasn't worked since upgrading to PM4 would it be worth my while trying to reset pulseaudio to defaults as per Marks instructions in the last post, if not I'll open a new thread

This is the commands I mean

Quote
You could try resetting pulseaudio to defaults by renaming the pulseaudio config directory:
Code: [Select]
mv -v ~/.config/pulse ~/.config/pulse-old

if the above fails .. the pulse config directory may be in the old position .. so try:
Code: [Select]
mv -v ~/.pulse ~/.pulse-old
then
Code: [Select]
mv -v ~/.pulse-cookie ~/.pulse-cookie-old

@Tramlink

Sorry for hijacking your post hope you don't mind


Many thanks


Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14048
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #5 on: August 08, 2013, 02:59:57 pm »
@Emegra

Probably best to open a new topic .. you may not teven have pulseaudio installed, Peppermint doesn't use it by default :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 689
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #6 on: August 08, 2013, 03:00:54 pm »
Hi I get the following error message.

ERROR: ld.so: object 'libpulsedsp.so' from LD_PRELOAD cannot be preloaded: ignored.
But the games still runs but with no sound.

By the way is your peppermint 4 a 64bit system, just asking.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14048
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #7 on: August 08, 2013, 03:02:28 pm »
No, I tested it in Peppermint 4 32bit .. but can test it in 64bit if you like ?

Looking for a solution now.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 689
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #8 on: August 08, 2013, 03:17:18 pm »
The fix worked in an Earlier version of Ubuntu 32bit system but that fix is not working in mint 13 64bit.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14048
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #9 on: August 08, 2013, 04:52:55 pm »
Try this:-
(this will download the 32bit libpulsedsp.so file for Ubuntu 12.04, unpack it to your game directory, and preload it before running the game)

Open a terminal and run
Code: [Select]
cd /home/userone/fantasticfarm
then
Code: [Select]
wget https://dl.dropboxusercontent.com/u/11876059/libpulsedsp.so.tar.gz
then
Code: [Select]
tar -xvf libpulsedsp.so.tar.gz

Now see if it will run (with sound) with this command
Code: [Select]
bash -c "LD_PRELOAD=/home/userone/fantasticfarm/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

If that DOESN'T work, what was output ?



If that DOES work .. modify the games .desktop file (launcher) so the "Exec=" line reads:
Code: [Select]
Exec=bash -c "LD_PRELOAD=/home/userone/fantasticfarm/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

--
« Last Edit: August 08, 2013, 04:56:38 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 689
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #10 on: August 12, 2013, 04:41:17 pm »
Hi it works fine thanks for your help.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14048
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sound issue in Game Fantastic Farm Solved
« Reply #11 on: August 12, 2013, 05:05:58 pm »
No problem :)

Is sound working in the game now, and if so was it the above fix that worked ?

--
« Last Edit: August 12, 2013, 09:11:44 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 689
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm Solved
« Reply #12 on: August 13, 2013, 04:18:29 pm »
It is Yes and Yes.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14048
  • Karma: 348
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Sound issue in Game Fantastic Farm Solved
« Reply #13 on: August 13, 2013, 06:05:23 pm »
Cheers :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 689
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm
« Reply #14 on: July 09, 2014, 10:48:45 pm »
Hi The sound issue is back now that I have upgraded to mint 17 64bit.  Below is the fix for mint 13 64bit

but it is not working for mint 17..

Any help welcome.


Try this:-
(this will download the 32bit libpulsedsp.so file for Ubuntu 12.04, unpack it to your game directory, and preload it before running the game)

Open a terminal and run
Code: [Select]
cd /home/userone/fantasticfarm
then
Code: [Select]
wget https://dl.dropboxusercontent.com/u/11876059/libpulsedsp.so.tar.gz
then
Code: [Select]
tar -xvf libpulsedsp.so.tar.gz

Now see if it will run (with sound) with this command
Code: [Select]
bash -c "LD_PRELOAD=/home/userone/fantasticfarm/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

If that DOESN'T work, what was output ?



If that DOES work .. modify the games .desktop file (launcher) so the "Exec=" line reads:
Code: [Select]
Exec=bash -c "LD_PRELOAD=/home/userone/fantasticfarm/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

--

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal