Author Topic: [SOLVED] Transmission gone wonky  (Read 2557 times)

0 Members and 1 Guest are viewing this topic.

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Transmission gone wonky
« Reply #15 on: August 14, 2013, 12:17:16 am »
You'll have to create your own "Service" called sommat like "Transmission"

And tell it to forward incoming connections on TCP <port-number> to the PC's IP address

<port-number> = whatever you've set in Transmission.

I can't help much more than that as all routers have their own interfaces.

Done  :)

Thanks Mark 8)

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12491
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #16 on: August 14, 2013, 01:43:20 am »
No problem pooky .. glad you got it sorted :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #17 on: August 14, 2013, 12:36:49 pm »
...Spoke too soon  >:(
I've set port forwarding rules for Qbittorrent, Vuze and Transmission and only Qbit works?
Even setting a range of ports for all of them to use, all but the one for Qbit show as closed to the software?
And...Yes. I have set the same port to be used in the software.

Qbittorrent
6881
TCP/UDP
192.168.0.2

Transmission
6882
TCP/UDP
192.168.0.2

Vuze
6883
TCP/UDP
192.168.0.2

Filesharing
6885..6889
TCP/UDP
192.168.0.2

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #18 on: August 15, 2013, 12:37:57 am »
It doesn't rain, it pours.

Now Qbittorrent will not start at all?
Vuze & Transmission work OK. But they do still have the same problem as before.

Is there anything I can do to check the system for what should be installed to see if that's the reason for the programs not starting?

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12491
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #19 on: August 15, 2013, 01:02:15 am »
Try reinstalling qbittorrent

Code: [Select]
sudo apt-get install --reinstall qbittottent



In Transmission >Preferences > Network

Set -

Port used for incoming connections: 6882
Pick a random port every time Transmission is started = UNticked
Use UPnP or NAT-PMP port forwarding from my router = UNticked

Now if you've forwarded port 6882 to the PC's IP address in the router .. it should all work

You can also check the port is OPEN by clicking the "Test Port" button in Transmission.

--
« Last Edit: August 15, 2013, 01:04:13 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #20 on: August 15, 2013, 01:06:35 am »
E: Unable to locate package qbittottent

Might try a reboot to see if that helps...

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #21 on: August 15, 2013, 01:18:12 am »
Still would'nt work so I tried to reinstall it through through SPM and it worked *this time* (I'd tried to do a 'reinstall' before posting my problem.

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12491
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #22 on: August 15, 2013, 01:33:37 am »
Sorry .. typo:
Code: [Select]
sudo apt-get install --reinstall qbittorrent

But if it's working now, don't bother.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #23 on: August 15, 2013, 12:47:52 pm »
Frying pan n fire spring to mind...
Firewall is set to 'High' and even with port forwarding addresses set, it still blocks traffic!
When its set to 'Low' it lets traffic through...

Qbittorrent is also now crashing...

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12491
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #24 on: August 15, 2013, 01:23:46 pm »
Which router make/model ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #25 on: August 15, 2013, 01:58:19 pm »
Which router make/model ?

The BEST in the world... a VM Superhub  ;D :o

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12491
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #26 on: August 15, 2013, 03:22:59 pm »
OK, I know sod all about the Virgin "not-so-Superhub" .. it may also require you to allow incoming connections on that port through its firewall

ie. a firewall rule.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #27 on: August 15, 2013, 04:40:26 pm »
Mark, from what I've just read here; http://community.virginmedia.com/t5/Up-to-60Mb-Setup-Equipment/SuperHub-R36-Firewall-settings/td-p/1325885 VM don't give two hoots. t's either On or Off...

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12491
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #28 on: August 15, 2013, 04:53:34 pm »
Hmm .. WTF is the point in having port forwarding if the minimalist firewall configuration options are going to ignore them anyway  ::)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Online pooky2483

  • Hero Member
  • *****
  • Posts: 1552
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: [SOLVED] Transmission gone wonky
« Reply #29 on: August 15, 2013, 05:12:39 pm »
No idea, but then again, tha'ts VM for you, or rather me!

Kubuntu 12.04LTS 64bit|M3A76-CM|BIOS 2101|AMD PhenomII X4 965 3400+|Realtek RTL8168C(P)|8111C(P) PCI-E Gigabit Ethernet NIC|NVIDIA 128MB GeForce6200 Turbocache|8.0GB Single-Channel DDR2|Chrome|

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal