Author Topic: Adding a wireless connection in Peppermint 3 [SOLVED]  (Read 1295 times)

0 Members and 1 Guest are viewing this topic.

Offline Keith

  • Hero Member
  • *****
  • Posts: 542
  • Karma: 10
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Adding a wireless connection in Peppermint 3 [SOLVED]
« on: August 03, 2013, 03:15:02 pm »
I have just installed Peppermint 3 on a friend's Dell Inspiron 1501.  All went well except that the Connection icon in the system tray (bottom right of screen) says:
Wireless Networks:
Device not ready (firmware missing)

I have added the network via the Network Manager but the message continues to deny that the firmware exists.  For the record; the wireless system on this machine worked fine in the previous, Vista installation. 

Any ideas?
« Last Edit: August 04, 2013, 10:00:50 am by Keith »

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2730
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #1 on: August 03, 2013, 03:27:39 pm »
Hi Keith

Have you checked in "Additional Drivers" to see if there is a proprietory driver available for that chipset, You may have a Broadcom chipset and I'm sure there was some issue with Broadcom drivers not included in the installation of Peppermint 3 for some commercial licensing reasons

EDIT

 if you want to check what wireless chipset you have type in the terminal

Code: [Select]
lshw -c network
« Last Edit: August 03, 2013, 03:41:30 pm by Emegra »
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Keith

  • Hero Member
  • *****
  • Posts: 542
  • Karma: 10
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #2 on: August 03, 2013, 03:42:41 pm »
Hi Graeme.
You are absolutely right - the Broadcom driver was missing. 
Unfortunately, when I attempted to download it, the system crashed - twice!
This looks like a more difficult problem.  Do you have any experience of this?

Offline Keith

  • Hero Member
  • *****
  • Posts: 542
  • Karma: 10
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #3 on: August 03, 2013, 03:48:01 pm »
Just seen your Edit. The output from the lshw command is:
*-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:18 memory:c0200000-c0203fff


The Connection icon no longer lists a wired-connection option at all - not even greyed out, as before.
« Last Edit: August 03, 2013, 03:49:47 pm by Keith »

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2730
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #4 on: August 03, 2013, 03:54:03 pm »
Sorry Keith

My knowledge and experience is very limited but I think you need to connect your laptop to the router via ethernet then when you have an internet connection type this command into the terminal
Quote
sudo apt-get install b43-fwcutter firmware-b43-installer
 

as per this post
 http://peppermintos.net/viewtopic.php?f=9&t=4799

but it may be better to wait till our lord and master (Mark) or someone more savvy comes along to advise you as I wouldn't want to be responsible for screwing things up for you


Good luck


Graeme
« Last Edit: August 03, 2013, 04:08:10 pm by Emegra »
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14279
  • Karma: 354
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #5 on: August 03, 2013, 04:07:44 pm »
OK, on the Peppermint3 PC, create a folder on the desktop called b43offline

On another PC

Download the b43-fwcutter_xxx-x_xxxx.deb file for your architecture from one of the mirrors at this link:
http://packages.ubuntu.com/precise/utils/b43-fwcutter
and place it in the b43offline directory you created on your desktop)

Once you have the b43-fwcutter_xxx-x_xxxx.deb file in the b43offline directory on your desktop .. open a terminal (Ctrl+Alt+T) and run:
Code: [Select]
cd ~/Desktop/b43offline
then
Code: [Select]
sudo dpkg -i b43-fwcutter*

On another PC with internet access .. download these 2 (firmware) files:-
http://mirror2.openwrt.org/sources/broadcom-wl-5.10.56.27.3_mipsel.tar.bz2
and
http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o

and copy them both to the b43offline directory you created on the Peppermint desktop.

Open a terminal, and run these commands in sequence:
Code: [Select]
cd ~/Desktop/b43offline
then
Code: [Select]
tar -xjvf broadcom-wl-5.10.56.27.3_mipsel.tar.bz2
then
Code: [Select]
sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.10.56.27.3/driver/wl_apsta/wl_prebuilt.o
then
Code: [Select]
sudo b43-fwcutter -w /lib/firmware wl_apsta-3.130.20.0.o
then
Code: [Select]
sudo chmod 755 /lib/firmware/b43
then
Code: [Select]
sudo chmod 755 /lib/firmware/b43legacy
then
Code: [Select]
sudo modprobe -r b43
(don't worry if that command fails .. just carry on below
then
Code: [Select]
sudo modprobe b43

Wireless adapters that use the b43 drivers should now spring to life

If that doesn't work .. try changing to the b43legacy driver with:
Code: [Select]
sudo modprobe -r b43
then
Code: [Select]
sudo modprobe b43legacy
Let me know which (if any) of those 2 drivers worked .. b43 or b43legacy

--
« Last Edit: August 03, 2013, 05:02:51 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2730
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #6 on: August 03, 2013, 04:20:55 pm »
Code: [Select]
inxi -F output:

the first line should tell you if it's 32 or 64 bit

If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Keith

  • Hero Member
  • *****
  • Posts: 542
  • Karma: 10
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #7 on: August 03, 2013, 04:23:10 pm »
Thanks, Graeme. 

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14279
  • Karma: 354
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #8 on: August 03, 2013, 04:30:52 pm »
Code: [Select]
inxi -S
will tell you if it's 64bit or 32bit  without all the other output.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2730
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #9 on: August 03, 2013, 04:32:33 pm »
Quote
will tell you if it's 64bit or 32bit  without all the other output.

I knew that  :P
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14279
  • Karma: 354
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #10 on: August 03, 2013, 04:34:32 pm »
:)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Keith

  • Hero Member
  • *****
  • Posts: 542
  • Karma: 10
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #11 on: August 03, 2013, 04:52:11 pm »
Sorry: I deleted my silly queries before checking that you had both replied - I wasn't being rude!

And yes - everything sprang into life immediately!
Thank you both very much for your prompt and effective advice.  I don't know what I would do without your help.

Keith

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2730
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #12 on: August 03, 2013, 04:53:53 pm »
Yeah I have to agree Mark was quite helpfull as well :)


glad you got it working



Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 14279
  • Karma: 354
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #13 on: August 03, 2013, 04:55:58 pm »
Check  it survives a reboot.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Keith

  • Hero Member
  • *****
  • Posts: 542
  • Karma: 10
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: Adding a wireless connection in Peppermint 3
« Reply #14 on: August 03, 2013, 05:09:52 pm »
Ah!  Funny you should mention that.  It didn't. 
I tried:
sudo modprobe -r b43
sudo modprobe b43legacy

but that doesn't connect the wireless.

May I beg your advice once more?
« Last Edit: August 03, 2013, 05:49:23 pm by Keith »

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal