Author Topic: Support Thread - Installing PeppermintOS Four on an Acer Aspire One AOA110L ZG5  (Read 3722 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
This is the support thread for the:

Tutorial - Installing PeppermintOS Four on an Acer Aspire One AOA110L ZG5

topic located here:
http://linuxforums.org.uk/index.php?topic=11109.0
« Last Edit: August 28, 2013, 10:10:59 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline gecko_03

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 5
  • I've just joined!
    • View Profile
    • Awards
Hi Mark,
I have updated from Peppermint 2 to Peppermint 4 on my AAO with HDD. It all went fine. Thank you so much for the efffort you have put into compiling a tutorial once again. It makes such a difference for people like me who want to use their existing hardware rather than buying new one every two years.
The only issue I am having is a message that appears every time during bootup and says something along the lines of "keys: Press I to ignore, S to skip mounting, or M for manual recovery". I assume this is because of a suboptimal fstab and this again might have been caused by the fact that the initial boot was from the USB stick. Although I have some knowledge on fstab, I still hesitate to modify it because the error is not too grave. But I thought it might be worthwile looking into this as others might experience the same issue.
I am attaching the fstab and would appreciate any comments on which of the lines is causing the problem.
Thanks again and kind regards,
Thomas

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
OK, somehow you've elected to use LVM and an encrypted swap file .. I wouldn't have done this, and can't say for sure how it will affect things.

If I were you I'd start again and NOT use LVM .. but we can attempt to stop the filesystem check dialog .. run:
Code: [Select]
sudo touch /forcefsck
that will force a run of the file system checker (fsck) at next boot .. hopefully this will automatically fix any errors.

If you still get the same message, hit the "M" key for manual recovery, cross your fingers, and accept any suggested changes.

Once finished, see if it boots without that message.
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline gecko_03

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 5
  • I've just joined!
    • View Profile
    • Awards
Thanks, Mark. The option to use LVM was one of the first ones to make during the installation, and as you did not mention it I thought it may be a good idea.Well, it probably was not.
I have rebooted with fsck and also hit the "M" key for manual recovery, but the message still appears during bootup. Booting now also takes very long...seems it does the fsck every time?
Anyway, thanks for your help. I think I can live with this message.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Okey Dokey :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2592
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Quote
Press I to ignore, S to skip mounting, or M for manual recovery

I get that message every time I boot up my laptop and occasionally when i boot my PC I just leave it and it continues to boot, it doesn't seem to slow down the boot process at least not noticeably so I just live with it





Graeme
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Can't say I do ... odd  :o

I wonder if booting a LiveUSB/LiveCD and manually running an fsck would help .. if anyone want to try, let me know if you need instructions.

[EDIT]

I do occasionally get:-

keys:

Displayed top left during boot, and I vaguely remember seeing that in the plymouth configs during the beta testing .. but I just ignore it.

--
« Last Edit: September 30, 2013, 09:24:05 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline joeyrico95

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
I have followed your steps closely but when I boot the usb it just says "SYSLINUX 4. 03 2010-10-22 EDD Copyright (c) 1994-2010 H. Peter Anvin et al" and doesn't move from this screen what have I done wrong?

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Shut down the AA1

Insert the LiveUSB

Turn ON the AA1, and immediately hit and hold the F12 key

When the boot device options are displayed, is the USB stick listed as a

USB HDD
or a
USB FDD

?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline joeyrico95

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
It is listed as a USB FDD

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
You'll need to usde a different USB stick .. for some reason the AA1 is pretty choosy about which USB sticks it will recognise as an HDD  :o
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline joeyrico95

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Oh okay thnkyou, I will have another go wheni find a different USB then.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
OK, please let us know how you get on :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline joeyrico95

  • Jr. Member
  • **
  • Posts: 4
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Purchased a new USB drive today and it worked fine im now running peppermint 4. Thanks for the support :)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13594
  • Karma: 339
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Thanks for the feedback, and you're welcome :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal