Author Topic: Player/Stage : Error in running 3 roomba robots  (Read 370 times)

0 Members and 1 Guest are viewing this topic.

Offline Mitali Sodhi

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Player/Stage : Error in running 3 roomba robots
« on: September 04, 2013, 06:16:35 am »
Hi,
I am working on a player/stage project which currently has 3 (Later it will be extended to 6) iRobots -Roomba.
As suggested in Jenny Owen's Tutorial on player/stage http://www-users.cs.york.ac.uk/~jowe...ial-manual.pdf , I was giving different port numbers to each one of the robots.

Here is my .cfg file :

driver
(
name "stage"
provides [ "simulation:0"]
plugin "stageplugin"
worldfile "pacman.world"
)


driver
(
name "stage"
provides [ "6665:position2d:0" ]
model "pacman"
)




driver
(
name "stage"
provides ["6666:position2d:0" ]
model "ghost1"
)


driver
(
name "stage"
provides ["6667:position2d:0" ]
model "ghost1"
)


But, I am getting this error when I am running ./ghost1 and ./ghost2 :

playerc error : got NACK from request

The simulator is not able to run the other two robots, I guess.

Kindly help me in this regard.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1510
  • Karma: 119
  • Gender: Male
    • View Profile
    • Awards
Re: Player/Stage : Error in running 3 roomba robots
« Reply #1 on: September 04, 2013, 10:21:51 pm »
I have no experience with the player/stage project but just noticed that you have two models named the same:
Quote
driver
(
name "stage"
provides ["6666:position2d:0" ]
model "ghost1"
)


driver
(
name "stage"
provides ["6667:position2d:0" ]
model "ghost1"
)

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal