Author Topic: Public folder not so public  (Read 2263 times)

0 Members and 1 Guest are viewing this topic.

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1510
  • Karma: 119
  • Gender: Male
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #30 on: September 06, 2013, 11:06:35 pm »
To test do this before and after the modifications:
Code: [Select]
nmblookup -R workgroup
or
Code: [Select]
nmblookup -R WORKGROUP

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13767
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Public folder not so public
« Reply #31 on: September 06, 2013, 11:09:42 pm »
As I said, there's nothing stopping you from bookmarking them after browsing to them by IP

I mean, a bookmark is easier to access than having to go to Go>Network Drives anyway ;)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2657
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #32 on: September 07, 2013, 06:38:42 am »
Yeah bookmarking is the simple solution in Peppermint, not so simple in Linux Lite which has the thunar file manager as there is no bookmark option in the taskbar, I can add any local folder to the side pane by right clicking>create shortcut>add to side pane, but as I'm already inside the folder I cant do that, if I mount the share (ie open it) I can view the folder in mounted volumes but when I right click on it there's no option to add to side pane I do have the option to add to desktop but if I select that a message pops up telling me it can't create the shortcut because it's not a local file
« Last Edit: September 07, 2013, 06:50:03 am by Emegra »
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mad Penguin

  • #Mad_Penguin_UK
  • Administrator
  • Hero Member
  • *****
  • Posts: 1318
  • Karma: 10017
  • Gender: Male
    • View Profile
    • Linux in the UK
    • Awards
Re: Public folder not so public
« Reply #33 on: September 07, 2013, 07:54:21 am »
Is there any specific reason why you are using SAMBA for shared drives ???

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2657
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #34 on: September 07, 2013, 08:12:14 am »
Quote
Is there any specific reason why you are using SAMBA for shared drives

it's the only way i know
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1510
  • Karma: 119
  • Gender: Male
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #35 on: September 07, 2013, 10:00:11 am »
Yeah bookmarking is the simple solution in Peppermint, not so simple in Linux Lite which has the thunar file manager as there is no bookmark option in the taskbar, I can add any local folder to the side pane by right clicking>create shortcut>add to side pane, but as I'm already inside the folder I cant do that, if I mount the share (ie open it) I can view the folder in mounted volumes but when I right click on it there's no option to add to side pane I do have the option to add to desktop but if I select that a message pops up telling me it can't create the shortcut because it's not a local file

In Thunar (1.6.3) after mounting the share, navigate to where it displays the folders.
Then right click on a folder -> Send to -> Side Pane (Create Shortcut)
This should add a shortcut to the side pane in the format:
smb://<servername>/<share>/<folder>
On my system this survives reboot

Offline Mad Penguin

  • #Mad_Penguin_UK
  • Administrator
  • Hero Member
  • *****
  • Posts: 1318
  • Karma: 10017
  • Gender: Male
    • View Profile
    • Linux in the UK
    • Awards
Re: Public folder not so public
« Reply #36 on: September 07, 2013, 12:10:44 pm »
« Last Edit: September 07, 2013, 03:16:33 pm by Mad Penguin »

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2657
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #37 on: September 07, 2013, 03:24:54 pm »
Quote
In Thunar (1.6.3) after mounting the share, navigate to where it displays the folders.
Then right click on a folder -> Send to -> Side Pane (Create Shortcut)
This should add a shortcut to the side pane in the format:
smb://<servername>/<share>/<folder>
On my system this survives reboot

I'm not sure what version of thunrar I'm using but if I mount the share the go to that folder & right click>send to  I only get 2 options "Desktop (create link)" or "80 GB filesystem" (which is a windows partition) i don't get any option to send to side pane and even if I choose send to desktop an error message pops up saying "could not create symbolic link to "public on 192.168.2.2.mount" because it is not a local file"
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13767
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Public folder not so public
« Reply #38 on: September 07, 2013, 03:40:04 pm »
Install pcmanfm ;) .. or just go the whole hog..........

Have a look in the help>about menu item of Thunar for the version.

[EDIT]

Doesn't Thunar allow you to drag and drop folders into the left hand panel to create shortcuts ?

--
« Last Edit: September 07, 2013, 03:44:15 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2657
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #39 on: September 07, 2013, 03:42:57 pm »
Quote
So what was wrong with this ??
http://http://linuxforums.org.uk/index.php?topic=11105.0


If I fully understood the implications of it I could answer your question ie how would it affect the mounted shares I already have on my NAS, how easy is it to add new shares etc.

Sharing between computers is not that important to me because I store all my data on a NAS so what is important is that all PC,/Laptops etc can share with the NAS but there are instances when it would be helpful to share between 2 PC's in particular and that's why I was attempting to do this

But I'm not against the idea if it has benefits so long as you or someone is prepared to help me because I don't think it's something I could do myself



Graeme
« Last Edit: September 07, 2013, 03:49:44 pm by Emegra »
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2657
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #40 on: September 07, 2013, 03:49:14 pm »
Quote
go the whole hog..........

I have absolutely no idea what you mean  ;)

Quote
Have a look in the help>about menu item of Thunar for the version.

Never thought of that (another mental block) it's version 1.2.3

Quote
Doesn't Thunar allow you to drag and drop folders into the left hand panel to create shortcuts ?

I tried that I get an error message saying "the path "public on 192.168.2.2" does not refer to a directory"
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1510
  • Karma: 119
  • Gender: Male
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #41 on: September 07, 2013, 03:54:21 pm »
Quote
I tried that I get an error message saying "the path "public on 192.168.2.2" does not refer to a directory"

Your "Public" is the share name, go one step deeper like:
smb://192.168.2.2/public/<folder>

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2657
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #42 on: September 07, 2013, 04:04:20 pm »
Quote
Your "Public" is the share name, go one step deeper like:
smb://192.168.2.2/public/<folder>

I tried that but I get exactly the same results/error messages with a file within the Public" folder
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13767
  • Karma: 342
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Public folder not so public
« Reply #43 on: September 07, 2013, 04:13:45 pm »
You could always create a launcher in your home folder
Code: [Select]
sudo gedit ~/Linux1-shares.desktop

and make it read:-
Code: [Select]
[Desktop Entry]
Type=Application
Icon=folder-publicshare
Name=Linux1 Shares
Comment=Browse the shares on Linux1
Exec=thunar smb://192.168.2.2
StartupNotify=true
Terminal=false
Categories=FileManager;Utility;Core;GTK;
MimeType=x-directory/normal;inode/directory;

SAVE the file.

Now look in your home folder for a folder called "Linux1 Shares"
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Emegra

  • Hero Member
  • *****
  • Posts: 2657
  • Karma: 54
  • Gender: Male
  • Devilishly Handsome
    • View Profile
    • Awards
Re: Public folder not so public
« Reply #44 on: September 07, 2013, 04:26:57 pm »
Quote
You could always create a launcher in your home folder

That would probably fix the problem but seeing how this has unfolded I'm now thinking of switching Linux2 over to PM4 for reasons of compatibility the only reason I have Linux Lite is because I couldn't get PM4 installed which I think was due to a graphics card that I've since removed.

Apart from the problem I'm currently having the earlier kernel version used in Linux Lite is causing a python dependency problem preventing me from running compatible versions of Gramps on both PC's so rather than jumping through hoops to sort that out (if it's even sortable) it would probably be easier to just to install PM4 on Linux2 (if I can) and sort all the problems and possibly prevent any future issues.

I'm sorry if I've wasted your time with this but seeing how this is turning out I think this would be the best approach

what do you think ?
If you can keep your head while all around are losing theirs, then you're not quite grasping the situation

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal