Author Topic: Newbie  (Read 475 times)

0 Members and 1 Guest are viewing this topic.

Offline Linko

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 0
  • On a mission to learn!
    • View Profile
    • Awards
Newbie
« on: October 25, 2013, 09:42:50 am »
Hi all, I'm new to the world of Linux, but am keen to get stuck in.

My question is, I installed Zorin OS 7 on my laptop, and Mint 15 Cinnamon to see which of these I liked more. (Zorin is winning at the minute - it seems more stable). They are on there own partitions. All i wanted to do was use the gui to create a new folder in the root directory, but the option was greyed out on the context menu. Why was this? I know Linux works differently to Windows as everything is a file and to access anything you have to mount it..and so on. But I was just wondering if there was a simple explanation for this, like me not having root access or the root being protected/restricted...or whatever. I believe that I can create a new folder using the terminal, but my better half is learning to use Linux as well but I think the terminal and all of it's commands would blow her mind.

If there is a good beginners book anyone knows of, please feel free to point me to it. I wanted to know how to share files between users as well but I'll save that for another time - unless it's simply right-click > Share (guess i should have tried this one first...haha).

Anyway, sorry for rambling on. Any help much appreciated.

Thanks

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13806
  • Karma: 343
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Newbie
« Reply #1 on: October 25, 2013, 12:28:58 pm »
OK, when you open the file manager in the normal way you only have permission to write to your home folder (/home/<username>)

If you want permission to write to anywhere else, you'll need to open the file manager "as root" .. which means with root permissions.

I'm not familiar with Zorin, but there's usually an option in the file manager toolbar somewhere to "open as root" .. failing that, open the filemanager from a terminal with:
Code: [Select]
gksudo nautilus
(replace the word "nautilus" with whatever the filemanager is called if it's not nautilus)

that will open the file manager with root permission.

BE AWARE .. ONLY do this when it's 100% necessary ;)

[EDIT]

See here for some free books/tutorials (though they may be a little dated, 99% should still apply):
http://linuxforums.org.uk/index.php?topic=232.0
« Last Edit: October 25, 2013, 12:32:57 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Linko

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 0
  • On a mission to learn!
    • View Profile
    • Awards
Re: Newbie
« Reply #2 on: October 28, 2013, 02:28:08 pm »
Thanks for the reply Mark, i'll check out the links.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 13806
  • Karma: 343
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Newbie
« Reply #3 on: October 28, 2013, 02:43:28 pm »
You're welcome :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal