Author Topic: Usb wifi not working after new Ubuntu installation  (Read 758 times)

0 Members and 2 Guests are viewing this topic.

Offline iena5

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Usb wifi not working after new Ubuntu installation
« on: October 27, 2013, 12:35:26 pm »
hello guys

sorry for my english (I'm Italian :D )

As the title of the post, after having re-installed ubuntu studio, my wifi key no longer works.

I had previously followed the steps in this forum at this link: http://linuxforums.org.uk/index.php?topic=11065.0 , and the wifi key worked properly, but, now, after performing the steps in the same procedure, nothing happens and the usb is "turned off".    :'(

Could you help me?    :P

thanks!!!!!!

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12490
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #1 on: October 28, 2013, 04:22:24 am »
Hi iena5, and welcome to the forum :)

Can you post the output from these commands (with your wireless adapter plugged in):
Code: [Select]
sudo lshw -C network
and
Code: [Select]
lsusb
and
Code: [Select]
iwconfig
and
Code: [Select]
ifconfig
and
Code: [Select]
iwlist scanning
and
Code: [Select]
rfkill list
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline iena5

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #2 on: October 28, 2013, 06:45:33 am »
hello!

Meanwhile, thank you :) ( I'm new to the Linux world, please already be forgiven if the error was obvious )

I do not know if there is a more correct procedure to attach the results of the terminal. I will use directly copy and paste


sudo lshw -C network:

 *-network               
       description: Ethernet interface
       product: RTL8111/8168 PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 06
       serial: bc:5f:f4:cb:58:c6
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=192.168.1.2 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:51 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       bus info: usb@2:4
       logical name: wlan0
       serial: 64:66:b3:22:89:4a
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu multicast=yes wireless=unassociated

lsusb:

Bus 002 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 003 Device 002: ID 04f3:0234 Elan Microelectronics Corp.
Bus 004 Device 006: ID 0e6f:0301 Logic3
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 011 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

iwconfig:

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ifconfig:

eth0      Link encap:Ethernet  IndirizzoHW bc:5f:f4:cb:58:c6 
          indirizzo inet:192.168.1.2  Bcast:192.168.1.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::be5f:f4ff:fecb:58c6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5378 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5072 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:3703395 (3.7 MB)  Byte TX:1203139 (1.2 MB)

lo        Link encap:Loopback locale 
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:315 errors:0 dropped:0 overruns:0 frame:0
          TX packets:315 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:31464 (31.4 KB)  Byte TX:31464 (31.4 KB)


iwlist scanning:

eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     No scan results


rfkill list: This command has not resulted any response


(Ok it is clear that the wifi is not set up very well  :)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12490
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #3 on: October 28, 2013, 11:57:45 am »
It *appears* as though the drivers are loaded, but may be broken.

Can you tell us which distro, version, architecture you're using

example = Ubuntu 12.04 32bit

If unsure .. just post the output from:
Code: [Select]
uname -a
and
Code: [Select]
cat /etc/*release

--
« Last Edit: October 28, 2013, 12:02:37 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline iena5

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #4 on: October 28, 2013, 07:43:22 pm »
Hi,

wow, it's a  "wonderful" information!   :'( ....... you think it's possible resolve this issue?

however:

uname -a
Linux iena5-desktop 3.8.0-32-lowlatency #24-Ubuntu SMP PREEMPT Mon Oct 7 08:03:08 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.04
DISTRIB_CODENAME=raring
DISTRIB_DESCRIPTION="Ubuntu 13.04"
NAME="Ubuntu"
VERSION="13.04, Raring Ringtail"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 13.04"
VERSION_ID="13.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

thanks for your support!!!

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12490
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #5 on: October 28, 2013, 09:09:42 pm »
Make SURE your PC is connected to the internet via an ethernet cable, then open a terminal and run these commands in sequence:
Code: [Select]
sudo apt-get install git linux-headers-generic build-essential
then
Code: [Select]
mkdir ~/RTL8188EU-3.8kernel
then
Code: [Select]
cd ~/RTL8188EU-3.8kernel
then
Code: [Select]
git clone git://github.com/lwfinger/rtl8188eu
then
Code: [Select]
cd ~/RTL8188EU-3.8kernel/rtl8188eu
then
Code: [Select]
make
then
Code: [Select]
sudo make install
then
Code: [Select]
sudo cp -v ~/RTL8188EU/rtl8188eu/rtl8188eufw.bin /lib/firmware/rtlwifi/
then
Code: [Select]
sudo depmod -a
then
Code: [Select]
sudo update-initramfs -u
then
Code: [Select]
sudo modprobe -r r8188eu
(don't worry if that last command fails .. just carry on below)
then
Code: [Select]
sudo modprobe 8188eu
Did wireless spring to life ?

If not, REBOOT .. does it work now ?

if not, what's the output from:
Code: [Select]
lsmod | grep 8188
« Last Edit: November 05, 2013, 12:15:58 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline iena5

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #6 on: October 28, 2013, 09:55:58 pm »
So, I performed all the steps (the LED of the key has been turned off, so I rebooted). after a reboot I again performed the last step, but nothing.

the command - lsmod | grep 8188 - give this result: 8188eu                692712  0 

(I do not know if it is important, the number 8188 appears in red  ??? )


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12490
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #7 on: October 28, 2013, 10:38:27 pm »
Not that's just showing the match of the query in red.

What's the output from:
Code: [Select]
rfkill list
now ?
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline iena5

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #8 on: October 30, 2013, 06:23:34 pm »
Hello.

excuse me for the delay in the response. I tried to run the command you have posted and then try to give the "sudo modprobe 8188eu." But the key continues to be off. I do not know if that was the procedure that I should follow.  :(


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12490
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #9 on: October 30, 2013, 06:33:18 pm »
What's the output from:
Code: [Select]
sudo lshw -C network
and
Code: [Select]
rfkill list
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline iena5

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #10 on: October 30, 2013, 08:52:01 pm »
okay, then for -sudo lshw -C network-:

*-network               
       description: Ethernet interface
       product: RTL8111/8168 PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 06
       serial: bc:5f:f4:cb:58:c6
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=192.168.1.7 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:52 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       bus info: usb@2:4
       logical name: wlan0
       serial: 64:66:b3:22:89:4a
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu multicast=yes wireless=unassociated

while the command -rfkill list - nothing is shown

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12490
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Usb wifi not working after new Ubuntu installation
« Reply #11 on: October 30, 2013, 10:04:55 pm »
Is there any output from:
Code: [Select]
modinfo 8188eu

If so, run:
Code: [Select]
sudo modprobe -r r8188eu
then
Code: [Select]
sudo modprobe 8188eu
then post the output from:
Code: [Select]
sudo lshw -C network
and
Code: [Select]
rfkill list
and
Code: [Select]
lsmod | grep 8188
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal