Author Topic: No internet connection any more  (Read 4928 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #15 on: March 09, 2016, 12:17:07 am »
With the setup I described do you get ping returns from:
Code: [Select]
ping -c 5 216.58.213.174
but not from:
Code: [Select]
ping -c 5 google.com
?



If so, what happens if (in networkmanager NOT in the router) on the IPv4 tab you set:-

Method: Automatic (DHCP) addresses only

DNS Servers: 8.8.8.8, 8.8.4.4
(that's a comma and space between the 2 DNS IP's)

SAVE the settings .. then restart the network by either clicking on the networkmanager icon, then your network name in the list .. or by logging off/on.
« Last Edit: March 09, 2016, 12:26:14 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikep

  • Full Member
  • ***
  • Posts: 198
  • Karma: 1
  • Gender: Male
  • Me again!
    • View Profile
    • Awards
Re: No internet connection any more
« Reply #16 on: March 09, 2016, 06:57:09 pm »
Yes I do Mark, although even using the IP address I get anything between 0% and 100% packet loss. With the domain name I get nothing.

Same thing with DNS Servers: 8.8.8.8, 8.8.4.4

There's inconsistency though. The router diagnostics allow a DNS lookup. Also, if I switch between openDNS and getting a dns from the ISP, sometimes I actually see the netgear website, although no other sites load, and in fact the netgear one doesn't next time I try. Something to do with caching?

Could this be as simple as a failing router? Actually probably not, as Windows is consistently online, albeit 75% as fast as previously..

I'm fighting the urge to kick some expensive monitors now!

« Last Edit: March 09, 2016, 08:41:49 pm by mikep »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #17 on: March 09, 2016, 10:51:33 pm »
So you're getting packet loss even with
Code: [Select]
ping -c 5 216.58.213.174
how are you connected again . wireless or cable ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikep

  • Full Member
  • ***
  • Posts: 198
  • Karma: 1
  • Gender: Male
  • Me again!
    • View Profile
    • Awards
Re: No internet connection any more
« Reply #18 on: March 10, 2016, 02:33:34 am »
Yes. And cable.

Thanks for your help Mark. Got to sleep now. I'll check in later today..

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #19 on: March 10, 2016, 02:12:36 pm »
Have you tried replacing the
8.8.8.8, 8.8.4.4
in networkmanager, with your ISP's DNS addresses ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikep

  • Full Member
  • ***
  • Posts: 198
  • Karma: 1
  • Gender: Male
  • Me again!
    • View Profile
    • Awards
Re: No internet connection any more
« Reply #20 on: March 10, 2016, 09:02:28 pm »
I've tried replacing them with the option to get DNS automatically from the ISP. Is that what you mean? Works in Windows. Fails in Ubuntu (although it used to work fine).


... just emailed the ISP to ask for any specific DNS addresses which might help.

This is driving me insane. It just used to WORK!
« Last Edit: March 10, 2016, 09:34:20 pm by mikep »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #21 on: March 10, 2016, 09:49:16 pm »
No

What I meant was, look in your router and it should tell you which primary and secondary DNS the router is currently using.

use those in networkmanager.

if you can't find them, try:-

109.228.30.14, 109.228.10.55

I "think" those are the fireflyinternet DNS server IP's



Beyond that, have you checked if a LiveCD/LiveUSB is able to connect to the web ? (to rule out an OS configuration problem)

Have you tried another ethernet cable ? (to rule out the cable)

have you tried another ethernet card, or wireless ? (to rule out the adapter)
« Last Edit: March 10, 2016, 09:53:19 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikep

  • Full Member
  • ***
  • Posts: 198
  • Karma: 1
  • Gender: Male
  • Me again!
    • View Profile
    • Awards
Re: No internet connection any more
« Reply #22 on: March 11, 2016, 10:24:04 pm »
Hello Mark,

Tried your first two suggestions - no luck!

Haven't got a live cd/usb handy, but will find one.

Can't see the point of swapping the cable or the card. They both worked with Ubuntu till recently, and they both still work with windows.

I suspect this is to do with settings. Do the DNS addresses in the router have to match those in Ubuntu's network manager? I would have thought so, but I'm no comms expert..

I'm thinking about the nuclear option. Reset the router to factory settings, and reinstall Ubuntu. This is getting tedious.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #23 on: March 12, 2016, 12:29:28 am »
No they don't need to match.

I'd seriously like to know if the web works from a LiveCD/LiveUSB though.

Are you saying you have Windows on this same PC ?



Okay, put the networkmanager setting back to
Method: Automatic (DHCP)

Now let's start from the beginning .. post the output from these commands
Code: [Select]
ifconfig
and
Code: [Select]
sudo lshw -C network
and
Code: [Select]
lspci -vnn | grep -i net
and
Code: [Select]
ls /etc/NetworkManager/system-connections
and the contents of
Code: [Select]
gedit /etc/NetworkManager/NetworkManager.conf
and
Code: [Select]
gedit /etc/network/interfaces
and
Code: [Select]
gedit /etc/udev/rules.d/70-persistent-net.rules
« Last Edit: March 12, 2016, 12:37:47 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikep

  • Full Member
  • ***
  • Posts: 198
  • Karma: 1
  • Gender: Male
  • Me again!
    • View Profile
    • Awards
Re: No internet connection any more
« Reply #24 on: March 12, 2016, 06:44:47 pm »
Thanks Mark,

Just been online with an old Mint 7 LiveCD.

And yes, it's a dual-boot with XP and Ubuntu. XP isn't normally allowed online, but right now it's the only way I can get online (apart from a LiveCD), which obviously isn't ideal.

Here are the outputs you requested.


mike@mike-abit:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:8d:be:be:f3 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr 00:50:8d:be:be:f4 
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::250:8dff:febe:bef4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4902 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6064 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:442874 (442.8 KB)  TX bytes:8543244 (8.5 MB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:238 errors:0 dropped:0 overruns:0 frame:0
          TX packets:238 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:18621 (18.6 KB)  TX bytes:18621 (18.6 KB)

mike@mike-abit:~$ sudo lshw -C network
[sudo] password for mike:
Sorry, try again.
[sudo] password for mike:
  *-network:0             
       description: Ethernet interface
       product: RTL-8110SC/8169SC Gigabit Ethernet
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 10
       serial: 00:50:8d:be:be:f3
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       resources: irq:23 ioport:be00(size=256) memory:fdbff000-fdbff0ff memory:fdb00000-fdb1ffff
  *-network:1
       description: Ethernet interface
       product: RTL-8110SC/8169SC Gigabit Ethernet
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 1
       bus info: pci@0000:04:01.0
       logical name: eth1
       version: 10
       serial: 00:50:8d:be:be:f4
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.2 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:22 ioport:bc00(size=256) memory:fdbfe000-fdbfe0ff memory:fdb20000-fdb3ffff
mike@mike-abit:~$ lspci -vnn | grep -i net
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet [10ec:8167] (rev 10)
04:01.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet [10ec:8167] (rev 10)
mike@mike-abit:~$ ls /etc/NetworkManager/system-connections
Wired connection 1  Wired connection 2

mike@mike-abit:~$ gedit /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

no-auto-default=00:50:8D:BE:BE:F4,00:50:8D:BE:BE:F3,

[ifupdown]
managed=false

mike@mike-abit:~$ gedit /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

mike@mike-abit:~$ gedit /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x10ec:0x8167 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:8d:be:be:f4", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# PCI device 0x10ec:0x8167 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:8d:be:be:f3", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
mike@mike-abit:~$
« Last Edit: March 12, 2016, 07:07:11 pm by mikep »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #25 on: March 13, 2016, 12:28:21 am »
Run:
Code: [Select]
sudo gedit /etc/udev/rules.d/70-persistent-net.rules
when it opens, make it read just:
Code: [Select]
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.
SAVE the file and exit gedit.

Now REBOOT.

Once rebooted, check if networking works .. and post the contents of:
Code: [Select]
gedit /etc/udev/rules.d/70-persistent-net.rules
again.



Have you got 2 network adapters in this PC ?
(maybe one on the mother board and an add-in card ?)

.
« Last Edit: March 13, 2016, 12:32:17 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikep

  • Full Member
  • ***
  • Posts: 198
  • Karma: 1
  • Gender: Male
  • Me again!
    • View Profile
    • Awards
Re: No internet connection any more
« Reply #26 on: March 13, 2016, 07:25:00 pm »
Done that Mark. Still not online.. (I assume that's what you mean by 'check if networking works'?)

Also, only the onboard network adapters are present. No add-ins.

Here's the output.

# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.


# PCI device 0x10ec:0x8167 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:8d:be:be:f4", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# PCI device 0x10ec:0x8167 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:8d:be:be:f3", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #27 on: March 13, 2016, 07:54:51 pm »
So why is it listing 2 hardware addresses

00:50:8d:be:be:f4
and
00:50:8d:be:be:f3

?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 16782
  • Karma: 419
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: No internet connection any more
« Reply #28 on: March 13, 2016, 08:10:43 pm »
I wonder what would happen if you ...

right-click the networkmanager icon, select "Edit Connections" .. select your wired connection and select "Edit" .. then on the "Ethernet" tab...

Change the drop down menu called "Device MAC Address" to the one that's currently NOT selected .. then click "SAVE"

Then log off/on (or reboot).
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikep

  • Full Member
  • ***
  • Posts: 198
  • Karma: 1
  • Gender: Male
  • Me again!
    • View Profile
    • Awards
Re: No internet connection any more
« Reply #29 on: March 13, 2016, 08:15:44 pm »
Aren't the 2 hardware addresses the 2 ethernet ports on the motherboard?

I'll try your suggestion Mark. need to boot into Ubuntu first, then boot back to get online...
« Last Edit: March 13, 2016, 08:22:40 pm by mikep »

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal