Author Topic: Offline install of b43-fwcutter and firmware for Broadcom Wireless cards  (Read 38146 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12494
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Hi seydell, and welcome to the forum :)

You're right of course .. thanks for pointing out my mistake   :-[ (fixed in previous posting)

or you can just leave out the -

as in:-

Code: [Select]
tar xfvj broadcom-wl-5.10.56.27.3_mipsel.tar.bz2



Fixed above.

--
« Last Edit: April 06, 2013, 01:48:53 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline allnunstoport

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
I'm trying to get my wireless working in 12.04 on a DELL Latitude D630 with the broadcom card.  I've gone through all of the steps you've posted.  When I run the "sudo modprobe -r b43" command my terminal just hangs never goes back to a prompt.  Same if I pub in "b43legacy".  Everything else seemed to work.  No wireless on reboot.  Any suggestions?

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12494
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Hi allnunstoport, and welcome to the forum :)

Did you follow the updated instructions for 12.04 here:
http://linuxforums.org.uk/index.php?topic=5842.msg81040#msg81040

What's the output from:
Code: [Select]
sudo lshw -C network
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline allnunstoport

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Thank you.  I've been through all of the steps you indicated.  Perhaps I botched something?

Output is:

  *-network               
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=wl latency=0
       resources: irq:17 memory:efdfc000-efdfffff
  *-network
       description: Ethernet interface
       product: NetXtreme BCM5752 Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 02
       serial: 00:15:c5:50:c5:ff
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.121 firmware=5752-v3.19 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:44 memory:efcf0000-efcfffff

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12494
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Hmm, seems your wireless adapter can use either the wl or b43 drivers .. wl are loaded, so let's try making sure they're ALL unloaded, then try them one at a time

Open a terminal and run:
Code: [Select]
sudo modprobe -r b43 ssb wl
then:
Code: [Select]
sudo modprobe b43

Did wireless spring to life ?

If not, run:
Code: [Select]
sudo modprobe -r b43 ssb wl
then
Code: [Select]
sudo modprobe wl

Did wireless spring to life ?

Be aware, neither of the above attempts will survive a reboot .. but if either work we can tell the system to load them at bootup.

If still no .. send the output from these commands:
Code: [Select]
lspci -vnn | grep -i net
and
Code: [Select]
iwconfig
and
Code: [Select]
iwlist scanning
and
Code: [Select]
rfkill list
« Last Edit: April 28, 2013, 10:35:07 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline allnunstoport

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
No luck.  When I run any form of the 'sodu modprobe' command, the terminal never returns to a prompt.  I've given it up to an hour before cancelling the terminal and getting the message that doing so will cancel an open process.  Something hung up in a loop?

Here is the out put from the other diagnostics you asked for.  Thanks for your continuing help:

matthew@delldualboot:~$ lspci -vnn | grep -i net
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express [14e4:1600] (rev 02)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
matthew@delldualboot:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

matthew@delldualboot:~$ iwlist scanning
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

matthew@delldualboot:~$ rfkill list
0: dell-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: dell-bluetooth: Bluetooth
   Soft blocked: no
   Hard blocked: no
2: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12494
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
How did you end up with the "wl" drivers if you haven't got an internet connection ?

Have you got an internet connection ?



You might want to try purging bcmwl-kernel-source:
Code: [Select]
sudo apt-get remove --purge bcmwl-kernel-source
then download this file:
http://ie.archive.ubuntu.com/ubuntu/pool/multiverse/l/linux-firmware-nonfree/linux-firmware-nonfree_1.11ubuntu1_all.deb
double-click it to install it.

Then reboot, and see if Wireless works.
« Last Edit: April 28, 2013, 04:43:01 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline allnunstoport

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
OK!  Now we're getting somewhere.  That got the wireless working intermittently and am able to work from 12.04 OS.   I'm online through the Broadcom card and my wifi hotspot.  However, the wireless is cycling on and off and requesting the wireless network authentication key every 20 seconds or so or whenever I refresh or browse to another page.  So we're not quite stable.  Any suggestions?

Offline allnunstoport

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
I think I might have solved the intermittent issue by going into the wireless connection and editing the wireless security to save the authentication key.  That seems to have stopped the cycling.  Thank you very much for all your help.  It seems like these Broadcom cards are going to be an issue at each upgrade.  Perhaps I'll jump on Ebay and buy one of the other better supported Wifi cards!

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12494
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
You're welcome .. happy to hear you solved the dropping connection .. but if it reappears, give us a shout ;)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Colin Weaver

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Just joined the forum so I could say "thank you"!

I am currently setting up an old ex-work Latitude D630 with Ubuntu 12.04, and had exactly the same issue as allnunstoport: modprobe would just hang up.   Turned out that because I had a wired connection working, I had also installed the "wl" drivers, and the advice above got my wi-fi going nicely.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12494
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Thanks for the feedback Colin, it's always nice to hear from people that have benefited in some way .. kinda makes it all worthwhile :)
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

Offline Silhalnor

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Hello, I was following the instructions but whenever I use modprobe it hangs and never completes the task. Any idea why?

Offline DionTheGreek

  • Jr. Member
  • **
  • Posts: 3
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Offline install of b43-fwcutter and firmware for Broadcom Wireless cards
« Reply #58 on: August 03, 2013, 07:50:04 am »
I followed the instructions until now but somehow I got something wrong and now my wireless is not stable. I do see the network but it doesnt connect. Somehow I installed various .deb files and now I am all confused. Can anyone here help?

I am newbie to linux 12.04 but want to learn more.

Appreciate any help.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 12494
  • Karma: 306
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Offline install of b43-fwcutter and firmware for Broadcom Wireless cards
« Reply #59 on: August 03, 2013, 09:53:28 am »
Can you open a terminal and post the output from these commands:
Code: [Select]
lsusb
and
Code: [Select]
lspci -vnn | grep -i net
and
Code: [Select]
sudo lshw -C network
and
Code: [Select]
iwconfig
and
Code: [Select]
rfkill list
and
Code: [Select]
sudo iwlist scan
WARNING: You are logged into reality as 'root'

logging in as 'insane' is the only safe option.

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal