Many new features now available including 2-Factor authentication

Ralink RT2870 based USB Wireless N adapters (Ubuntu)

Started by Mark Greaves (PCNetSpec), April 10, 2010, 01:44:57 PM

Previous topic - Next topic

0 Members and 5 Guests are viewing this topic.

Mark Greaves (PCNetSpec)

For kernels >= 2.6.35 make sure you read the the EDIT.

If you want to know which kernel you are using, open a terminal and enter:
uname -r
(if it's greater than, or equal to 2.6.35, be sure to follow the instructions in the EDIT.

In Ubuntu 9.10 (Karmic), Ubuntu 10.04 (Lucid), and Ubuntu 10.10 (Maverick) there is an issue with USB Wireless N adapters based on the Ralink RT2870 chip.
The issue seems to be that 2 (conflicting?) driver modules are loaded... rt2870sta and rt2800usb... resulting in no wireless access.

The solution is to blacklist the rt2800usb module if it is loaded.

To see if they are both loaded, enter this in a terminal:
sudo lsmod | grep rt28
if they are both loaded, blacklist the rt2800usb module by opening the /etc/modprobe.d/blacklist.conf file (as root)
sudo gedit /etc/modprobe.d/blacklist.conf

and add the line:

blacklist rt2800usb

then save the file and reboot.

If after rebooting you can now 'see' the network, but it will not accept a WPA key (WEP seems fine)... you need to recompile the driver with WPA support... the driver can be found here:

2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2 (http://eng.ralinktech.com.tw/license_us.php?n=2&p=0&t=U0wyRnpjMlYwY3k4eU1ERXdMekEzTHpBNUwyUnZkMjVzYjJGa05ETTVOalU0TXpVeU5pNWllakk5UFQweU1ERXdYekEzTURsZlVsUXlPRGN3WDB4cGJuVjRYMU5VUVY5Mk1pNDBMakF1TVM1MFlYST1D) (you can enter 'any' name and email)
Ralink Linux Driver Page (http://eng.ralinktech.com.tw/en/Products/support.php?sn=501)
(HINT - change the files extension to tar.gz before unpacking... for some reason it comes up as an invalid bz2 archive, but unpacks properly as a tar.gz)

Before compiling - you are going to need to install build-essential, and linux-headers-generic.
sudo apt-get update && sudo apt-get install build-essential linux-headers-generic

If you use WPA/WPA2 encryption, you will have to change the lines

(inside the unpacked driver)


Once you have changed these to =y and saved the config.mk file...

Newer kernels >= 2.6.35 will fail to compile (make) the driver because the driver makes use of the functions usb_buffer_alloc() and usb_buffer_free() which were renamed in kernel 2.6.35 .. so if during the next (make && make install) step it fails with this error:

Quotemake[2]: *** [/home/mark/Desktop/RT2870/os/linux/../../common/cmm_mac_usb.o] Error 1
make[1]: *** [_module_/home/mark/Desktop/RT2870/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-27-generic'
make: *** [LINUX] Error 2
or similar.

The fix is to cd to the driver source directory (eg. 2010_0709_RT2870_Linux_STA_v2.4.0.1), and run the following 3 commands which will clean the build directory and replace the old calls with the new ones:

make clean
find . -name \*.[ch] -exec grep usb_buffer_alloc "{}" ";" -exec sed -i 's/usb_buffer_alloc/usb_alloc_coherent/g' "{}" ";"
find . -name \*.[ch] -exec grep usb_buffer_free "{}" ";" -exec sed -i 's/usb_buffer_free/usb_free_coherent/g' "{}" ";"

(hitting enter after each line)

Or, I've uploaded a pre-modified version of the driver that WILL compile on kernels >= 2.6.35 here:
2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2 (http://bit.ly/eZHx0J)

Then carry on with the "sudo su" and "make && make install", as per the instructions below.

To compile and install, open a terminal and enter:
sudo su
make && make install

It is important here not to use "sudo" alone, but "sudo su" because with sudo for some reason the installation script fails to create the necessary files and folders.

Now, while still root modprobe the driver module:
modprobe rt2870sta

Give it a minute to create the ra0 device node, and network manager should now be able to display all visible wireless networks in your area, meanwhile you can stop being root.

Make sure that ra0 is up and running as it's supposed to:

and check for a section similar to:
Quotera0 RT2870 Wireless ESSID:"" Nickname:"RT2870STA"
Mode:Managed Frequency=2.412 GHz Access Point:
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Link Quality=100/100 Signal level:-29 dBm Noise level:-71 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

To make sure the module is loaded after a reboot, add it to the /etc/modules file:
sudo sh -c 'echo rt2870sta >> /etc/modules'

Your wireless card should now be working (it may require a reboot first)... Use network manager to set your WEP/WPA(2) key, and connect to your network.

Further info can be found at the following URLs:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/460323 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/460323)

http://www.linuxquestions.org/questions/linux-hardware-18/d-link-dwa-140-802-11n-usb-with-ralink-rt2870-chispet-driver-probs-635827/ (http://www.linuxquestions.org/questions/linux-hardware-18/d-link-dwa-140-802-11n-usb-with-ralink-rt2870-chispet-driver-probs-635827/)

http://swiss.ubuntuforums.org/showthread.php?t=1382798 (http://swiss.ubuntuforums.org/showthread.php?t=1382798)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


Hi Mark

I have been looking for a solution to this problem for ages on and have tried allsorts with my patchy but growing knowledge of linux.  I am now running xubuntu 11.04 on an ancinet laptop.  The USB wifi unit is recognised in 11.04 without the need for blacklisting and I can see my network but canont login.  On  your modified driver for later kernals do I need to change thge WPA_Supplicant info or have you done that already? I am going to try this tonight.

I must say this is the clearest linux forum that I have come across.



Mark Greaves (PCNetSpec)

I've NOW changed the WPA settings to Y in the pre-modified driver :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


Hi Mark,

Thank you very much for the tip on the compilation error, this certainly saved me quite a bit of trouble.

I'm up and running now (on Natty), but I notice that iwconfig is only reporting 54 Mb/s. As I have an "N" speed router & adapter (and is configured as such), shouldn't I be seeing speeds higher than this?

Thanks again...

Mark Greaves (PCNetSpec)

Are there any slower wireless devices connected to the router ?

AFAIK, a mixed mode b/g/n wireless router (or access point) will default to the slowest protocol depending on what devices are connected wirelessly.
(ie. an 802.11n router that supports b/g/n will scale back to 802.11b if a device with only 802.11b capabilities connects to it... slowing ALL other device connections)

You could try changing the (default) configuration:
line in

sudo gedit /etc/Wireless/RT2870STA/RT2870STA.dat

to force a Wireless "N" connection.
(be aware, if there are any slower devices connected to the router this mode may leave you unable to connect)

Some people say setting it to:
helps, in mixed mode... ie.dropping support for 802.11b and/or 802.11a

WirelessModes -

     0: legacy 802.11b/g mixed
     1: legacy 802.11b only
     2: legacy 802.11a only
     3: legacy 802.11a/b/g mixed
     4: legacy 802.11g only
     5: 802.11a/b/g/n mixed
     6: 802.11n only
     7: 802.11g/n mixed
     8: 802.11a/n mixed
     9: 802.11b/g/n mixed
   10: 802.11a/g/n mixed

Don't forget to save the RT2870STA.dat file, and restart the wireless (or reboot).

It's all in the README_STA file in the driver archive ;)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.



I recently download Ubuntu 11.04 and created a dual-boot system.  This is my second experience with Linux in general in about 12 years, and so far, so good.  However, I'm trying to get it to connect to the internet and I can't seem to get it to.

I have an AE1000 USB Adapter, and following the step-by-step wizard included with ubuntu for configuring wireless settings got me as far as "Great! Now go to the device drivers page" which just brought me back to the same instruction page I was on.  But it did yield the fact that the chipset within my USB Adapter (which it was able to recognize as being plugged in, if not being able to load some sort of driver for initializing it) was an RT2870. 

I'm a Windows user; I'm used to the command prompts in MS-DOS and the Terminal system is somewhat familiar to me, but I still can't get it to do much of anything.  Is there anyway you could perhaps make it simpler for a complete Noob such as myself to follow your instructions?  I got as far as saving that reworked driver you made to my Linux partition, but I just can't get to it through terminal.  In windows you can change directories via "cd" much as linux does, but I must be getting some critical element of the syntax wrong, because no matter how I vary the spacing, or use "/" versus "\" or including multiple folder files to provide the exact file path name, it always returns a file not found message.  Which is somewhat frustrating.

As soon as I figure out more of the way commands are entered into terminal, I could perhaps piece together the rest of what I need from posts.  In fact, I'm about to google that now, so, if I don't have it *solved* by the time I get a reply, at least my need for simpler instructions won't be as---stringent.  Thank you in advance!

Mark Greaves (PCNetSpec)

Can you confirm you can browse to the file using the nautilus file manager, and where it is ?

If you downoaded it with Firefox (with default settings) it is probably in the "Downloads" directory.

If you can't find it, download it again with these commands:

cd ~
wget -O 2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2 "http://bit.ly/eZHx0J"

You with then find the 2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2 file in your "Home" directory.

you can unpack it through the GUI, or with:
tar -jxvf 2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2

cd into the unpacked directory:
cd ~/2010_0709_RT2870_Linux_STA_v2.4.0.1

then carry on from the:
sudo su
make && make install

Extra info...

Just prior to posting this, I've updated the pre-modified driver to also include the WPA/WPA2 modification... so it would probably be a good idea to re-download it anyway.

BTW, the ~ in the above paths just means the current users "Home" directory... it saves you having to type /home/username

If you want to get to grips with the Linux command line, some of these free online books might help -
http://linuxforums.org.uk/ubuntu/ubuntu-andor-generic-linux-books-or-text-()/ (http://linuxforums.org.uk/ubuntu/ubuntu-andor-generic-linux-books-or-text-()/)

If you want to know more about a particular command, you can enter "man" in front  of it to see the commands man page (manual)... eg.
man tar
man make
man modprobe

To exit the man page, just hit the Q key.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


I can confirm I can browse to the file using nautilus manager, and it was in the downloads folder.  What was really wrong was the fact I was not including the '~' symbol.  Thank you for the heads-up about that one.

I downloaded your revised driver, accessed it using Terminal and it seemed to throw a couple of memory warnings.  Went to install it again, and it said directories were already created, so I'm not sure if all went well upon download or not. 

However I seem to have run into a snag, in that the 'iwconfig' command still didn't return all of the information that you showed would've been available had all gone well.  It is probably pertinent to mention at this point that I did not follow the edits for blacklisting.  I will do that now, just to say I tried everything.  I was confused, as you mentioned specific versions, and the dimly hopeful feeling in my soul said, "Well, maybe they fixed it in 11.04."  My bad on that one.

Mark Greaves (PCNetSpec)

First, let's confirm your card IS an RT2870 based card... can you post the output from:

sudo lshw -C network

entered into a terminal.

I can confirm the driver builds and installs properly on 11.04, so I'm guessing something went wrong on your build... and I'm *guessing* (because of your "directories were already created" comment) that the command wasn't run as root... but we'll get to that once you post the output from the above command ;)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


I ran that command and it kicked out:

Description: Ethernet Interface
     Product: Netlink BCM 57780 Gigabit Ethernet PCIe
     Vendor: Broadcom Corp
     Physical ID: 0
     Bus Info: . . . . . .  and it all goes on.  This, as you may have guessed is all information related to my onboard network adapter which I can visually confirm is not what connects me to the Internet.  Never has been, never will, and I forgot about it until now.
     I have had to use my windows OS to sign onto the internet and talk with you here, and I've been copy/pasting posts/directions inbetween.  The reason I didn't go much further is because, as I discovered, the disk I've been using was configured by windows as a pseudo-USB device that will let me read off it---but not write to it, at least with Ubuntu.  So I wrote down enough to convey the general impression that this is in fact not my usb device at all..  Since I didn't have another disk. 

     Ubuntu doesn't even seem to recognize that my USB adapter exists.  And I can confirm that I was in root when I ran that program, because it prompts me to enter a password in when I access any sudo commands and will not run until I do.

     Do you know of any off-the-shelf internet adapters that do work with Linux right out of the box? 

Mark Greaves (PCNetSpec)

QuoteThis, as you may have guessed is all information related to my onboard network adapter which I can visually confirm is not what connects me to the Internet.  Never has been, never will, and I forgot about it until now. I have had to use my windows OS to sign onto the internet

Erm... If you don't have an active internet connection in Ubuntu, this command will have failed:

sudo apt-get update && sudo apt-get install build-essential linux-headers-generic

It needs an active internet connection to download/install those files... which would explain why the "make && make install" command  also failed.

So connect with a cable, and try again.

If that doesn't work...

Can you unplug your USB wireless adapter... wait 5 seconds... plug it back in, then run:

dmesg | tail -n 15

and post the output.

and the FULL output from:

sudo lshw -C network



If you can't mount and write to the windows disk/partition... use a cabled connection to your router, or copy the output to a USB stick.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


Okay, I entered 'sudo apt-get update && sudo apt-get install build-essential linux-headers-generic' and here's what linux kicked:
[email protected]:~$ sudo apt-get update && sudo apt-get install build-essential linux-headers-generic
[sudo] password for logan:
Ign http://extras.ubuntu.com (http://extras.ubuntu.com) natty InRelease
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security InRelease
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty InRelease
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates InRelease             
Hit http://extras.ubuntu.com (http://extras.ubuntu.com) natty Release.gpg                       
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security Release.gpg
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty Release.gpg
Hit http://extras.ubuntu.com (http://extras.ubuntu.com) natty Release     
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security Release                 
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates Release.gpg           
Hit http://extras.ubuntu.com (http://extras.ubuntu.com) natty/main Sources
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/main Sources
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty Release
Hit http://extras.ubuntu.com (http://extras.ubuntu.com) natty/main amd64 Packages                         
Ign http://extras.ubuntu.com (http://extras.ubuntu.com) natty/main TranslationIndex             
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/restricted Sources     
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/universe Sources       
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/multiverse Sources     
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/main amd64 Packages   
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/restricted amd64 Packages
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates Release               
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/universe amd64 Packages
Hit http://security.ubuntu.com (http://security.ubuntu.com) natty-security/multiverse amd64 Packages
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/main TranslationIndex 
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/multiverse TranslationIndex
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/restricted TranslationIndex
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/main Sources                 
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/restricted Sources           
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/universe Sources             
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/multiverse Sources           
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/main amd64 Packages           
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/universe TranslationIndex
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/restricted amd64 Packages     
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/universe amd64 Packages
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/multiverse amd64 Packages
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/main TranslationIndex
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/multiverse TranslationIndex   
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/restricted TranslationIndex   
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/universe TranslationIndex     
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/main Sources         
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/restricted Sources   
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/universe Sources     
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/multiverse Sources   
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/main amd64 Packages   
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/restricted amd64 Packages
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/universe amd64 Packages
Hit http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/multiverse amd64 Packages
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/main TranslationIndex
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/restricted TranslationIndex
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/universe TranslationIndex
Ign http://extras.ubuntu.com (http://extras.ubuntu.com) natty/main Translation-en_US           
Ign http://extras.ubuntu.com (http://extras.ubuntu.com) natty/main Translation-en               
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/main Translation-en_US
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/main Translation-en
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/multiverse Translation-en_US
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/multiverse Translation-en
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/restricted Translation-en_US
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/restricted Translation-en
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/universe Translation-en_US
Ign http://security.ubuntu.com (http://security.ubuntu.com) natty-security/universe Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/main Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/main Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/multiverse Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/restricted Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/universe Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty/universe Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/main Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/multiverse Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com (http://us.archive.ubuntu.com) natty-updates/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
linux-headers-generic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 84 not upgraded.

Here is the output after reinserting my wireless adapter and entering in 'dmesg | tail -n 15' :
[email protected]:~$ dmesg | tail -n 15
[   13.276620] tg3 0000:05:00.0: eth0: Link is up at 100 Mbps, full duplex
[   13.276623] tg3 0000:05:00.0: eth0: Flow control is off for TX and off for RX
[   13.277151] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   13.820860] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro,commit=0
[   23.649522] eth0: no IPv6 routers present
[   46.751357] CE: hpet5 increased min_delta_ns to 7500 nsec
[   46.751365] CE: hpet5 increased min_delta_ns to 11250 nsec
[   46.751368] hrtimer: interrupt took 2788 ns
[   51.270000] CE: hpet2 increased min_delta_ns to 7500 nsec
[   51.270065] CE: hpet2 increased min_delta_ns to 11250 nsec
[   68.197523] CE: hpet3 increased min_delta_ns to 7500 nsec
[   68.197533] CE: hpet3 increased min_delta_ns to 11250 nsec
[   99.129742] CE: hpet4 increased min_delta_ns to 7500 nsec
[   99.129773] CE: hpet4 increased min_delta_ns to 11250 nsec
[  643.711646] usb 2-1.4: new high speed USB device using ehci_hcd and address 6

Here is the full output of 'sudo lshw -C network' :

[email protected]:~$ sudo lshw -C network
       description: Ethernet interface
       product: NetLink BCM57780 Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: [email protected]:05:00.0
       logical name: eth0
       version: 01
       serial: 00:25:64:e5:04:60
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.116 duplex=full firmware=sb v2.05 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:48 memory:fbff0000-fbffffff

[EDIT] : Here's 'lusb' results:

[email protected]:/home/logan/2010_0709_RT2870_Linux_STA_v2.4.0.1# lsusb
Bus 002 Device 006: ID 13b1:002f Linksys AE1000 v1 802.11n [Ralink RT2870]
Bus 002 Device 005: ID 0461:4d65 Primax Electronics, Ltd
Bus 002 Device 004: ID 0b38:0003 Gear Head
Bus 002 Device 003: ID 18e3:9106 Fitipower Integrated Technology Inc
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[email protected]:/home/logan/2010_0709_RT2870_Linux_STA_v2.4.0.1#

Mark Greaves (PCNetSpec)

[  643.711646] usb 2-1.4: new high speed USB device using ehci_hcd and address 6

This tells us that it is detecting a USB device is being attached, but the system isn't recognising it as a wireless adapter.

you missed the:


command... hopefully this will give us the vendor and device ID string, so we can find out what the adapter is.

There may also be an issue with your sources.list as you shouldn't be getting those Ign lines

Is this a fresh install of natty, or an upgrade ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


This is a fresh install.  I'm utterly new to Linux of any sort; the last thing I tried was Redhat 6.0.  :-[

[EDIT] This is also the first time I've ever physically connected to ethernet.  The last hardline I ever had connected to my computer was indeed a regular phone line.  Once we upgraded to something faster, I automatically switched to wireless. . . It goes a whole lot quicker than wireless does.  Think I might just get about 30 feet or so of line and call it good, lol.  Seeing as how the adapter that came with the computer works and all. . . .

Mark Greaves (PCNetSpec)

Heh  ;D bit restrictive if it's a laptop though... you'll trip everyone else up.

Can you post the output from:


with the adapter plugged in.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.