Updates:

Similar topics mod installed, currently shown at the end of a topic

Dell 5100cn colour laser printer on network

Started by Sim, June 07, 2016, 11:45:56 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Sim

We've had this printer for ages, and had it in the network before, accesible from laptop and desktop, but its stopped working. ::)

I'm guessingthat this may be a change of ISP, and the "new" router, but given we have an HP3392 all in one which just works, I am a bit lost as to what has happenned.

I've used ifconfig to find the gateway and subnet mask, assigned a fixed IP to the printer, but can't get it to work on the net. USB still works fine, but, obviously this isn't as convenient..

Could anyone walk me through this please?

TIA.

Mark Greaves (PCNetSpec)

If you open your web browser and go to
http://localhost:631 (http://localhost:631)

then go to

Administration (tab)

and click on "Find New Printers"

is anything found ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk


Sim

Thanks for the reply.

No new printers are found in CUPS on both the wireless connected laptop (P6), or the hardwired desktop running P6. ???

Mark Greaves (PCNetSpec)

Was the printer turned on, and is it in the same IP range as the PC ?

What's the IP and subnet of your printer ?

What's the IP and subnet of your router ?

What's the IP and subnet of your PC ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Sim

Aye, the printer is turned on ! works fine over USB from the desktop....

IP and subnet of printer:-

192.168.1.245 subnet 255.255.255.0 ( I tried to use the top of the range after reading the FAQ on TalkTalks forum and reserving 240 to 255 out of the DHCP table - it didn't work )

IP and subnet of router:-

192.168.1.1 subnet 255.255.255.0

IP and subnet of PC:-

[email protected] ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr 74:d4:35:e2:9c:85 
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0

I can't even ping the dell!! process just sits there until I ctrl+Z it (!)

I have tried setting the IP to a fixed IP within the Huawei 633 router ( as above ) - no joy, then setting the IP to x.x.1.4 - still no joy, installed snmpwalk, and tried
[email protected] ~ $ snmpwalk -Cc -v 1 -c public 192.168.1.4 | tee snmpwalk.log
Timeout: No Response from 192.168.1.4
[email protected] ~ $

same command directed to the HP's IP works instantly

So I tried arp, which gives:-

[email protected] ~ $ arp
Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.1.245                    (incomplete)                              eth0
192.168.1.4              ether   08:00:37:2a:96:af   CM                    eth0      <--- supposedly the Dell
192.168.1.1              ether   58:7f:66:b1:52:77   C                     eth0        <-- router
192.168.1.2              ether   dc:d3:21:aa:7a:1f   C                     eth0        <--- ???
192.168.1.6              ether   c4:85:08:e5:43:40   C                     eth0       <--- set top box
192.168.1.7              ether   00:14:38:d1:e9:02   C                     eth0       <--- HP3392
[email protected] ~ $

The x.x.1.245 was deleted using arp -d - but remains in the list for some reason (?) the MAC address at x.x.1.4 is the Dell's MAC

I've tried reseting the Dell, and more or less every permutation of protocol I can think of - still works fine over USB - would you like a test  page ::) - i have "several" spares free to a good home!!

lost? you betcha!

TIA






Mark Greaves (PCNetSpec)

Are you SURE you've told the Dell Printer not to get its IP via DHCP ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Sim

Well, until you asked the question, I was sure - but now you ask the question, I can see why - resetting the thing will have reset that bit too. Ooops! 

I'll try and get it back to a fixed IP..

Any advice on the next steps please?

Sorry,  :-[ and thanks  :)


Mark Greaves (PCNetSpec)

#7
If you make SURE the printer is set to have a static IP of 192.168.1.245 I'd expect it would "just work" if that's that's the IP it had when you originally set up the printer.

otherwise either give the printer that IP then change the IP to match in the printer profile, or delete the printer profile and reset it up from scratch.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Sim

Thanks for the reply.  :) I expected it to "just" work - and still don't know why it didn't. ???  I do wonder if something has happened to the network side of the printer.  :( I'll set a static IP, and try to ping it - once I get that to work, I'll see if it will play the rest of the game  ::)

I'll be back !! :)


Mark Greaves (PCNetSpec)

Have you got one of those routers where you can reserve an IP for a given MAC address, and have you implemented that and forgotten ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk