Forums updated to SMF version 2.1.1

Neither software or package manager working ! ?? (SOLVED)

Started by Sim, March 20, 2017, 07:26:41 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi Folks, So, here's a new one on me.... neither SPM nor Software manager are working....

SPM, having asked for, and received my pwd,  gives the following errors:-

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

Sotware manager asks for my pwd, and is given it, and then closes the window (!!)

So..., I did a manual update:-

[email protected] ~ $ sudo apt-get update
[sudo] password for sim:
Ign http://gb.archive.ubuntu.com trusty InRelease
Hit http://ppa.launchpad.net trusty InRelease                                 
Ign http://extras.ubuntu.com trusty InRelease                                 
Get:1 http://gb.archive.ubuntu.com trusty-updates InRelease [65.9 kB]         
Ign http://ppa.launchpad.net trusty InRelease                                 
Get:2 http://extras.ubuntu.com trusty Release.gpg [72 B]                       
Hit http://ppa.launchpad.net trusty/main amd64 Packages                       
Hit http://extras.ubuntu.com trusty Release                                   
Get:3 http://security.ubuntu.com trusty-security InRelease [65.9 kB]           
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://extras.ubuntu.com trusty/main Sources                               
Get:4 http://gb.archive.ubuntu.com trusty-backports InRelease [65.9 kB]       
Hit http://extras.ubuntu.com trusty/main amd64 Packages                       
Hit http://ppa.launchpad.net trusty/main Translation-en                       
Hit http://extras.ubuntu.com trusty/main i386 Packages                         
Get:5 http://ppa.launchpad.net trusty Release.gpg [316 B]                     
Hit http://ppa.launchpad.net trusty Release                                   
Ign http://ppa.launchpad.net trusty Release                                   
Ign http://ppa.launchpad.net trusty/main amd64 Packages/DiffIndex             
Ign http://ppa.launchpad.net trusty/main i386 Packages/DiffIndex               
Hit http://ppa.launchpad.net trusty/main amd64 Packages                       
Get:6 http://security.ubuntu.com trusty-security/main Sources [127 kB]         
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Ign http://extras.ubuntu.com trusty/main Translation-en_GB                     
Ign http://extras.ubuntu.com trusty/main Translation-en                       
Get:7 http://gb.archive.ubuntu.com trusty Release.gpg [933 B]                 
Get:8 http://gb.archive.ubuntu.com trusty-updates/main Sources [393 kB]       
Get:9 http://security.ubuntu.com trusty-security/restricted Sources [4,637 B] 
Ign http://ppa.launchpad.net trusty/main Translation-en_GB                     
Get:10 http://security.ubuntu.com trusty-security/universe Sources [50.3 kB] 
Ign http://ppa.launchpad.net trusty/main Translation-en                       
Get:11 http://security.ubuntu.com trusty-security/multiverse Sources [3,203 B]
Get:12 http://security.ubuntu.com trusty-security/main amd64 Packages [594 kB]
Get:13 http://gb.archive.ubuntu.com trusty-updates/restricted Sources [5,911 B]
Get:14 http://gb.archive.ubuntu.com trusty-updates/universe Sources [175 kB]   
Get:15 http://gb.archive.ubuntu.com trusty-updates/multiverse Sources [7,513 B]
Get:16 http://gb.archive.ubuntu.com trusty-updates/main amd64 Packages [963 kB]
Get:17 http://security.ubuntu.com trusty-security/restricted amd64 Packages [13.4 kB]
Get:18 http://gb.archive.ubuntu.com trusty-updates/restricted amd64 Packages [16.4 kB]
Get:19 http://security.ubuntu.com trusty-security/universe amd64 Packages [154 kB]
Get:20 http://gb.archive.ubuntu.com trusty-updates/universe amd64 Packages [402 kB]
Get:21 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [4,143 B]
Get:22 http://security.ubuntu.com trusty-security/main i386 Packages [553 kB] 
Get:23 http://gb.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [14.0 kB]
Get:24 http://gb.archive.ubuntu.com trusty-updates/main i386 Packages [924 kB]
Get:25 http://gb.archive.ubuntu.com trusty-updates/restricted i386 Packages [16.2 kB]
Get:26 http://gb.archive.ubuntu.com trusty-updates/universe i386 Packages [403 kB]
Get:27 http://security.ubuntu.com trusty-security/restricted i386 Packages [13.1 kB]
Get:28 http://security.ubuntu.com trusty-security/universe i386 Packages [155 kB]
Get:29 http://gb.archive.ubuntu.com trusty-updates/multiverse i386 Packages [14.4 kB]
Get:30 http://gb.archive.ubuntu.com trusty-updates/main Translation-en [474 kB]
Get:31 http://security.ubuntu.com trusty-security/multiverse i386 Packages [4,292 B]
Get:32 http://security.ubuntu.com trusty-security/main Translation-en [325 kB]
Get:33 http://gb.archive.ubuntu.com trusty-updates/multiverse Translation-en [7,340 B]
Get:34 http://gb.archive.ubuntu.com trusty-updates/restricted Translation-en [3,847 B]
Get:35 http://gb.archive.ubuntu.com trusty-updates/universe Translation-en [212 kB]
Get:36 http://gb.archive.ubuntu.com trusty-backports/main Sources [9,712 B]   
Get:37 http://gb.archive.ubuntu.com trusty-backports/restricted Sources [28 B]
Get:38 http://gb.archive.ubuntu.com trusty-backports/universe Sources [35.3 kB]
Get:39 http://gb.archive.ubuntu.com trusty-backports/multiverse Sources [1,898 B]
Get:40 http://gb.archive.ubuntu.com trusty-backports/main amd64 Packages [13.3 kB]
Get:41 http://security.ubuntu.com trusty-security/multiverse Translation-en [2,201 B]
Get:42 http://gb.archive.ubuntu.com trusty-backports/restricted amd64 Packages [28 B]
Get:43 http://gb.archive.ubuntu.com trusty-backports/universe amd64 Packages [43.2 kB]
Get:44 http://security.ubuntu.com trusty-security/restricted Translation-en [3,357 B]
Get:45 http://gb.archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1,571 B]
Get:46 http://gb.archive.ubuntu.com trusty-backports/main i386 Packages [13.3 kB]
Get:47 http://security.ubuntu.com trusty-security/universe Translation-en [90.2 kB]
Get:48 http://gb.archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
Get:49 http://gb.archive.ubuntu.com trusty-backports/universe i386 Packages [43.2 kB]
Get:50 http://gb.archive.ubuntu.com trusty-backports/multiverse i386 Packages [1,552 B]
Get:51 http://gb.archive.ubuntu.com trusty-backports/main Translation-en [7,503 B]
Get:52 http://gb.archive.ubuntu.com trusty-backports/multiverse Translation-en [1,215 B]
Get:53 http://gb.archive.ubuntu.com trusty-backports/restricted Translation-en [28 B]
Get:54 http://gb.archive.ubuntu.com trusty-backports/universe Translation-en [36.8 kB]
Hit http://gb.archive.ubuntu.com trusty Release                               
Ign http://gb.archive.ubuntu.com trusty Release                               
Ign http://gb.archive.ubuntu.com trusty/main Sources/DiffIndex                 
Ign http://gb.archive.ubuntu.com trusty/restricted Sources/DiffIndex           
Ign http://gb.archive.ubuntu.com trusty/universe Sources/DiffIndex             
Ign http://gb.archive.ubuntu.com trusty/multiverse Sources/DiffIndex           
Ign http://gb.archive.ubuntu.com trusty/main amd64 Packages/DiffIndex         
Ign http://gb.archive.ubuntu.com trusty/restricted amd64 Packages/DiffIndex   
Ign http://gb.archive.ubuntu.com trusty/universe amd64 Packages/DiffIndex     
Ign http://gb.archive.ubuntu.com trusty/multiverse amd64 Packages/DiffIndex   
Ign http://gb.archive.ubuntu.com trusty/main i386 Packages/DiffIndex           
Ign http://gb.archive.ubuntu.com trusty/restricted i386 Packages/DiffIndex     
Ign http://gb.archive.ubuntu.com trusty/universe i386 Packages/DiffIndex       
Ign http://gb.archive.ubuntu.com trusty/multiverse i386 Packages/DiffIndex     
Hit http://gb.archive.ubuntu.com trusty/main Translation-en_GB                 
Hit http://gb.archive.ubuntu.com trusty/main Translation-en                   
Hit http://gb.archive.ubuntu.com trusty/multiverse Translation-en_GB           
Hit http://gb.archive.ubuntu.com trusty/multiverse Translation-en             
Hit http://gb.archive.ubuntu.com trusty/restricted Translation-en_GB           
Hit http://gb.archive.ubuntu.com trusty/restricted Translation-en             
Hit http://gb.archive.ubuntu.com trusty/universe Translation-en_GB             
Hit http://gb.archive.ubuntu.com trusty/universe Translation-en               
Get:55 http://gb.archive.ubuntu.com trusty/main Sources [1,064 kB]             
Get:56 http://gb.archive.ubuntu.com trusty/restricted Sources [5,433 B]       
Get:57 http://gb.archive.ubuntu.com trusty/universe Sources [6,399 kB]         
Get:58 http://gb.archive.ubuntu.com trusty/multiverse Sources [174 kB]         
Get:59 http://gb.archive.ubuntu.com trusty/main amd64 Packages [1,350 kB]     
Get:60 http://gb.archive.ubuntu.com trusty/restricted amd64 Packages [13.0 kB]
Get:61 http://gb.archive.ubuntu.com trusty/universe amd64 Packages [5,859 kB] 
Get:62 http://gb.archive.ubuntu.com trusty/multiverse amd64 Packages [132 kB] 
Get:63 http://gb.archive.ubuntu.com trusty/main i386 Packages [1,348 kB]       
Get:64 http://gb.archive.ubuntu.com trusty/restricted i386 Packages [13.4 kB] 
Get:65 http://gb.archive.ubuntu.com trusty/universe i386 Packages [5,866 kB]   
Get:66 http://gb.archive.ubuntu.com trusty/multiverse i386 Packages [134 kB]   
Fetched 28.9 MB in 58s (493 kB/s)                                             
Reading package lists... Error!
W: GPG error: http://ppa.launchpad.net trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4DF9B28CA252A784
W: GPG error: http://gb.archive.ubuntu.com trusty Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <[email protected]>
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.
[email protected] ~ $

??? any idea please ??? TIA

Mark Greaves (PCNetSpec)

Does running:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4DF9B28CA252A784
sudo mv -v /var/lib/apt/lists /var/lib/apt/lists-broken
sudo mkdir -p /var/lib/apt/lists/partial
sudo apt-get update
fix the issue ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


Hi mark, and Thanks for the reply  :)

EDIT:- I didn't see your entire post  - I'll "do" the rest of the commands and come  back to you. Sorry  :-[



Well, it worked !! Thanks ever so much Mark. You're a star  :)

triggered 138 Mb of updates too !

Of course I'll spare you the details of how I typed in less than half of the commands and "all hell broke loose" .... and how I felt a complete plonker when I scrolled down and saw the rest of your post  ::) - I mean, honestly I just can't get the "staff" ..... oh, er...., wait..... yeah - I am the "staff"  ::) ::) ::)     ;D ;D

Thanks again  :)

I'll mark this as solved  :)

Mark Greaves (PCNetSpec)

You're most welcome Sim :)

BTW, it wasn't necessarily you missing the commands .. I added the last 3 as an edit, probably after you'd first seen the post.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.


Ah!! No worries - Thought I was losing the plot !!

Any idea what caused this? ( and does it matter ??! )

thanks again for your help.

Mark Greaves (PCNetSpec)

WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.