Similar topics mod installed, currently shown at the end of a topic

Scangearmp2 SOLVED.

Started by 19goalie50nxQ, December 18, 2020, 09:58:07 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Further to my recent request for help with installing the scangearmp2 for use with my Canon TR8550 printer. The problem was solved for me to be able to use scangearmp2 with Simple Scan, however now when I receive Software Updates included is one for scangearmp2. But now when I install the updates the scangearmp2 won't and I receive a notice as shown on the attachment. I have to quit the scangearmp2 update to enable the other updates to install. I've now received the scangearmp2 update several times and each time I quit it.                                                                                                                                                                                                                                                        My question is, should I uninstall the scangearmp2 and then, next time the scaneramp2 update appears reinstall. I'm reluctant to uninstall the present scangearmp2, which I did through the instructions given to me by Rich J, as this is working perfectly.


As far as I can tell (I've never used it), Scangear is provided by Canon solely for installing Canon software/drivers.  Now that you've installed your printer, do you need Scangear?  If  not, then I suggest that you un-install it as you can re-install it at a later date if necessary.   

I have used Canon printers in the past and have not needed any helper software - just lucky, I guess. 



Hello Keith.

Thanks for your reply, I used the default scanner on the Canon printer settings originally but found it wasn't as user friendly as the Linux Simple Scan I used with the Epson printer which the Canon printer has replaced. I've been satisfied with the Linux scangearmp2 since installing it as per Rich J instructions, which I now use with the Linux Simple Scan.   
                                                                                                                                                                                                                                                                                 My concern is, if I uninstall the scangearmp2 and reinstall the update as you suggest I may make a mess of things. So for the time being I'll stick with 'quitting' the scangearmp2 updates when they appear, unless I can be assured that installing the update will be okay.

Best regards.



Not sure what you mean by re-installing the update.  If it can't update scangear due to a "competing" file then starting from scratch might be the best way to go. 
It looks like installing the Linux Scangear has left in place a Canon file that Update objects to, preventing the update. 

Since you know how to install the Linux Scangear successfully I suggest that you remove Scangear completely and re-install it.  If that doesn't work you might need to use Synaptic Package Manager to remove the offending file(s) but we'll deal with that if necessary. 

Hope that helps.

Rich J

As has been previously stated - if all you want to do is scan then Simple Scan 'should' fulfil that without further ado - and it would not work 'with' Scangear anyway, they would just exist side-by-side on the computer.  As Keith says, uninstall all Scangear files and test Simple Scan again to se if it does what you require.  You can always reinstall Scangear afterwards if needs be.

To completely remove Scangear:  Open a Terminal (click on the icon or press "Ctrl + Alt + T") and copy/paste this command after the prompt - sudo apt-get --purge remove scangearmp2 and hit Enter.  Type in your password when prompted and hit Enter again.

You may have to confirm this when Terminal halts (press Y to accept, then Enter) and all traces of scangear will be gone.  This should stop the error messages appearing when updating  ;)



Hi Keith & Rich J.
I've tried both your latest suggestions and removed completely the scangearmp2 as suggested and tried to re-install as per Rich J previous instructions. unfortunately now when trying to re-install I'm unable to do so and get message as shown on the Terminal attachment. I've tried various methods but still unable to install scangeramp2. You will see on the Terminal attachment at the bottom is two error notices dpkg:error and dpkg-error do these have anything to do with not being able to install scangearmp2. NOTE:- Ironically I have not had any scangeramp2 updates since removing the scangearmp2.
I'm sorry to bother you again on this subject I was dubious about removing the scangearmp2 when it was operating successfully with Simple Scan.


Hi Goalie.

Simple Scan has nothing to do with Scangearmp2 (as far as I know) - it is an entirely separate software that works on its own. 
Please let us know if Simple Scan is still working.  If it is, you don't need Scangearmp2. 
The dpkg errors do indicate that Scangearmp2 has not been installed properly (if at all).  As the installation has failed you will not receive any scangearmp2 updates as there is nothing to update.

If Simple Scan is not working, then:
The instructions you are using to install Scangear are explicitly for Ubuntu 20.04.  What version of Ubuntu are you using?  If not 20.04, then the installation might not work, but other users reporting on that web page also have the same problem as you when changing to Ubuntu 20.04. 
The same web page says:
"To install UFRII or LIPSLX printer driver for Canon LBP/iR printers, install one of following packages for your devices via apt command:
I can't help you with that as I haven't a clue what it means.

You might like to try downloading and installing ScanGear MP Ver. 3.60 from the Canon site: https://my.canon/en/support/0100949101/1 which looks a lot simpler!


[EDIT]  I've just installed ScangearMP2 Ver. 3.60 on my Ubuntu 18.04.  The installation went OK, although I don't have a Canon printer/scanner to try it on.


Hi Keith.

Thanks for your quick reply, didn't expect a reply until after Christmas, I'm using Linux Mint 19.3 Cinnamon 64bit. Simple Scan isn't working. I've downloaded the ScanGear MP Ver. 3.60 from the Canon site this downloads as :- scangearmp2-3.60-1-deb.tar.gz file. Unfortunately I've no idea how to read or open this type of file can you help me with this.

I don't want to interrupt your Christmas celebrations so you don't have to reply until after Boxing day if you are busy



Hi Goalie.

I don't have Mint on any of my computers but I believe Mint is based on Ubuntu which I do use, so the following instructions might work.

To create directory .scangear in home directory
Start a terminal session:   Ctrl+Alt+t
mkdir .scangear     {Note the "."}

To extract the files
In your file manager, navigate to the scangearmp2-3.60-1-deb.tar.gz file that you put in Downloads.
Right click on that Scangear file then in the context menu that appears, select Open with.. then select Archive manager.

In the window that appears:
   Click on Extract
   When the file window appears, go to your home directory then
   Enter Ctrl+h to display hidden directories. Then:
   Navigate to the .scangear directory that you created in your home directory and double-click on it
      (This will show the empty directory)
   Click on the Extract button (top right?).
If you are invited to "show the files" or "Close", choose "close".  You can also close the Archive Manager window.

To change the PATH variable so it can find your scangear files:
Return to your terminal session.
gedit  .profile  Note the "."!

In the editor window, make the last two lines look like:
# set PATH so it includes user's private bin directories

Save the file and exit the gedit editor.


Now install your files:
In your terminal enter:
cd .scangear/scangearmp2-3.60-1-deb
chmod +x install.sh
install.sh  This should install scangearmp2

I can't guarantee that this will work in Mint but it works fine on my Ubuntu 18.04.
Good Luck!



Hi Keith.

Thanks for your quick reply, I have to stress that I'm a novice with Linux so I may not do things correctly as per your instructions. So I'm having difficulty in following all your instructions (not your fault)  Can you clarify some points for me to do with your instructions as follows:-   
    1. To create .scangear in Home directory.

I've taken this to mean create a folder then from there open Terminal and enter                 Code :- mkdire  .scangear  (See attachment 'A') (Not sure where the "." is)

    2. To extract the files.

From my Home directory I select the scangearmp2-3.60-1-deb.tar.gz file from the Downloads folder. Right click on the Scangear file and from the menu  Open with Archive Manager  I clicked on the Extract button in (top L.H. corner) Then a box with the 'Show the files' or 'Close' I chose 'Close' and closed the Archive Manager.

    3. To change the PATH variable so it can find your scangear fles. (This is where I struggled)

            Returned to Terminal session entered Code: - gedit .profile  (Not sure where the "." is)

            Not sure what is meant by :- In the editor window, make the last two lines look like:-
#set PATH so it includes users private bin directories. See Attachment 'B'  Can you illustrate how I do it.                      What do  you mean by bin directories.


Hi Goalie,

It seems that I didn't do a good job of explaining the process - sorry.  It looks like you have extracted the files from the *.tar.gz file but we don't know where they have been extracted to.
Never mind:  let's do it one step at a time.
By the way - please don't attach images of the whole window as it takes up too much space on the server.  Simply highlight the text as you would in an office document by clicking and dragging the cursor over all the text then copy it using Ctrl+Shift.  You can then paste it into your post with Ctrl+v.

First of all, start a Terminal Session (Ctrl+Alt+t).  Then enter: mkdir .scangear The "." is the normal decimal-point/full-stop on your keyboard. 
Check that you have created the directory by entering: ls -a You should see ".scangear" listed in the output.  Let me know if it's there (or not!) and we'll go from there. 
Just for practice; copy and paste into your reply the line containing ".scangear".


{By the way: the "."  before a file name makes it "hidden" in that it is not normally displayed.  The "-a" in the list command shows all files in the directory including hidden ones}


Hi Keith,

Thanks again for your quick reply hope I'm not spoiling your Christmas celebrations and note your clarification of where the full stop is.

I've started a Terminal session and added the Code :- mkdir  .scangear  that was the easy bit.

Now I don't fully understand the next instruction :-                                                                                                                                                                                               Check that you have created the directory by entering: Code:-  ls -a
Question where do I do this in Terminal? and where is the directory created and where will I find the output to check if "scangear" has been created.

Finally what is this operation :- Just for practice; copy and paste into your reply the line containing ".scangear".



The command you entered (mkdir .scangear) created the directory ".scangear" in your home directory.  (You did press the Enter key, didn't you?!)
If you now type in the terminal the command ls -a followed by pressing the Enter key this will print on the terminal all the files/directories in your home directory.  For example, here is part of my output:
[email protected]:~$ ls -a
.                      Documents        .lesshst          .sane
..                     Downloads        .local            .scangear
.adobe                 .dropbox         .macromedia     

I described in my previous post how to copy text from your terminal and paste it into your post.  Here it is again:
Simply highlight the text as you would in an office document by clicking and dragging the cursor over all the text (or just the line containing .scangear) then copy it using Ctrl+Shift.  You can then paste it into your post with Ctrl+v.  I want you to do this so I can see that your really have created the .scangear directory. 



Hi Keith.

Here is copy of section off Terminal with ".scangear " shown amongst them as requested.

'Scam email.png'
'Scanned Docs 2020'

Hope this is what you are looking for and look forward to further instructions.




You have a wrongly-named " .scngear" also, but don't worry about it. 
Now I want to check if you have anything in the .scangear directory.  Please enter the following commands into your terminal (followed in each case by the Enter key): cd .scangear then ls Now copy all the lines from the ls command line you entered to the end of the last line, and post them here.