Forums updated to SMF version 2.1.1

Login loop in Kali linux 2021.4 [SOLVED]

Started by Adithyan, December 25, 2021, 02:23:10 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I am using kali linux 2021.4 xfce . I have done some .vnc folder Xstartup file configuration and rebooted the system . But now i am not able to log in ,But I can access the GUI through a VNC session. When i try to type username and password it just ask to again without any error. I have done
sudo apt update
sudo apt upgrade
in the console but not fixed the issue. I have upgraded to 2021.4 a week ago . Pls help if anyone know the answer your help would be appreciate, .Beacause I have not encountered this issue in any distros

Kali 2021.4
4gb ram

inxi -P output
ID-1: / size: 40.95 GiB used: 23.74 GiB (58.0%) fs: ext4 dev: /dev/sda9
ID-2: /home size: 40.94 GiB used: 25.11 GiB (61.3%) fs: ext4 dev : /dev/sda10
ID-3: swap-1 size: 10.18 GiB used: 524 KiB (0.0%) fs: swap dev: /dev/sda11



I don't use VNC myself - but what changes have you made to that config, and have you tried to revert those?

Perhaps it's best to enable SSH and confirm that works if only to avoid locking yourself out completely.

Could you kindly confirm that you're using the same account details for both VNC and at the machine itself (and whether that's root).

Finally, how did you create the VNC account - I seem to recall that VNC users don't always equate to local (/etc/passwd) users (that would explain why you can't login locally!).

Let us know.....