The Linux Community Forum

Support => Internet Connectivity => Topic started by: Tramlink on September 25, 2020, 10:52:16 pm

Title: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Tramlink on September 25, 2020, 10:52:16 pm
Mint 19.3 64bit mate.

I installed this wi-fi adapter and all seemed OK indicator light working and can see the different wi-fi networks.

However, it will not log in to any networks box comes up for password but will not connect.

Any suggestions.
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Keith on September 26, 2020, 12:57:47 pm
Hello Tramlink,

While it's true that Linux is very good at coping with most things one plugs into it, you might be unlucky his time.

If this is the Wavlink Model: WL-WN681A1, https://www.wavlink.com/en_us/product/WL-WN681A1.html (https://www.wavlink.com/en_us/product/WL-WN681A1.html) says "If your computer’s operating system doesn’t install the driver automatically after plugging in, you just need to install the driver from the bundled CD or from Wavlink’s website.
Going to https://www.wavlink.com/en_us/Drivers.html (https://www.wavlink.com/en_us/Drivers.html) and selecting WL-WN681A1-B (there are several versions) shows a pop-up with drivers for Windows and MAC.  Since MAC is Linux based, you might like to try installing MAC drivers from your installation CD. 

Keith
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Tramlink on September 26, 2020, 02:05:44 pm
Thanks for reply. It is a meross model https://www.meross.com/product/35/article/ (https://www.meross.com/product/35/article/)

The drivers are fully installed and working I can see the wi-fi networks but can not log in to the networks the password is rejected.

My old D-Link adaptor logs in just fine with the same password.
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Keith on September 26, 2020, 03:05:20 pm
I did see that one but guessed you would be using the smaller, Wavlink one, also with the AC600 name. 

You seem to have chosen the most appropriate model, and I've not seen anything so supportive of Linux, unless there is something very different about Mint 19 c.f. Mint 18. 
I can't think of anything else except checking the WiFi settings very carefully - which I'm sure you will have done several times. 

Keith
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Keith on September 27, 2020, 05:26:00 pm
I contacted Melross and they replied " we are sorry that we stop supporting this device so it is not suitable for Ubuntu 18 & 20 now.  Sorry for the inconvenience and trouble caused.
Which means Mint 18 to 20, too.  So it looks like you are out of luck this time.  It might be worth contacting [email protected] for info on which of their products would be suitable. 

Keith
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Tramlink on September 28, 2020, 02:06:40 pm
Interesting but they still have drivers on their website for for mint 18.4 and the equipment is working seeing networks but will not let me log in with the password.

Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Keith on September 28, 2020, 02:43:57 pm
Are you using   IPV4 Method = Automatic (DHCP)    and   Security WPA2 Personal  (i.e. everything set to defaults) or do you use something fancy? 
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Tramlink on September 30, 2020, 10:32:30 pm
Yes everything set to default options......... it is so strange.
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting
Post by: Keith on October 05, 2020, 04:52:04 pm
When you attempt to log in, does it just ignore you or is there an error message? 
Does the wifi icon seem to be trying to connect?
Title: Re: AC600 Wireless USB Adapter MWA255 not connecting (Abandoned)
Post by: Tramlink on November 25, 2020, 11:00:53 am
Thanks for the info but have now given up on this adaptor.
Have put a comment on the site where I bought it saying it is no longer working with newer versions of LINUX.
SimplePortal 2.3.3 © 2008-2010, SimplePortal