The Linux Community Forum

Support => Ubuntu => Topic started by: Mark Greaves (PCNetSpec) on November 24, 2011, 12:28:41 am

Title: Installing BricsCAD 11.3.16-3 in 64bit Ubuntu 11.10
Post by: Mark Greaves (PCNetSpec) on November 24, 2011, 12:28:41 am
BricsCAD 11.3.16-3 is a great 3D CAD application for Linux that is compatible with .DWG files .. but it won't run in 64bit Ubuntu.

OK, there is a source tarball, so you could probably compile it for 64bit .. but there is no need, it is quite easy to get it to work in 64bit Ubuntu using the .deb installer ..

Go to the BricsCAD website, register, and download the DEB installer for the latest BricsCAD (11.3.16-3):
http://www.bricsys.com/en_INTL/bricscad/index.jsp (http://www.bricsys.com/en_INTL/bricscad/index.jsp)

And double-click the .deb file to install BricsCAD.

Now open a terminal and run these 3 commands

Install the ia32-libs package:
Code: [Select]
sudo apt-get install ia32-libs

To download (from my dropbox) the required 32bit libgl1-mesa-glx library and symlink as an archive:
Code: [Select]
wget http://dl.dropbox.com/u/11876059/mesa-libs-32bit.tar.gz

To extract the archive to the /opt/bricsys/bricscad/v11 directory:
Code: [Select]
sudo tar -xvf mesa-libs-32bit.tar.gz --directory /opt/bricsys/bricscad/v11/

BricsCAD should now run perfectly :)



If you'd rather not download the library and symlink from my dropbox .. you can download the latest 32bit libgl1-mesa-glx from here:
http://packages.ubuntu.com/oneiric/i386/libgl1-mesa-glx/download (http://packages.ubuntu.com/oneiric/i386/libgl1-mesa-glx/download)

Unpack the .deb .. then copy the -

libGL.so.1.2
libGL.so.1

files to your /opt/bricsys/bricscad/v11 directory.

Be Aware .. DO NOT use the 64bit version of  libgl1-mesa-glx .. it will not work.
SimplePortal 2.3.3 © 2008-2010, SimplePortal