Show Posts

You can view here all posts made by this member. Note that you can only see posts made in areas to which you currently have access.


Topics - pooky2483

Pages: [1] 2 3 ... 17
1
General Help & Advice / [SOLVED] Unable to boot to desktop
« on: November 27, 2018, 12:14:20 pm »
I have just rebooted my computer* and all seemed well until just after the splash screen, when I got this...

BusyBox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) _ <--- flashing cursor

I have already tried boot repair disk and then rebooted and it booted to the same state as above.


* Just before shut-down of the system to reboot, a couple of warnings popped up telling me that it was unable to write to disk, probably something to do with writing the state of the system to disk!

2
News and Events / Trojan miner for Linux removes antiviruses
« on: November 24, 2018, 04:52:52 am »
Found this story on exploit.in (a Russian site)

The Doctor Web specialists have discovered a trojan designed for the extraction of cryptocurrency, which can infect other network devices and remove antiviruses running in the system. The threat received the identifier Linux.BtcMine.174 and is a large script written in the command shell language containing more than 1000 lines of code.

Malware consists of several components. So, when launching, the trojan checks the availability of the server from which it subsequently downloads other modules, and searches for a folder on the disk with write permissions into which these modules will then be loaded. After this, the script is moved to a previously selected folder named diskmanagerd and re-launched as a daemon. For this, the trojan uses the nohup utility. If it is not in the system, it automatically downloads and installs the coreutils utilities package, including nohup.

If the installation is successful on the device, the malicious script downloads one of the versions of the Linux.BackDoor.Gates.9 Trojan. The backdoors of this family allow you to execute commands from attackers and carry out DDoS attacks.

After installation, malware looks for competing miners in the system and, upon detection, completes their processes. If the trojan was not launched on behalf of the superuser (root), it uses a set of exploits to escalate its privileges on the infected system. Analysts of Doctor Web have identified at least two problems exploited by him: these are CVE-2016-5195 (aka DirtyCow ) and CVE-2013-2094 . At the same time, the sources of the exploit for DirtyCow are downloaded from the Internet by the Trojan compiles directly on the infected machine.

After this, the malware tries to find antivirus services running under the names safedog, aegis, yunsuo, clamd, avast, avgd, cmdavd, cmdmgd, drweb-configd, drweb-spider-kmod, esets and xmirrord. If they are detected, the malware does not just end the antivirus process, but with the help of package managers, deletes its files and the directory in which the anti-virus product was installed.

Then the trojan registers itself at startup, downloads and launches a rootkit on an infected device. This module is also designed as a sh script and is based on source code that was previously published in the public domain. Among the functions of the rootkit module, you can highlight the theft of user-supplied passwords for the su command, hiding files in the file system, network connections and running processes. The trojan collects information about network nodes that were previously connected via the ssh protocol and tries to infect them.

After completing all these steps, the Trojan finally launches the miner, designed for the production of Monero cryptocurrency (XMR), in the system. At intervals of one minute, the malware checks to see if this miner is running, and automatically restarts it if necessary. It also connects to the managing server in a continuous loop and downloads updates from there, if they are available.

Source: https://xakep.ru/2018/11/20/linux-btcmine-174/

Source of the above story...
https://translate.google.com/translate?hl=en&sl=ru&u=https://exploit.in/&prev=search

3
I have entered a bug report but it is incomplete due to Dolphin being unable to report its crash properly as the version of the dbg file is a lower version than the version of Dolphin I have installed, which is 4:16.04.3-0ubuntu2.1~ubuntu16.04~ppa1 and the repo version is 4:15.12.3-0ubuntu1

4
I'm having problems with the mv command in terminal.
Basically what I want to do is similar to a copy but only a certain file type and keeping the same directory structure.

5
General Help & Advice / [SOLVED] Installed some books, now can't find them
« on: November 17, 2018, 01:48:30 pm »
I installed some 'books' from Synaptic but cant find them anywhere?
Does anyone know where they get 'installed'?

6
General Help & Advice / Problem removing a source
« on: November 17, 2018, 01:42:38 pm »
I'm trying to remove some sources which are causing problems but I am unable to.
The source I'm trying to remove is 'owncloud'

Ive used
Code: [Select]
grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/*
To get a list of sources, but when I use Discover to list the sources, 'owncloud' is not there.

I get; (I created a gap of a couple of lines so that what I'm trying to remove is easily seen, near the bottom)
(click to show/hide)

I don't know what to do to get rid of the entries.

7
My wifes laptop recently went in to get the screen fixed and it came back not working.
The repair report: 'What we've done... We have repaired the parts listed below. TO HELP PREVENT ISSUES IN THE FUTURE WE HAVE ALSO RESET THE INCORRECT SETTINGS TO DEFAULT. Cleaned your heatsink & fan and tightened some loose screws. We then ran some system checks to ensure your issue has been fully resolved.

nice that they don't tell me exactly WHAT settings they have reset.

Because of their tinkering with things they had no need to tinker with as all they needed to do was replace the laptop lid & screen, I am now unable to connect wirelessly to the internet.

The laptop is an ASUS Notebook X541B running Kubuntu 16.04

8
As the title says, I am unable to configure a network connection to uploaded.net
One glaringly obvious reason is when setting up dolphin network access, I am not required to enter a password anywhere, yet uploaded.net requires a password.

So, the question is, am I wasting my time trying to configure an ftp connection to uploaded.net using Dolphin?

I have tried to install filezilla (3.37.1) but I have no idea how to install the the tar.bz2 archive. I have also tried to install the version in the repo's for 16.04   but I am unable due to dependency issues, which the installation does not inform me of which dependencies it needs.

9
General Help & Advice / Unable to get script working when I need it to
« on: September 13, 2018, 04:52:10 pm »
I'm trying to get a script to work on boot, but I'm having problems.
I want the script to execute after I have got an internet connection as they will be useless if executed before.

I want the script to do three things;
1 connect to a VPN
2 start onedrive (using dolphin, I can access my MS OneDrive folder(s)
3 start GoogleDrive (same as #2)

Yet, when the script is run, nothing happens.
The script

#!/bin/bash
sleep 30
expressvpn connect ukdo
onedrive-d start
google-drive-ocamlfuse /media/pooky2483/EXT-05-8Tb/Google-Drive/

I would also like to be notified which command is being executed, possibly by way of some kind of on-screen message.

10
As the title suggests, I can't render a clip as Kdenlive is not being allowed to write the file.
I've tried what you, Mark, suggest in THIS thread (post#4). Yet, I am still unable to render the file...
The location is '/media/pooky2483/EXT-02-4Tb/Video/Kdenlive/'
How can I change the ownership & permission of the whole drive, except the 'lost+found' folder?

11
General Help & Advice / [ON-HOLD] System Freezing Up Regularly
« on: August 22, 2018, 03:43:37 am »
For the past week (possibly 2), my OS has been freezing up and taking a while to recover itself.
I have had the same couple of programs run at start and not installed any extra programs and only installed what the system wanted to install as updates.
The CPU History in the System Monitor shows the CPU's, either one or all 4 spiking at 100% and the system then locks up with me unable to do anything until the CPU usage drops back to normal.
I have added another tab to show the temp of the CPU and MoBo and they were high, spiking at 80C. I have since cleaned all the dust out and the temp has lowered to a high of 45C and the system still freezes.
I can be simply clicking on another program to bring its window to the front and the system will freeze, sometimes the clock will still show as normal with the seconds cycling though 00 - 59 and sometimes the clock will also freeze.
I have just done a system update and the system is still freezing.


The screenshot above shows the CPU's at 100% and all I had done was to select the System Monitor to show itself.

12
I an trying to move files of a certain filetype from many folders to one folder of a specific filetype, such as MKV, MP3, AVI, PDF etc.. etc..
I am using a file recovery program to recover files and it saves them in batches of around 500 of multiple filetypes.
What I want to do is put each filetype into their own folder.

I am currently doing this manually, which is going to take a lonnnnnng time as there's nearly 1000 folders so far.

How can I do this in terminal using mv recursively (if it can do that).

13
I've installed testdisk and searched for an answer on how to install the gui but was unable to find the solution.
I found THIS thread but even after trying it, I get a warning that it's not production ready!!!

Even though I click on the 'OK', the program stops.

Is there any way I can get the GUI installed?

14
I'm having issues with Firefox.
The issue is the 'tooptips', they are appearing as black-on-black.

I've been on the Mozilla forum and someone sugegsted I upgrade to the next GTK Theme (Currently 3).
Would it be OK to do that or would it make the system unstable?

15
I was able to print earlier, 26 March was the last time I was able then for some reason I am now unable to get anything to print, even 'Test Print' does not work.
I'm using an Epson ET3600.
I've tried rebooting both printer & PC, still nothing prints.
I thought it could be to do with the size of what I'm printing, a book with over 600 pages, so I used a PDF editor and chopped it up into 100 pages and I still get the same result... nothing prints.

I also tried searching to see if anyone else had the same problem, but did not find a solution!

I'm at a loss at to figure out how to fix it!

Pages: [1] 2 3 ... 17

SimplePortal 2.3.3 © 2008-2010, SimplePortal