Show Posts

You can view here all posts made by this member. Note that you can only see posts made in areas to which you currently have access.


Topics - chrissymac234

Pages: [1]
1
Linux Support / Mint won't update - out of memory? SOLVED!
« on: August 27, 2021, 09:03:21 pm »
Hi.

I hope someone can help me. For a while I've been getting error messages when updating. Today, as well as an error message, it said I would out of memory. I have no idea what to do.

This was the message today:

Preconfiguring packages ...
(Reading database ... 475539 files and directories currently installed.)
Preparing to unpack .../0-python3-samba_2%3a4.11.6+dfsg-0ubuntu1.10_amd64.deb ...
Unpacking python3-samba (2:4.11.6+dfsg-0ubuntu1.10) over (2:4.11.6+dfsg-0ubuntu1.9) ...
Preparing to unpack .../1-samba-common-bin_2%3a4.11.6+dfsg-0ubuntu1.10_amd64.deb ...
Unpacking samba-common-bin (2:4.11.6+dfsg-0ubuntu1.10) over (2:4.11.6+dfsg-0ubuntu1.9) ...
Preparing to unpack .../2-smbclient_2%3a4.11.6+dfsg-0ubuntu1.10_amd64.deb ...
Unpacking smbclient (2:4.11.6+dfsg-0ubuntu1.10) over (2:4.11.6+dfsg-0ubuntu1.9) ...
Preparing to unpack .../3-samba-common_2%3a4.11.6+dfsg-0ubuntu1.10_all.deb ...
Unpacking samba-common (2:4.11.6+dfsg-0ubuntu1.10) over (2:4.11.6+dfsg-0ubuntu1.9) ...
Preparing to unpack .../4-libsmbclient_2%3a4.11.6+dfsg-0ubuntu1.10_amd64.deb ...
Unpacking libsmbclient:amd64 (2:4.11.6+dfsg-0ubuntu1.10) over (2:4.11.6+dfsg-0ubuntu1.9) ...
Preparing to unpack .../5-libwbclient0_2%3a4.11.6+dfsg-0ubuntu1.10_amd64.deb ...
Unpacking libwbclient0:amd64 (2:4.11.6+dfsg-0ubuntu1.10) over (2:4.11.6+dfsg-0ubuntu1.9) ...
Preparing to unpack .../6-samba-libs_2%3a4.11.6+dfsg-0ubuntu1.10_amd64.deb ...
Unpacking samba-libs:amd64 (2:4.11.6+dfsg-0ubuntu1.10) over (2:4.11.6+dfsg-0ubuntu1.9) ...
Setting up linux-firmware (1.187.16) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-81-generic
I: The initramfs will attempt to resume from /dev/dm-2
I: (/dev/mapper/vgmint-swap_1)
I: Set the RESUME variable to override this.
Error 24 : Write error : cannot write compressed block
E: mkinitramfs failure cpio 141 lz4 -9 -l 24
update-initramfs: failed for /boot/initrd.img-5.4.0-81-generic with 1.
dpkg: error processing package linux-firmware (--configure):
 installed linux-firmware package post-installation script subprocess returned error exit status 1
Setting up samba-common (2:4.11.6+dfsg-0ubuntu1.10) ...
Setting up libwbclient0:amd64 (2:4.11.6+dfsg-0ubuntu1.10) ...
Setting up samba-libs:amd64 (2:4.11.6+dfsg-0ubuntu1.10) ...
Setting up libsmbclient:amd64 (2:4.11.6+dfsg-0ubuntu1.10) ...
Setting up smbclient (2:4.11.6+dfsg-0ubuntu1.10) ...
Setting up python3-samba (2:4.11.6+dfsg-0ubuntu1.10) ...
Setting up samba-common-bin (2:4.11.6+dfsg-0ubuntu1.10) ...
Checking smb.conf with testparm
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Server role: ROLE_STANDALONE

Done
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
Errors were encountered while processing:
 linux-firmware
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up linux-firmware (1.187.16) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-81-generic
I: The initramfs will attempt to resume from /dev/dm-2
I: (/dev/mapper/vgmint-swap_1)
I: Set the RESUME variable to override this.
Error 24 : Write error : cannot write compressed block
cpio: write error: Broken pipe
E: mkinitramfs failure cpio 2 lz4 -9 -l 24
update-initramfs: failed for /boot/initrd.img-5.4.0-81-generic with 1.
dpkg: error processing package linux-firmware (--configure):
 installed linux-firmware package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 linux-firmware


I don't know what any of this means. I'd be very grateful for any help.

Thank you.

Pages: [1]

SimplePortal 2.3.3 © 2008-2010, SimplePortal