Recent Posts

Pages: [1] 2 3 ... 10
1
General Discussion / Re: Boot Times & Run Times
« Last Post by steve57 on Today at 06:33:55 pm »
Maybe the “how much faster a system will be once installed to a hard drive” quote goes back a few years to when we had to use CD or DVD to run a live distro?

Nope, the comments I've seen have all been fairly recent. The comment that a hard drive is 10 to 15 times faster (which I thought was a ludicrous claim incidentally) was certainly within last 6 months.
2
Linux Support / Re: Keyboard and mouse problems
« Last Post by Keith on January 23, 2022, 11:30:56 pm »
Hi Mike.

I'm glad that you are pleased with your new system - and didn't have to buy new PSU. 
We look forward with interest to hear the outcome of your mouse experiment.

Keith
3
General Discussion / Re: Boot Times & Run Times
« Last Post by Brian000 on January 23, 2022, 09:04:18 pm »
Hi,

That's an interesting thought..............and I'd agree with your findings - at least based on my usage, I get similar performance (at least to login).... Although I always caveat that I'm not a heavy desktop user (I don't install/start a GUI if I don't need it).

Considering my own (old) hardware - I certainly find that CD and DVD is noticeably slower than either USB or HDD. For a few years, I actually installed that O/S onto a USB3.0 (600MB/s) which was plugged into a USB2.0 port (being only 60MB/s). This had minimal performance loss when compared against my standard 5400RPM HDD (100MB/s) installation. At present I use a SSD (530MB/s) which is plugged into the same old SATA2 port (being only 300MB/s)...   so based on that, it would appear that my SSD is by far my best option - but in reality, it is all very insignificant.
(I'm unsure if those figures are correct, I grabbed them from the internet solely for this post!)

It's probably worth considering that many of the boot processes are not reading from disk, but they are initialising hardware and negotiating network, etc - which may explain why "time to boot" is pretty consistent...
4
Linux Support / Re: Keyboard and mouse problems
« Last Post by mikep on January 23, 2022, 07:42:07 pm »
Hello Everybody,

I finally built the new computer last thursday and so far it's been fine. Much faster than the old one and very quiet (no spinners).

ASUS ROG Strix B450-F Gaming ATX Motherboard, AMD Socket AM4, Ryzen 3000 Ready (£108.48)
AMD Ryzen 5 2600 Processor with Wraith Stealth Cooler (£214)
Corsair Vengeance LPX 8GB (2x4GB) DDR4 DRAM 2666MHz C16 Memory Kit - Black (£32.49)
Kingston 250GB NV1 NVMe PCIe SSD (£23.74)
Total £378.71

I'm very pleased with it. Thank you all  for your help and your time. In the end it was a satisfying experience to build another computer and have it boot first time. I went for 8GB of RAM because that's more than enough for my needs and easily doubled if my requirements change. I'm still marveling at how much easier a build is without all those bulky HDDs and ribbon cables. Not to mention that the motherboard doesn't need an I/O shield.I've always found them to be the thing that made me curse the most after the first three or four attempts to get them in place.

Keith - I didn't need a new PSU. The existing one was younger than the rest of the box. I replaced it when the original one failed and killed a couple of hard drives!

All in all very pleased, but here's the surprise. It didn't fix the original problem! Unbelievable. It's essentially a completely different computer yet the problem persisted. I swapped the keyboard and that didn't work, so I swapped the mouse. So far so good...

I won't close this thread right now as I'm waiting to see whether the mouse was the culprit, If it was I'm down about £350 but, as I said, I'm very pleased with the new build. Not least because it's capable of running more VMs without breaking a sweat. And £378.71 isn't a lot to pay for this kind of upgrade.
5
General Discussion / Re: Boot Times & Run Times
« Last Post by Gaz511 on January 23, 2022, 06:55:11 pm »
Same as you running live in USB just as quick as a full install, even quicker if the the distro loads to ram like puppy linux.
 Maybe the “how much faster a system will be once installed to a hard drive” quote goes back a few years to when we had to use CD or DVD to run a live distro?
6
General Discussion / Boot Times & Run Times
« Last Post by steve57 on January 23, 2022, 01:07:49 pm »
I've seen it stated on various forums how much faster a system will be once installed to a hard drive, rather than running in live mode from a USB stick. In fact I've even seen figures of 10x and 15x faster quoted. Sorry but I haven't yet seen any evidence to support this. I've tried a vast number of different distros over the last couple of years or so, and I haven't yet come across one that has been significantly quicker once installed. Please note I said "significantly". Ok, so there's been one or two that have perhaps booted 5 seconds faster, but certainly nothing to get excited about.

I've also noticed that, although there's probably the odd exception, most distros appear to boot up in roughly the same time, again perhaps 5 seconds difference here and there. Distros that are specifically classed as "lightweight" don't boot up any quicker than others. Where I do notice a difference is with different desktops, e.g. something with Gnome will take longer than an XFCE set up, as you would expect.

Interestingly the other occasion I see a difference is with 32 bit systems, where they are still available. Although all my machines are 64 bit, a 32 bit distro will boot quicker than it's equivalent 64 bit version, and use less RAM. So there are other reasons for running 32 bit, other than having a 32 bit machine.

But as for an installation being much faster than a USB stick? Nope, not seen it yet. Perhaps that only applies to those with the latest Ryzen processor and 64Gb of RAM. Well I'm not in that position and never likely to be.

I'm not looking for any solutions or fixes, I assume a lot of it is simply down to my 12 year old machines. It's just something I felt like rambling about on this cold, grey, dreary Sunday and wondered if anyone else has made any similar observations? Or is it just me?

Thanks
7
Linux Support / Re: HALP. cannot set up vpn on ubuntu
« Last Post by Mad Penguin on January 21, 2022, 02:13:43 pm »
Hi dexxin,
It may be that you need to use "openvpn" specifically, but if not, you might like to consider; https://tinc-vpn.org/ , I struggled with OpenVPN for many (many) years before finding tinc. I've now been on tinc for probably 4-5 years, the two have quite different characteristics, but I think I would struggle to find a point where OpenVPN wins ..
8
Linux Support / Re: HALP. cannot set up vpn on ubuntu
« Last Post by Keith on January 21, 2022, 01:25:05 pm »
Hi Dexxin - and welcome to the Forum.

Quote
have had this exact set up before and never ever had an issue
Do you mean on this computer with this operating system? 

Please list the contents of /etc/openvpn

Keith
9
Linux Support / Re: SSH Key authentication
« Last Post by Mad Penguin on January 21, 2022, 01:13:26 pm »
As I understand it; on most desktops (?) when you log in it should activate the desktop's chosen keychain application and it should prompt you for a password to unlock your keychain. Once unlocked, subsequent use of the keychain should be transparent. (i.e. no password needed at the point of use, because it pulls it from the keychain) So to add your private ssh key to your keychain;
Code: [Select]
ssh-add .ssh/<private key>
(then enter your password) To ensure it's use, in .ssh/config;
Code: [Select]
Host *
   AddKeysToAgent yes
   IdentityFile ~/.ssh/<private key>
As for not using a password (  :)  ) , consider that some random bit of code in some random bit of software that you've installed onto your computer decided it's going to issue a single command at some point in it's lifecycle to copy .ssh/* to some random location out there on the Internet. If it were to happen (looking at toolchain polution at the moment, the odds seem high) , a passwordless key is potentially going to give a remote attacker passwordless access to your remote systems. (a short password, pretty much the same) Current recommendation seems to be >= 15 characters, avoiding dictionary words, dates etc. I know it's a pain (esp. if agent/keychain isn't set up) but for my $0.02, no passwords isn't worth the risk  :)

=== UPDATE ===
I appreciate this is a bit vague, bit it does differ from system to system. Just to prove the point I setup a clean machine to provide a concrete example. Assuming you have a working ssh setup and have done as described above, and assuming you're using a KDE-Plasma desktop (which is my current choice of desktop), you also need to create; ~/.config/autostart-scripts/ssh-add.sh
Code: [Select]
#!/bin/bash 
ssh-add $HOME/.ssh/id_rsa $HOME/.ssh/anotherkey </dev/null
Make sure it's excutable;
Code: [Select]
chmod a+x ~/.config/autostart-scripts/ssh-add.sh
Then log out .. when you log back in, it should ask if you want to allow the desktop to unlock the Wallet, select allow Always, then it will ask for your ssh password(s), make sure you click the "save" tickbox under the password. If you check a "ssh" command, it should now work without asking for a password. If you now log out and in again, it should ask for your wallet password to unlock your wallet (if your wallet password is different from your login password), but after that you should be good to go ... If you now launch the KDE Wallet manager, you should see an entry for "ksshaskpass", and if you open that, under password you should see your key(s).
10
Linux Support / HALP. cannot set up vpn on ubuntu
« Last Post by dexxin on January 21, 2022, 04:27:21 am »
hey guys. i have been going absolutely stir crazy, on this for going on 6 hours straight! cannot get my vpn settings to load at all. i have tried everryytthhiinngg. all sudo commands, zip commands, installed software, lost my marbles and getting the same error. below is the code for the open vpn protocol for perfect privacy. any idea what's going on please? much appreciation. ps have had this exact set up before and never ever had an issue. wahhhhh.


terminal code is as follows (red text at bottom is the root issue):



[email protected]:~$ sudo apt update && sudo apt install openvpn resolvconf

[sudo] password for roni:

Hit:1 http://archive.canonical.com/ubuntu focal InRelease

Hit:2 http://archive.ubuntu.com/ubuntu focal InRelease

Get:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]

Get:4 http://archive.ubuntu.com/ubuntu focal-security InRelease [114 kB]

Get:5 http://archive.ubuntu.com/ubuntu focal-backports InRelease [108 kB]

Get:6 http://archive.ubuntu.com/ubuntu focal-security/main Sources [198 kB]

Get:7 http://archive.ubuntu.com/ubuntu focal-security/main amd64 Packages [1,178 kB]

Get:8 http://archive.ubuntu.com/ubuntu focal-security/main i386 Packages [363 kB]

Get:9 http://archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages [676 kB]

Get:10 http://archive.ubuntu.com/ubuntu focal-security/universe i386 Packages [532 kB]

Fetched 3,283 kB in 2s (2,059 kB/s)                     

Reading package lists... Done

Building dependency tree       

Reading state information... Done

3 packages can be upgraded. Run 'apt list --upgradable' to see them.

Reading package lists... Done

Building dependency tree       

Reading state information... Done

resolvconf is already the newest version (1.82).

openvpn is already the newest version (2.4.7-1ubuntu2.20.04.3).

0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

[email protected]:~$ cd /etc/openvpn/

[email protected]:/etc/openvpn$ sudo unzip -j linux_op24_udp_v4_AES256GCM_AU_in_ci.zip

unzip:  cannot find or open linux_op24_udp_v4_AES256GCM_AU_in_ci.zip, linux_op24_udp_v4_AES256GCM_AU_in_ci.zip.zip or linux_op24_udp_v4_AES256GCM_AU_in_ci.zip.ZIP.

[email protected]:/etc/openvpn$
Pages: [1] 2 3 ... 10

SimplePortal 2.3.3 © 2008-2010, SimplePortal