Author Topic: Duel-Boot Windows 7 and Linpus  (Read 8107 times)

0 Members and 1 Guest are viewing this topic.

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #15 on: August 24, 2012, 12:52:49 am »
Ok, I went with Linux Mint 32-bit with codecs. Thanks for helping me choose  :)

My netgear version is WG111v3 (old but reliable). As for how I got it to work on Linpus, I really do not know. I was playing around with the wireless settings (turning it off and on) but after I did it about 8 times, my wireless network popped up and I was able to connect. Since that moment, it was able to connect instantly.

EDIT: I already downloaded 32-bit but can download 64-bit if you seriously think I would need it I will download the 64-bit as well.

I will try to override Linpus with Mint first and if that doesn't work, delete it from within Mint/Win7. Thanks again for your help.
« Last Edit: August 24, 2012, 01:00:28 am by joshbl56 »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #16 on: August 24, 2012, 01:20:04 am »
In Ubuntu, to get the WG111v3 working, you just have to connect with an ethernet cable .. then run:
Code: [Select]
sudo apt-get install linux-firmware-nonfree

Then it should show up in "Addittional Drivers"

It may be that Mint already includes the nonfree firmware (so it may work out of the box), but if it doesn't .. the instructions will be the same :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #17 on: August 24, 2012, 01:49:11 am »
Thank you for the help :)

I checked GParted for the sda5 partition and this is what came back:

(click to show/hide)

I'm not sure if this is normal or what but I don't want to mess anything like this up (all I've ever had to do was make freespace for Ubuntu and then install, not override others so sorry that I'm not that useful).

EDIT:

Also, I got my netgear adapter to connect in the exact same way I had it connect in Linpus. The network wasn't originally connecting (or even showing up for that matter) but I just changed the wireless from off to on a few times and it connected around the 6th time.
« Last Edit: August 24, 2012, 01:51:54 am by joshbl56 »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #18 on: August 24, 2012, 02:09:08 am »
OK, you can delete

/dev/sda5
/dev/sda6
and
/dev/sda7

You can leave the /dev/sda4 extended partition .. or delete it .. shouldn't matter.

just make SURE you DO NOT DELETE sda1, sda2, and sda3  ;)
« Last Edit: August 24, 2012, 02:12:12 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #19 on: August 24, 2012, 02:20:17 am »
OK, here comes the super fun part where I get to tell you GParted refuses to let me delete them. Here are the images when trying to delete sda5 and sda6

(click to show/hide)

(click to show/hide)

It wouldn't even let me click delete for sda4 and sda7.


EDIT

OK, I figured out how to delete sda4-sda7. I had to right-click sda7 and click swapoff which made it linux-swap instead of logical partition (I don't know if this is bad or not but it didn't affect sda1-sda3). I was able then able to delete all the extras and now have a little under 200GB of unallocated space. I will install mint in this and we should be done. Thank you for all your help!. Seriously, without your help I still would have been freaking out over Linpus. I will post if it worked or not.
« Last Edit: August 24, 2012, 02:24:17 am by joshbl56 »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #20 on: August 24, 2012, 02:26:35 am »
Did you navigate into the linpus directory whilst booted to the LiveDVD ? .. as that would have mounted the partition.

(gparted will not delete mounted partitions)

if so, reboot to the LiveDVD, then without doing anything else .. run grparted and try again.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #21 on: August 24, 2012, 03:04:37 am »
I was able to successfully install Linux Mint and only 1 big (and weird) problem (which is good). Every time I restart my computer, it will go through BIOS but will then pop up saying my screen has been changed to 1024x768 (the normal resolution) and 60 Hz. It basically stops me from seeing the bootloader completely. The first time it happened, I just let it continue on and it booted into Linux Mint. The second time it happened, I clicked down and left once, which booted me into safe mode for Linux Mint. Here are what each one does:

1. Boots into Linux Mint
2. Boots into Linux Mint (Safe Mode)
3. Boots into a memory test
4. Boots into a memory test (Same as 3)
5. Boots into Recovery Management (Same as earlier)
6. Boots into Windows 7

I would guess this to be all (7 is just Windows 7 again). Any answers to why this is happening?

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #22 on: August 24, 2012, 03:13:46 am »
Is this a message from the monitor ?

Hmm .. I wonder if mint have set a vesa mode in the grub bootloader

What are the contents of:
Code: [Select]
gedit /etc/default/grub

Do you know the resolution BEFORE it switches ?
« Last Edit: August 24, 2012, 03:16:35 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #23 on: August 24, 2012, 03:21:52 am »
I also thought it was just the monitor so I turned it off and back on, clicked the menu button, tried to change the sound volume and brightness but nothing happened.

Here is the results from the terminal (another window popped up with this in it):

(click to show/hide)

Also, I believe the resolution is 800x600 when it first boots up. I have just let it sit there and wait for the message to go away but it hasn't.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #24 on: August 24, 2012, 03:33:45 am »
If it's happening BEFORE the OS is loaded it can ONLY be a message from the monitor.

for now we'll try increasing the timeout for the GRUB menu .. thenn I'm off to bed, so we'll pick this up tomorrow.

Run:
Code: [Select]
sudo gedit /etc/default/grub

Find the line that read:-

GRUB_TIMEOUT=10

and change it to:

GRUB_TIMEOUT=60

SAVE the file and exit gedit.

Now back in the terminal, run:
Code: [Select]
sudo update-grub

It should now sit at the grub screen for 60 seconds before automatically booting Mint .. hopefully that will be long enough for the messaage to disappear.

As I said, we'll pick this up again tomorrow .. when we can try telling the GRUB bootloader to stay at 800x600
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #25 on: August 28, 2012, 12:28:28 am »
Ok, sorry I was gone the whole weekend. Personal matters came up and I didn't have time to reply or even access my computer.

I was loading the grub bootloader and noticed that I had taken the message the wrong way (sort of). It tells me to change my resolution to 1024x768 and 60 Hz, not  that it was changed into 1024x768. I was one letter off and made a mistake. Is there anyway for me to the resolution for the grub page to 1024x768?
« Last Edit: August 28, 2012, 12:58:47 am by joshbl56 »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #26 on: August 28, 2012, 01:04:15 am »
YES :) .. you just need to add vesa=791 to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub

Open a terminal, and run:
Code: [Select]
sudo gedit /etc/default/grub

Find the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vesa=791"

Visually check that line to be sure it's EXACTLY as above .. then SAVE the file, and exit gedit.

Now back in the terminal run:
Code: [Select]
sudo update-grub

When that command has finished and left you back at an $ prompt .. reboot to test



Other Linux vesa modes are listed here:
http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Linux_video_mode_numbers
« Last Edit: August 28, 2012, 01:06:48 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #27 on: August 31, 2012, 01:44:37 am »
Hello again!

I haven't been able to post for a bit as I have been away from this computer for a few days. I had it working after a reboot (at least, for the grub part) but I couldn't see the actual loading (load screen?) as the message kept popping up. I didn't think too much about it as I finally had some kindling on the grub.

I left my computer off for the few days I didn't post and came back today to find that the grub and load screen both had the message! I tried removing the vesa= 791 and restarting it, which didn't do anything, and then replacing it but nothing changed.

Do you have another solution for this problem? I turned off the screen and turned it back on and it showed these two numbers:

H= 93 kHz
V= 58 Hz

Do they mean anything to you?
« Last Edit: August 31, 2012, 01:47:27 am by joshbl56 »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #28 on: August 31, 2012, 12:04:08 pm »
What graphics card do you have ?

Can you open a terminal and run:
Code: [Select]
sudo lshw -C display
and post back the results.

And can you send the full contents of:
Code: [Select]
gedit /etc/default/grub



FYI, those 2 numbers are probably being displayed by the monitor .. either displaying the current horizontal (H) and vertical (V) scan rates, or if the signal is "out of range" it might be displaying the "maximum" vertical and horizontal sync rates it can handle.
« Last Edit: August 31, 2012, 12:35:46 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline joshbl56

  • Jr. Member
  • **
  • Posts: 15
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Duel-Boot Windows 7 and Linpus
« Reply #29 on: September 02, 2012, 03:01:23 am »
ok, to the first one, this pops up:

Code: [Select]
PCI (sysfs)

and then:

Code: [Select]
  *-display               
       description: VGA compatible controller
       product: C61 [GeForce 6150SE nForce 430]
       vendor: NVIDIA Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:22 memory:fb000000-fbffffff memory:e0000000-efffffff memory:fa000000-faffffff memory:febc0000-febdffff

For the second part:

Code: [Select]
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=60
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vesa=791"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal