Author Topic: Ralink wireless card does not work [SOLVED]  (Read 160991 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #135 on: October 12, 2013, 11:23:32 am »
did it compile  ?

does:
Code: [Select]
modinfo rt3290sta
return anything .. yes or no will do
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline vishal

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #136 on: October 12, 2013, 11:45:13 am »
Yes

Code: [Select]
[email protected]:~$ modinfo rt3290sta
filename:       /lib/modules/3.2.34-030234-generic/kernel/drivers/net/wireless/rt3290sta.ko
version:        2.6.0.0_rev1
srcversion:     13F483178C6DF2E02D874C3
alias:          pci:v00001814d00003290sv*sd*bc*sc*i*
depends:       
vermagic:       3.2.34-030234-generic SMP mod_unload modversions
parm:           mac:rt28xx: wireless mac addr (charp)

The Linux Community Forum

Re: Ralink wireless card does not work [SOLVED]
« Reply #136 on: October 12, 2013, 11:45:13 am »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #137 on: October 12, 2013, 12:25:13 pm »
I know this will be awkward, but just copy the output to a text file and save it to your desktop.

boot to 3.2 and post the output from:
Code: [Select]
lsmod
and
Code: [Select]
sudo lshw -C network
and
Code: [Select]
ifconfig
and
Code: [Select]
iwconfig
and
Code: [Select]
rfkill list
and
Code: [Select]
iwlist scanning
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline vishal

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #138 on: October 12, 2013, 04:24:01 pm »
Here are the output:

Code: [Select]
[email protected]:~$ lsmod
Module                  Size  Used by
bnep                   18281  2
rfcomm                 47604  0
bluetooth             180153  10 bnep,rfcomm
snd_hda_codec_realtek   223932  1
snd_hda_codec_hdmi     32429  1
parport_pc             36962  0
snd_hda_intel          33773  3
snd_hda_codec         122159  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
ppdev                  17113  0
snd_hwdep              17764  1 snd_hda_codec
snd_pcm                97275  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi           13324  0
snd_rawmidi            30748  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29990  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
uvcvideo               72627  0
videodev               98259  1 uvcvideo
v4l2_compat_ioctl32    17128  1 videodev
snd                    78547  16 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
radeon                804503  3
soundcore              15091  1 snd
ttm                    76949  1 radeon
snd_page_alloc         18572  2 snd_hda_intel,snd_pcm
drm_kms_helper         42489  1 radeon
drm                   241767  5 radeon,ttm,drm_kms_helper
joydev                 17693  0
i2c_algo_bit           13423  1 radeon
asus_nb_wmi            12667  0
asus_wmi               24411  1 asus_nb_wmi
k10temp                13166  0
video                  19411  0
psmouse                78533  0
sparse_keymap          13890  1 asus_wmi
serio_raw              13211  0
i2c_piix4              13301  0
mac_hid                13253  0
wmi                    19256  1 asus_wmi
rt3290sta            1182379  0
nls_iso8859_1          12713  1
nls_cp437              16991  1
lp                     17799  0
vfat                   17585  1
parport                46562  3 parport_pc,ppdev,lp
fat                    61512  1 vfat
sdhci_pci              18826  0
sdhci                  33205  1 sdhci_pci
usbhid                 47238  0
hid                    99636  1 usbhid

Code: [Select]
[email protected]:~$ sudo lshw -C network
[sudo] password for vishal:
  *-network DISABLED     
       description: Wireless interface
       product: RT3290 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: [email protected]:01:00.0
       logical name: ra0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=RALINK WLAN latency=0 multicast=yes wireless=Ralink STA
       resources: irq:16 memory:fea10000-fea1ffff
  *-network UNCLAIMED
       description: Ethernet controller
       product: AR8161 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list
       configuration: latency=0
       resources: memory:fe900000-fe93ffff ioport:e000(size=128)

Code: [Select]
[email protected]:~$ ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:32 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2624 (2.6 KB)  TX bytes:2624 (2.6 KB)

Code: [Select]
[email protected]:~$ iwconfig
lo        no wireless extensions.

ra0       Ralink STA 

Code: [Select]
[email protected]:~$ rfkill list
0: asus-wlan: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: asus-bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: no

Code: [Select]
[email protected]:~$ iwlist scanning
lo        Interface doesn't support scanning.

ra0       Failed to read scan data : Network is down


Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #139 on: October 12, 2013, 04:40:20 pm »
Boot to 3.2 and run:
Code: [Select]
sudo rfkill unblock 0
or
Code: [Select]
sudo rfkill unblock all

then  check if wireless is still softblocked with:
Code: [Select]
rfkill list
if not .. does wireless work ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

The Linux Community Forum

Re: Ralink wireless card does not work [SOLVED]
« Reply #139 on: October 12, 2013, 04:40:20 pm »

Offline vishal

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #140 on: October 12, 2013, 05:02:12 pm »
Mark - YOU ARE A STAR!!  :) It worked!! :)

Here's the output:

Code: [Select]
[email protected]:~$ rfkill list
0: asus-wlan: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: asus-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no

I have rebooted 3-4 times with 3.2, and I need to manually "Enable Wireless" to make it connect to the wireless.

Many thanks, Mark! :) :)

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #141 on: October 12, 2013, 05:05:55 pm »
Are you saying you need to run "rfkill unblock" every boot ?

BTW, we're not done yet .. we need to set the 32.kernel as the default, so you don't have to select it every time.

And it probably wouldn't hurt to try fix wired in 3.2 too
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline vishal

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #142 on: October 12, 2013, 05:13:03 pm »
Every time the system reboots, I need to manually select 'Enable Wireless' from the drop down menu in the top bar. Yes, we are not done yet. Here's what I am thinking:

1. Auto boot to 3.2
2. Fixing wired connection
3. Getting rid of error messages that show up everytime the system boots.

I am up for a clean install with 3.2 if it helps sorting out all the three with one stroke! Have already backed up my important files.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #143 on: October 12, 2013, 05:21:55 pm »
Can't do a clean install .. at least till we work out why wired doesn't work .. if we install 12.04.1 you won't have a wired connection, which is necessary to install build-essential, which is needed to compile the wireless driver  ::)

Check back here later .. I need to do a little homework on the wired driver, and why wireless is disabled at boot.

Try this .. whilst booted to 3.2 run:
Code: [Select]
sudo update-initramfs -u

Now reboot and tell me if you still need to enable wireless manually

[EDIT]

Also post the contents of
Code: [Select]
gedit /boot/grub/grub.cfg
« Last Edit: October 12, 2013, 05:23:49 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

The Linux Community Forum

Re: Ralink wireless card does not work [SOLVED]
« Reply #143 on: October 12, 2013, 05:21:55 pm »

Offline vishal

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #144 on: October 12, 2013, 05:38:33 pm »
Completely agree with you, Mark!

Yes, after reboot, wireless needs to be enabled manually.

Also, the connection dropped every 3 mins or so. But it has not, since last reboot. Will keep an eye on connection drops, if they happen again on subsequent reboots.

Here's the grub.cfg:

Code: [Select]
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod efi_gop
  insmod efi_uga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_gpt
  insmod ext2
  set root='(hd0,gpt3)'
  search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
  set locale_dir=($root)/boot/grub/locale
  set lang=en_IN
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
  clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
set gfxpayload="${1}"
if [ "${1}" = "keep" ]; then
set vt_handoff=vt.handoff=7
else
set vt_handoff=
fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "${linux_gfx_mode}" != "text" ]; then load_video; fi
menuentry 'Ubuntu, with Linux 3.8.0-31-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
linux /boot/vmlinuz-3.8.0-31-generic.efi.signed root=UUID=1f798a2a-9696-4bc2-bbed-534b8006aa47 ro   quiet splash $vt_handoff
initrd /boot/initrd.img-3.8.0-31-generic
}
menuentry 'Ubuntu, with Linux 3.8.0-31-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
echo 'Loading Linux 3.8.0-31-generic ...'
linux /boot/vmlinuz-3.8.0-31-generic.efi.signed root=UUID=1f798a2a-9696-4bc2-bbed-534b8006aa47 ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.8.0-31-generic
}
submenu "Previous Linux versions" {
menuentry 'Ubuntu, with Linux 3.8.0-29-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
linux /boot/vmlinuz-3.8.0-29-generic root=UUID=1f798a2a-9696-4bc2-bbed-534b8006aa47 ro   quiet splash $vt_handoff
initrd /boot/initrd.img-3.8.0-29-generic
}
menuentry 'Ubuntu, with Linux 3.8.0-29-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
echo 'Loading Linux 3.8.0-29-generic ...'
linux /boot/vmlinuz-3.8.0-29-generic root=UUID=1f798a2a-9696-4bc2-bbed-534b8006aa47 ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.8.0-29-generic
}
menuentry 'Ubuntu, with Linux 3.2.34-030234-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
linux /boot/vmlinuz-3.2.34-030234-generic root=UUID=1f798a2a-9696-4bc2-bbed-534b8006aa47 ro   quiet splash $vt_handoff
initrd /boot/initrd.img-3.2.34-030234-generic
}
menuentry 'Ubuntu, with Linux 3.2.34-030234-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
echo 'Loading Linux 3.2.34-030234-generic ...'
linux /boot/vmlinuz-3.2.34-030234-generic root=UUID=1f798a2a-9696-4bc2-bbed-534b8006aa47 ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.2.34-030234-generic
}
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod part_gpt
insmod ext2
set root='(hd0,gpt3)'
search --no-floppy --fs-uuid --set=root 1f798a2a-9696-4bc2-bbed-534b8006aa47
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ "x${timeout}" != "x-1" ]; then
  if sleep --verbose --interruptible -1 ; then
    set timeout=0
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'System setup' {
fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #145 on: October 12, 2013, 05:45:04 pm »
Wired connection .. seems we need to install the alx driver (which is included in later kernels, but not it 3.2) from a specific version of compat-wireless (yes, even though we're not talking about wireless) .. so in 3.2 run:
Code: [Select]
mkdir ~/alx-driver
then
Code: [Select]
cd ~/alx-driver
then
Code: [Select]
wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2012-02-28-p.tar.bz2
then
Code: [Select]
tar -xvf compat-wireless-2012-02-28-p.tar.bz2
then
Code: [Select]
cd ~/alx-driver/compat-wireless-2012-02-28-p
then
Code: [Select]
scripts/driver-select alx
then
Code: [Select]
make
then
Code: [Select]
sudo make install
then
Code: [Select]
sudo modprobe alx

Does wired now work ?

if so, does it survive a reboot ?

and what's the output from:
Code: [Select]
sudo lshw -C network
now ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline vishal

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #146 on: October 12, 2013, 06:46:12 pm »
Looks like today is THE day! :) Hats off, Mark!

Both, wired and wireless, survived reboots and working (no connection drops) properly. Here's the output:

Code: [Select]
[email protected]:~$ sudo lshw -C network
[sudo] password for vishal:
  *-network               
       description: Wireless interface
       product: RT3290 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: [email protected]:01:00.0
       logical name: ra0
       version: 00
       serial: 1c:3e:84:1f:2d:d1
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=RALINK WLAN ip=192.168.2.5 latency=0 multicast=yes wireless=Ralink STA
       resources: irq:16 memory:fea10000-fea1ffff
  *-network
       description: Ethernet interface
       product: AR8161 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: eth0
       version: 10
       serial: 74:d0:2b:75:af:6e
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx duplex=full firmware=alx ip=192.168.2.4 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:46 memory:fe900000-fe93ffff ioport:e000(size=128)

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #147 on: October 12, 2013, 07:34:10 pm »
OK. setting 3.2 as the default kernel -

Run:
Code: [Select]
sudo gedit /etc/default/grub

Find the line:-

GRUB_DEFAULT=0

and change it to:-

GRUB_DEFAULT="2>1"

SAVE the file, and close gedit.

Back in the terminal, run:
Code: [Select]
sudo update-grub

When that finishes .. Reboot, and see if the 3.2 kernel boot if you just let grub count down.

Once booted you can check which kernel you've booted into with:
Code: [Select]
uname -a

REMEMBER .. if anything goes wrong, you can still manually select the 3.2 kernel from the GRUB menu.



[EDIT]

Would you like to shorten the 10 second GRUB countdown ? (if so, how long would you like it to be ?) .. or indeed would you like to get rid of it altogether now ?

Are you still having to enable wireless manually ?

--
« Last Edit: October 12, 2013, 07:53:10 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline vishal

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #148 on: October 12, 2013, 08:35:01 pm »
When it is let to select the kernel on its own - it selects 3.8.0.29 recovery mode. Here's the output (while in 3.8):

Code: [Select]
[email protected]:~$ uname -a
Linux vishalcomp 3.8.0-29-generic #42~precise1-Ubuntu SMP Wed Aug 14 16:19:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

and here's output while in 3.2:

Code: [Select]
[email protected]:~$ uname -a
Linux vishalcomp 3.2.34-030234-generic #201211161335 SMP Fri Nov 16 18:36:29 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Would you like me to give you the menu/submenu item list in the GRUB?

As for GRUB menu timeout - I think we can halve it - for in future it might just be needed.

And yes, upon reboot this time around, I had to manually enable wireless.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Ralink wireless card does not work [SOLVED]
« Reply #149 on: October 12, 2013, 08:57:56 pm »
My mistake .. run:
Code: [Select]
sudo gedit /etc/default/grub

find the line that reads

GRUB_DEFAULT="2>1"

and change it to

GRUB_DEFAULT="2>2"

SAVE the file and close gedit.

Back in the terminal run:
Code: [Select]
sudo update-grub

Reboot to test.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal