Author Topic: [SOLVED]Dual booting Peppermint and Linpus problems  (Read 6188 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #15 on: September 29, 2012, 04:22:10 pm »
OK, let's try to mount the Linpus partition, then update grub .. with a little luck os-prober will then pick up the Linpus installation and add it to the grub boot menu.

first lets make a mount point:
Code: [Select]
sudo mkdir /mnt/linpus
now try mounting it:
Code: [Select]
sudo mount /dev/sda1 /mnt/linpus
(if there's any output from that last command .. post it here)
if not, what's the output from:
Code: [Select]
ls -a /mnt/linpus
?
« Last Edit: September 29, 2012, 04:24:21 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline member550

  • Jr. Member
  • **
  • Posts: 14
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #16 on: September 29, 2012, 04:28:58 pm »
It does not mount i get this output:

Code: [Select]
sanish@AcerAspireOne ~ $ sudo mkdir /mnt/linpus 
[sudo] password for sanish:
mkdir: cannot create directory `/mnt/linpus': File exists
sanish@AcerAspireOne ~ $ sudo mount /dev/sda1 /mnt/linpus
mount: /dev/sda1: more filesystems detected. This should not happen,
       use -t <type> to explicitly specify the filesystem type or
       use wipefs(8) to clean up the device.

mount: you must specify the filesystem type
sanish@AcerAspireOne ~ $ ls -a /mnt/linpus
.  ..
sanish@AcerAspireOne ~ $

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #17 on: September 29, 2012, 04:34:33 pm »
Hmm .. wonder whay that's there ..

Anywho, try it with a different mountpoint

first lets make a mount point:
Code: [Select]
sudo mkdir /mnt/linpuslite
mount it
Code: [Select]
sudo mount /dev/sda1 /mnt/linpuslite
(if there's any output from that last command .. post it here)
if not, what's the output from:
Code: [Select]
ls -a /mnt/linpuslite
?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline member550

  • Jr. Member
  • **
  • Posts: 14
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #18 on: September 29, 2012, 04:39:52 pm »
The reason it said
Code: [Select]
mkdir: cannot create directory `/mnt/linpus': File exists
is because I tried the whole thing twice. So making another mount point wont work.

EDIT:

Do you think it is because the peppermint partition is ext4 and linpus is ext2?
« Last Edit: September 29, 2012, 04:41:51 pm by member550 »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #19 on: September 29, 2012, 04:42:34 pm »
OK, try:
Code: [Select]
sudo mount -t ext2 /dev/sda1 /mnt/linpus
what's the output from that ?

[EDIT]

Quote
Do you think it is because the peppermint partition is ext4 and linpus is ext2?

Simple answer .. Nope .. it should be able to recognise an ext2 partition without issue .. I'm guessing it's down to the weird union filesystem overlay that Linpus uses for adding an (FAT32) SDcard to the main file system.

Have you got an SDcard  inserted ?
« Last Edit: September 29, 2012, 04:49:42 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline member550

  • Jr. Member
  • **
  • Posts: 14
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #20 on: September 29, 2012, 06:40:04 pm »
It worked! Thank you for your time. The only reason I wanted to keep linpus was If there was some kind of hardware incompatibility with peppermint but everything is working fine anyways.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #21 on: September 29, 2012, 06:44:09 pm »
Do you mean

it worked .. (it mounted) what do I do now ?

or do you mean .. it worked, it's all fixed and dual booting properly now ?
« Last Edit: September 29, 2012, 06:47:27 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline member550

  • Jr. Member
  • **
  • Posts: 14
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #22 on: September 29, 2012, 06:49:56 pm »
Its all fixed I mounted , ran os prober then updated grub. Maybe you can post a tutorial for dual boot now? I'm sure alot of people would find that useful.
« Last Edit: September 29, 2012, 07:04:42 pm by member550 »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Dual booting Peppermint and Linpus problems
« Reply #23 on: September 29, 2012, 07:48:17 pm »
Thanks for the update .. I don't think I'll bother with a dualboot tutorial, as by far the majority have the 8GB SSD model and there isn't room .. but at least we now know how to fix it if anyone asks :)
« Last Edit: September 29, 2012, 09:11:23 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal