Updates:

Similar topics mod installed, currently shown at the end of a topic

TP-LINK TL-WN721N wireless adapter [SOLVED]

Started by jiaweihuo, April 28, 2013, 04:42:20 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jiaweihuo

Ubuntu 12.04 64

Quote[email protected]:~$ uname -a
Linux jiaweihuo-LIFEBOOK-LH772 3.2.0-40-generic #64-Ubuntu SMP Mon Mar 25 21:22:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[email protected]:~$ md5sum /lib/firmware/htc_9271.fw
76c902360ef8a095133258fd0d287292  /lib/firmware/htc_9271.fw

Mark Greaves (PCNetSpec)

#16
Quote from: dmesg outputath9k_htc: Unable to allocate URBs

I'm reading that ths issue was fixed in 12.10/13.04 .. do you want to try installing a newer kernel ?

We'll start with the most up to date (3.4) build for precise first if you want ?

--
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk


jiaweihuo

Sorry, I do not want to upgrade to 12.10 or higher currently.

Mark Greaves (PCNetSpec)

#18
I'm not asking if you want to upgrade to 12.10/13.04 .. I'm asking if you want to try a newer kernel (possibly the one from 12.10/13.04 .. though we'll try the 3.4 kernel for 12.04 first) in 12.04 ?

See here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1088809 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1088809)
and
http://superuser.com/questions/465415/unable-to-allocate-urbs-error-on-usb-wi-fi-netgear-wnda3200 (http://superuser.com/questions/465415/unable-to-allocate-urbs-error-on-usb-wi-fi-netgear-wnda3200)
for info on the bug.

Do you want to try a more recent kernel in 12.04 ?
(there is nothing stopping you selecting the original kernel at bootup .. then removing the newer kernel if you want)

--
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

jiaweihuo

OK, I can upgrade to a newer kernel.


Mark Greaves (PCNetSpec)

OK, run these commands in sequence:
mkdir ~/Desktop/precise-kernel-3.4
then
cd ~/Desktop/precise-kernel-3.4
then
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/linux-headers-3.4.0-030400-generic_3.4.0-030400.201205210521_amd64.deb
then
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/linux-image-3.4.0-030400-generic_3.4.0-030400.201205210521_amd64.deb
then
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/linux-headers-3.4.0-030400_3.4.0-030400.201205210521_all.deb
then
sudo dpkg -i *.deb

Once that's finished .. REBOOT and post the output from:
uname -a

and check if the USB wireless adapter works .. if not, unplug the tplink, replug the tplink and post the output from:
dmesg | tail -n 20
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

jiaweihuo


Mark Greaves (PCNetSpec)

You're welcome :)

You can safely delete the precise-kernel-3.4 folder on your desktop if you''d like.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

jiaweihuo

Hi, now I have a new problem. After upgrading the kernel to 3.4, the update manager asks to to update the kernel 3.2. What should I do? Thanks.


Mark Greaves (PCNetSpec)

What's the output from
uname -a

and if you click the "Check" button in update manager, is the 3.2 kernel still listed ?

This is Ubuntu 12.04 right ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

jiaweihuo

#25
Quote[email protected]:~$ uname -a
Linux jiaweihuo-LIFEBOOK-LH772 3.4.0-030400-generic #201205210521 SMP Mon May 21 09:22:02 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 12.04, yes.

The attachment is a sreenshot of update manager.

Mark Greaves (PCNetSpec)

Just let it do the update .. if when you reboot it boots into a 3.2 kernel and wireless is broken, you can reboot and select kernel 3.4 from the grub menu.

If necessary, let us know and we'll set kernel 3.4 as the default kernel.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

jiaweihuo

I do not use grub. But it selects kernel 3.4 by default.