Author Topic: A little help with fstab (SOLVED)  (Read 8453 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #30 on: February 07, 2014, 11:21:45 pm »
is this Peppermint 4 ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Emegra

  • Guest
Re: A little help with fstab
« Reply #31 on: February 07, 2014, 11:22:19 pm »
Quote
is this Peppermint 4 ?

Yes

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #32 on: February 07, 2014, 11:23:41 pm »
So what's the output from
Code: [Select]
mount
?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Emegra

  • Guest
Re: A little help with fstab
« Reply #33 on: February 07, 2014, 11:24:39 pm »
graeme@Linux1 ~ $ mount
/dev/sda5 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
gvfsd-fuse on /run/user/graeme/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=graeme)
gvfsd-fuse on /home/graeme/.gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev)
graeme@Linux1 ~ $

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #34 on: February 07, 2014, 11:28:04 pm »
run:
Code: [Select]
sudo mount -a
then post the output from:
Code: [Select]
mount

is this PC connected wirelessly ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Emegra

  • Guest
Re: A little help with fstab
« Reply #35 on: February 07, 2014, 11:30:48 pm »
Code: [Select]
graeme@Linux1 ~ $ sudo mount -a
[sudo] password for graeme:
graeme@Linux1 ~ $ mount
/dev/sda5 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
gvfsd-fuse on /run/user/graeme/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=graeme)
gvfsd-fuse on /home/graeme/.gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev)
//192.168.2.50/family-tree on /mnt/NAS/family-tree type cifs (rw)
//192.168.2.50/graeme on /mnt/NAS/graeme type cifs (rw)
//192.168.2.50/pat on /mnt/NAS/pat type cifs (rw)
//192.168.2.50/multimedia on /mnt/NAS/multimedia type cifs (rw)
//192.168.2.50/movies on /mnt/NAS/movies type cifs (rw)
//192.168.2.50/backups on /mnt/NAS/backups type cifs (rw)
//192.168.2.50/utilities on /mnt/NAS/utilities type cifs (rw)
graeme@Linux1 ~ $

Quote
is this PC connected wirelessly ?

Yes but the NAS is connected directly to the router via ethernet

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #36 on: February 07, 2014, 11:39:45 pm »
OK something tells me the shares are being brought up earlier than the network .. which is odd as cifs should wait :/

I know in PM3 you had to use smbfs and add a switch to tell it to wait.

Erm .. you may have to gimme till tomorrow to search for a solution as that switch doesn't work with cifs

You online tomorrow ?

try shutting down .. then restarting the PC .. see if that works ?

is this the respin or the original PM4 ?
« Last Edit: February 07, 2014, 11:41:23 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Emegra

  • Guest
Re: A little help with fstab
« Reply #37 on: February 07, 2014, 11:42:55 pm »
Quote
You online tomorrow ?

Yeah I'll be on in the afternoon, my grandaughter stays with us from 5pm and I try to spend the evening with her on a saturday

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #38 on: February 07, 2014, 11:44:34 pm »
is this the respin ?

what's the output from:
Code: [Select]
dpkg -l | grep smb
and
Code: [Select]
dpkg -l | grep cifs
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Emegra

  • Guest
Re: A little help with fstab
« Reply #39 on: February 07, 2014, 11:49:43 pm »
Quote
is this the respin ?

No it was installed with a pre respin disc and updated

Code: [Select]
graeme@Linux1 ~ $ dpkg -l | grep smb
ii  libsmbclient:i386                         2:3.6.9-1ubuntu1.2                       i386         shared library for communication with SMB/CIFS servers
ii  python-smbc                               1.0.13-0ubuntu4                          i386         Python bindings for Samba clients (libsmbclient)
ii  smbclient                                 2:3.6.9-1ubuntu1.2                       i386         command-line SMB/CIFS clients for Unix
graeme@Linux1 ~ $ dpkg -l | grep cifs
ii  cifs-utils                                2:5.5-1ubuntu2                           i386         Common Internet File System utilities
graeme@Linux1 ~ $
« Last Edit: February 07, 2014, 11:51:14 pm by Emegra »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #40 on: February 07, 2014, 11:56:23 pm »
OK, leave it with me till tomorrow..

We have 2 options here .. figure out why cifs isn't waiting for the network to come up .. or possibly run a script with a delay that runs "mount -a"

We'll figure it out :)

Odd that cifs waits on my system .. and keeps attempting to connect till it gets there.

Have you still got gigolo installed, and are the mounts set to automount in that ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Emegra

  • Guest
Re: A little help with fstab
« Reply #41 on: February 08, 2014, 12:05:58 am »
Quote
Have you still got gigolo installed, and are the mounts set to automount in that ?

Yes Gigolo is still installed and all shares set to automount, would it be worth trying  un-installing Gigolo and rebooting again ?

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #42 on: February 08, 2014, 12:08:16 am »
I doubt if it'll make a difference, but worth a shot .. until tomorrow, you'd just need to run:
Code: [Select]
sudo mount -a
after rebooting.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Emegra

  • Guest
Re: A little help with fstab
« Reply #43 on: February 08, 2014, 12:11:02 am »
ok see you tomorrow then thanks again for your help





Graeme

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18252
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: A little help with fstab
« Reply #44 on: February 08, 2014, 01:26:42 am »
Try this...

Code: [Select]
sudo gedit /etc/network/if-up.d/my-custom-mountall
when a BLANK file opens, make it read:-
Code: [Select]
#!/bin/sh
mount -a
SAVE the file, and close gedit.

Back in the terminal run:
Code: [Select]
sudo chmod +x /etc/network/if-up.d/my-custom-mountall
reboot to test.

If that doesn't work .. just delete the /etc/network/if-up.d/my-custom-mountall file.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal