Author Topic: Sound issue in Game Fantastic Farm revised for mint 17 (Solved)  (Read 4885 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm Solved
« Reply #15 on: July 09, 2014, 11:04:53 pm »
That's probably an old version of libpulsedsp.so .. but if you have libpulsedsp installed you should already have it somewhere on your system

Run:
Code: [Select]
sudo apt-get install libpulsedsp
then
Code: [Select]
sudo updatedb
then post the output from
Code: [Select]
locate libpulsedsp.so
« Last Edit: July 09, 2014, 11:06:51 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 951
  • Karma: 14
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm Solved
« Reply #16 on: July 10, 2014, 08:49:49 am »

userone@Office2 ~ $ locate libpulsedsp.so
/home/userone/libpulsedsp.so
/home/userone/libpulsedsp.so.tar.gz
/home/userone/.local/share/Trash/files/libpulsedsp.so
/home/userone/.local/share/Trash/files/libpulsedsp.so.tar.gz
/home/userone/.local/share/Trash/info/libpulsedsp.so.tar.gz.trashinfo
/home/userone/.local/share/Trash/info/libpulsedsp.so.trashinfo
/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so
/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so
userone@Office2 ~ $

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm revised for mint 17
« Reply #17 on: July 10, 2014, 01:38:16 pm »
OK, try either

Code: [Select]
Exec=bash -c "LD_PRELOAD=/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"
or
Code: [Select]
Exec=bash -c "LD_PRELOAD=/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"
That's assuming the path to Fantastic Farm is still /home/userone/fantasticfarm/'Fantastic Farm
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 951
  • Karma: 14
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm revised for mint 17
« Reply #18 on: July 10, 2014, 04:23:43 pm »
They did not work and I got the following message for both.

-c: command not found

This computer has a AMD CPU.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm revised for mint 17
« Reply #19 on: July 10, 2014, 04:33:28 pm »
you're not entering those (still with the "Exec=") at the command line are you ?

The "Exec=" part is only for the .desktop launcher.



do either of these work from the command line:
Code: [Select]
bash -c "LD_PRELOAD=/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"
or
Code: [Select]
bash -c "LD_PRELOAD=/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"
?
« Last Edit: July 10, 2014, 04:38:45 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 951
  • Karma: 14
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm revised for mint 17
« Reply #20 on: July 10, 2014, 09:05:28 pm »
The 2nd option works just fine and works in the luncher as well.

Many thanks.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Sound issue in Game Fantastic Farm revised for mint 17 (Closed)
« Reply #21 on: July 10, 2014, 09:14:23 pm »
No problem :)

Can I ask a favour .. if it's now solved, can you change (Closed) in the subject line to (SOLVED) .. closed tends to mean (gave up).

TIA :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal