Author Topic: Exfat in Gparted (Solved)  (Read 70945 times)

0 Members and 2 Guests are viewing this topic.

Jocklad 1

  • Guest
Exfat in Gparted (Solved)
« on: October 03, 2014, 12:49:22 pm »
 Trying to format a 64g micro Sd card to exfat in Gparted.

 The exfat option is greyed out.

 Jocklad  ::)
« Last Edit: October 03, 2014, 03:07:24 pm by Jocklad 1 »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18182
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Exfat in Gparted
« Reply #1 on: October 03, 2014, 01:20:31 pm »
Code: [Select]
sudo apt-get install exfat-utils exfat-fuse
then restart Gparted .. is it still greyed out ?
« Last Edit: October 03, 2014, 01:28:16 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Jocklad 1

  • Guest
Re: Exfat in Gparted
« Reply #2 on: October 03, 2014, 01:34:39 pm »
ben@ben-Dell-DV051 ~ $ sudo apt-get install exfat-utils exfat-fuse
[sudo] password for ben:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
exfat-fuse is already the newest version.
exfat-utils is already the newest version.
0 to upgrade, 0 to newly install, 0 to remove and 21 not to upgrade.
ben@ben-Dell-DV051 ~ $


It installed ok, but exfat still greyed out in Gparted


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18182
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Exfat in Gparted
« Reply #3 on: October 03, 2014, 02:46:23 pm »
If you look at the suported oprations for different file systems here:
http://gparted.org/features.php
it seems Gparted doesn't support creation of exfat file systems .. I read somewhere that it's for "legal reasons", but don't know if that's true.



I just used
menu > Preferences >Disks

selected the device I wanted to format in the laft hand column

clicked on  the partition I wanted to format (so it was outlined) .. then clicked the little cog icon underneath, and selected "Format"

then set
Type: Custom (Enter filesystem type)
Filesystem: exfat

Then clicked Format > Format

That seemed to do the trick :)
« Last Edit: October 03, 2014, 03:06:44 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Jocklad 1

  • Guest
Re: Exfat in Gparted
« Reply #4 on: October 03, 2014, 02:48:59 pm »

 Thanks Mark will have a go at that  :)

 Jocklad

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18182
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Exfat in Gparted
« Reply #5 on: October 03, 2014, 02:58:41 pm »
just checked, and Win7 was happy to recognise the USB stick formatted with "Disks" as having an exFAT filesystem :)

Gparted (and blkid) also recognises it as exfat.
« Last Edit: October 03, 2014, 03:01:52 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Jocklad 1

  • Guest
Re: Exfat in Gparted
« Reply #6 on: October 03, 2014, 03:06:56 pm »

 Yes that did it Mark.

 Have formatted the SD Card and inserted back into camera,its working fine.

 Again many thanks.  :) :) :) :) :)

 Jocklad

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18182
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Exfat in Gparted (Solved)
« Reply #7 on: October 03, 2014, 03:08:49 pm »
You're most welcome .. I learned something new myself too :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline botable

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Exfat in Gparted
« Reply #8 on: October 17, 2015, 09:21:15 pm »
clicked the little cog icon underneath, and selected "Format"

then set
Type: Custom (Enter filesystem type)
Filesystem: exfat

I know this thread is marked as solved, but it contains false or misleading information. The little clog icon and the Custom field are NOT found in GParted. They are found in GNOME Disk Utility a.k.a Disks. Those are two different partition managers. Based on my own experience, GParted is completely useless as fas as ExFat goes. It can't even detect an ExFat partition properly. Use GNOME Disk Utility and the little clog icon.
« Last Edit: October 17, 2015, 09:24:00 pm by botable »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18182
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Exfat in Gparted (Solved)
« Reply #9 on: October 18, 2015, 11:55:49 am »
Welcome to the forum botable :)

I strongly suggest you go back and re-read the post of mine that you quoted before telling the world it was misleading .. then saying EXACTLY the same thing.

And if you're going to quote my posts, please quote them in FULL rather than clipping them to fit YOUR misconception or agenda...



For clarity here it is again (in FULL) with the relevant parts highlighted in red/blue for your benefit:-

If you look at the suported oprations for different file systems here:
http://gparted.org/features.php
it seems Gparted doesn't support creation of exfat file systems .. I read somewhere that it's for "legal reasons", but don't know if that's true.



I just used
menu > Preferences >Disks    <-- this is the gnome disk utility

selected the device I wanted to format in the laft hand column

clicked on  the partition I wanted to format (so it was outlined) .. then clicked the little cog icon underneath, and selected "Format"

then set
Type: Custom (Enter filesystem type)
Filesystem: exfat

Then clicked Format > Format

That seemed to do the trick :)
« Last Edit: October 18, 2015, 12:45:48 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal