Author Topic: Problem with 14.04 (Solved)  (Read 19380 times)

0 Members and 1 Guest are viewing this topic.

Offline Degsy

  • Sr. Member
  • ****
  • Posts: 355
  • Karma: 3
  • Gender: Male
  • I am getting there, but it is very slow going!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #30 on: October 10, 2014, 09:01:54 am »
Thanks, will let you know how any of this progresses.

Degsy

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #31 on: October 10, 2014, 11:43:55 am »
Yeah, try booting with the xforcevesa boot parameter .. then installing the nvidia drivers again.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #32 on: October 10, 2014, 12:17:52 pm »
The latest nvidia drivers I can get on Mint 17 (same base as Ubuntu 14.04) is the package called nvidia-331, so to install:
Code: [Select]
sudo apt-get install nvidia-331

This might land you in the same boat as your started in (needed to crash into a terminal with Ctrl-Alt-F1), but you can follow the process detailed earlier in this thread to recover.

Let us know if this still leaves you with problems, as I've found a way to install a couple of newer kernels that might be worth a stab (Mark - using debs from the mainline that are "longterm" according to kernel.org; it's ok not to use synaptic/apt, right?)

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #33 on: October 10, 2014, 02:43:18 pm »
Quote
(Mark - using debs from the mainline that are "longterm" according to kernel.org; it's ok not to use synaptic/apt, right?)

Not sure what you're asking here .. do you mean is it OK to install the vanilla kernel in .deb format with dpkg ?

I doubt if this is a kernel issue .. Peppermint 5 will be using the same kernel as 14.04 and that's working fine .. I think this is either
a) a graphics driver issue
b) an xorg issue (possibly still using the 12.04 xorg version, with the new kernel)
c) just sommat in the users home folder

I think the way forward is to
i) see if it boots with the xforcevesa kernel boot parameter
ii) if it does .. re-install the nvidia drivers through "Additional Drivers"
iii) if it still won't boot .. create a new user (and home folder) from the commandline, adding it to the correct groups .. with sommat like:
Code: [Select]
sudo useradd -m testuser -G adm,tty,disk,lp,dialout,fax,cdrom,floppy,tape,sudo,audio,dip,backup,video,plugdev,syslog,fuse,lpadmin,nopasswdlogin,netdev,ssh,sambashare
then set the password for the new "testuser" account with:
Code: [Select]
sudo passwd testuser
Then logging into the new "testuser" account at the login screen



You can get a list of the current groups with:
Code: [Select]
groups
and adjust the "useradd" command accordingly
« Last Edit: October 10, 2014, 02:45:34 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #34 on: October 10, 2014, 03:15:28 pm »
Quote
(Mark - using debs from the mainline that are "longterm" according to kernel.org; it's ok not to use synaptic/apt, right?)

Not sure what you're asking here .. do you mean is it OK to install the vanilla kernel in .deb format with dpkg ?

Not vanilla as such, I meant the Ubuntu mainline, but yes - installing the deb files using dpkg. I wasn't sure how you get on with updates (whether Update Manager would automagically apply new versions of the 3.10 or 3.12 or whatever kernel)

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #35 on: October 10, 2014, 04:17:47 pm »
yeah it (dpkg -i blah blah) will install them and make them available at the GRUB boot menu, but it won't set an earlier kernel as the default to boot into .. you'd have to select it at GRUB, them manually set it as the default in grub.cfg .. once set as the default it will remain as default even across updates.
(ie. you'll still be getting the kernel updates, but GRUB will always boot the one you selected as the default .. if no default is set, GRUB always boots the most recent)

Make sense ?
« Last Edit: October 10, 2014, 04:26:47 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Degsy

  • Sr. Member
  • ****
  • Posts: 355
  • Karma: 3
  • Gender: Male
  • I am getting there, but it is very slow going!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #36 on: October 10, 2014, 04:47:29 pm »
Hi Guys,
Having problems getting to the options to try the xforcevesa thing, tried left shift and F6 but I just end up back in the Grub screen, any suggestions?

Degsy

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #37 on: October 10, 2014, 08:12:00 pm »
Whilst at the GRUB menu


Select the 'default' Ubuntu kernel  and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:


Press DOWN ARROW until you get to the line that starts with:

Quote
linux /boot


and press the END key to position the cursor at the end of the that line... it *usually* ends with “quiet splash”.

Now you can enter additional kernel boot options... so add xforcevesa .. so it now reads:

Quote
quiet splash xforcevesa

(doesn't matter if it moves down a line, as long as there is a space between splash and xforcevesa)

Now hit Ctrl+X to boot.
« Last Edit: October 10, 2014, 08:14:20 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Degsy

  • Sr. Member
  • ****
  • Posts: 355
  • Karma: 3
  • Gender: Male
  • I am getting there, but it is very slow going!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #38 on: October 11, 2014, 10:44:29 am »
Hi Guys,
OK tried your last suggestion Mark, the line didn't end with quiet splash, it actually ended with this "$vt-handoff"  I tried adding the xforcevesa after this, then deleting this and adding after the quiet splash, then finally after quiet splash and before the $vt=handoff.
The outcome was "best with this last attempt, it booted to the desktop, I thought it had worked, there was even a mouse cursor! The mouse moved and allowed me to click on Firefox, the circle went round a couple of times then stopped, froze up, no mouse movement, no keyboard, then the screen went black.
No idea if this tells you anything but that is what happened.
Any further thoughts please?


Thank you for your time,

Degsy

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1834
  • Karma: 142
  • Gender: Male
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #39 on: October 11, 2014, 12:22:39 pm »
I think you meant to do and not actually use it:
Yeah, try booting with the xforcevesa boot parameter .. then installing the nvidia drivers again.

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #40 on: October 13, 2014, 09:01:20 am »
Maybe we could try re-installing xorg:

Code: [Select]
sudo apt-get update && sudo apt-get --reinstall install xorg
A bit make or break though  :-\

Offline Degsy

  • Sr. Member
  • ****
  • Posts: 355
  • Karma: 3
  • Gender: Male
  • I am getting there, but it is very slow going!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #41 on: October 13, 2014, 01:55:15 pm »
Hi Chemicalfan, sorry only just seen your post. Did try your suggestion but no joy I am afraid. Still boots OK to the old Kernel, it is a strange occurence isn't it?

Many thanks for your continued help, it is appreciated.

Cheers,
Degsy

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #42 on: October 13, 2014, 02:29:10 pm »
Even more strange! So, at the moment, are the nvidia drivers installed? Or are you running the nouveau xorg drivers?

It's strange that the older kernel works  ???

I think that you should try an older kernel that's newer than 3.2, see at what point it stopped working. I can't remember if you're running 32 or 64bit, but see below for code:

For 32bit:
Code: [Select]
mkdir ~/temp && cd ~/temp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12.30-trusty/linux-image-3.12.30-031230-generic_3.12.30-031230.201410081535_i386.deb && dpkg -i *.deb

For 64bit:
Code: [Select]
mkdir ~/temp && cd ~/temp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12.30-trusty/linux-image-3.12.30-031230-generic_3.12.30-031230.201410081535_amd64.deb && dpkg -i *.deb

As stated by Mark, these won't update GRUB's default entry, so when the machine boots, you'll have to select the new one manually (remember the version number, 3.12.30)

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #43 on: October 13, 2014, 03:52:51 pm »
Still not convinced this is a kernel problem, or Peppermint 5 would also be affected (same kernel).

We need to know if the nvidia drivers have been reinstalled yet .. Degsy hasn't furnished this info yet ??

Boot Ubuntu with the old kernel, then what's the output from:
Code: [Select]
dpkg -l | grep nvidia
and
Code: [Select]
sudo lshw -C display
« Last Edit: October 13, 2014, 03:55:48 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Problem with 14.04
« Reply #44 on: October 13, 2014, 03:58:15 pm »
Just a thought.... Degsy, can you run the same in Peppermint and post that up too?

Edit: Mark, I don't think it's a kernel problem either, but the fact the old kernel works suggests a compatibility issue somewhere with the new kernel. Maybe the old kernel has forced something else into some kind of fallback mode, which works? I was going with the "let's get the newest kernel possible working, then call it a day"
« Last Edit: October 13, 2014, 04:00:54 pm by chemicalfan »

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal