Author Topic: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE  (Read 10422 times)

0 Members and 1 Guest are viewing this topic.

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« on: October 29, 2014, 09:14:39 pm »
Hi guys, hope you can help.

I'm trying to install Fuse but it required something called libspectrum to be installed. So I did that first, successfully compiled (or so I thought). Now, when I try to configure the Fuse program itself, I get this in the terminal followed by later errors mentioning that libspectrum was not "available":

Code: [Select]
checking for GTK+ - version >= 2.18.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.

..and things go wrong from there on. I checked the config.log file but it didn't make things any clearer to me. I'm sure I've got GTK+ installed because the relevant files are ticked in my Software Manager. I'm guessing I need to upgrade my version of GTK+ (to at least 2.18.0)? How would I go about that? Would this be causing the libspectrum errors too?

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #1 on: October 30, 2014, 12:30:34 am »
Any reason you're not just installing it from the default repositories:
Code: [Select]
sudo apt-get install fuse-emulator-gtk
?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #2 on: October 30, 2014, 09:00:28 am »
Mint 16 is unsupported, you should upgrade to Mint 17 when you can - do you need assistance with that?

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #3 on: October 31, 2014, 11:59:06 pm »
Thanks guys.

Mark, the command you suggested brought up:

Code: [Select]
E: Unable to locate package fuse-emulator-gtk

Chemicalfan, I didn't realise that. Will be upgrading soon.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #4 on: November 01, 2014, 01:33:50 am »
Do you get any errors when you run:
Code: [Select]
sudo apt-get update
?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #5 on: November 05, 2014, 12:04:48 am »
No Mark, no errors there.

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #6 on: November 05, 2014, 01:00:13 am »
No worries guys, I tried another emulator (Speccy), it works fine.

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #7 on: November 05, 2014, 07:48:23 pm »
Spoke too soon. Speccy works but I can't hear any sound. I have it checked in the drop-down menu [F5] but can't hear sounds or tape noise. I've tried opening it via a command-line from the Terminal (with -sound 1) but no luck.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #8 on: November 06, 2014, 01:39:30 am »
I'll have a bash at this if you gimme links to the resources I may need .. such as a game to test.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #9 on: November 06, 2014, 09:53:55 am »
Spoke too soon. Speccy works but I can't hear any sound. I have it checked in the drop-down menu [F5] but can't hear sounds or tape noise. I've tried opening it via a command-line from the Terminal (with -sound 1) but no luck.


Be honest, that's the whole reason you're after it  :P

Edit: Have you seen this - sites.google.com/site/pauldunn/ - according to Wikipedia, it's a port of the Spectrum's BASIC interpreter to Linux (and other platforms). If you've got the source code of the Spectrum programmes, you may be able to run them natively without an emulator.
« Last Edit: November 06, 2014, 10:09:06 am by chemicalfan »

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #10 on: November 06, 2014, 01:53:32 pm »
Mark, Speccy 1.7 for Linux is available here but there doesn't appear to be a config file, which is a pain:

http://fms.komkon.org/Speccy/

Roms from World of Spectrum:

http://www.worldofspectrum.org/archive.html

chemicalfan, love a bit of tape noise, me. :) I have a friend who used to be a radio ham, he would share programs, etc., with his radio buddies over Short Wave. As long as the signal was clear enough it was an effective way to share data, especially with work colleagues. I'd never heard of such a thing. Also, a friend of mine who owned a Spectrum back in the '80s never realised it was possible to load games quicker by using the High-speed Dubbing on your cassette player!

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #11 on: November 07, 2014, 01:15:49 am »
Try running:
Code: [Select]
sudo apt-get install libasound2 libc6 libcairo2 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk-3-0 libpango-1.0-0 libpng12-0 libsdl1.2debian libspectrum8 libx11-6 libxml2 spectrum-roms zlib1g

If that command finishes without error .. then create a folder on your desktop called fuse-temp with:
Code: [Select]
mkdir ~/Desktop/fuse-temp
then if you're running Mint 32bit download the following 2 files and place them in the fuse-temp directory on your desktop .. if you're running Mint 64bit download the 2 files under the 64bit heading INSTEAD and place them in the fuse-temp directory on your desktop

REMEMBER - You only want 2 files in the fuse-temp directory on your desktop depending on your architecture .. if you're not sure whether you're running 32bit or 64bit Mint, stop now and let me know.

32bit
https://launchpad.net/ubuntu/+archive/primary/+files/fuse-emulator-common_1.1.1%2Bdfsg1-2_all.deb
and
https://launchpad.net/ubuntu/+archive/primary/+files/fuse-emulator-gtk_1.1.1%2Bdfsg1-2_i386.deb

64bit
https://launchpad.net/ubuntu/+archive/primary/+files/fuse-emulator-common_1.1.1%2Bdfsg1-2_all.deb
and
https://launchpad.net/ubuntu/+archive/primary/+files/fuse-emulator-gtk_1.1.1%2Bdfsg1-2_amd64.deb

now run:
Code: [Select]
cd ~/Desktop/fuse-temp
then
Code: [Select]
sudo dpkg -i *.deb



If you manage to get it installed, you might want to read this about loading a tape
http://raspi.tv/2012/how-to-install-fuse-zx-spectrum-emulator-on-raspberry-pi
« Last Edit: November 07, 2014, 01:47:57 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #12 on: November 07, 2014, 02:36:26 am »
Will try that Mark, thanks.

Offline Morgan700

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #13 on: November 07, 2014, 04:39:01 pm »
Mark, I get this error with the first command:

Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package spectrum-roms

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Trying to install Fuse (ZX Spectrum emulator) on Mint 16 MATE
« Reply #14 on: November 07, 2014, 08:35:30 pm »
OK, make the first command read:
Code: [Select]
sudo apt-get install libasound2 libc6 libcairo2 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk-3-0 libpango-1.0-0 libpng12-0 libsdl1.2debian libspectrum8 libx11-6 libxml2 zlib1g
and when you download your 2 files to put in the fuse-tem directory on your dewsktop .. also dowmload this file and put it in there:
http://mirrors.kernel.org/ubuntu/pool/multiverse/s/spectrum-roms/spectrum-roms_20081224-3_all.deb
so you have 3 files in the directory before running thee "dpkg" command.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal