Author Topic: [SOLVED] Unable to install Openshot  (Read 9271 times)

0 Members and 1 Guest are viewing this topic.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
[SOLVED] Unable to install Openshot
« on: November 26, 2014, 03:19:15 pm »
I am running Kubuntu 12.04 and I tried to install openshot via Muon Software Centre which failed so I tried through Terminal, that failed too.
I get;
pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo apt-get install openshot
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 openshot : Depends: python-mlt3 but it is not going to be installed or
                     python-mlt2 but it is not installable
E: Unable to correct problems, you have held broken packages.
pooky2483@pooky2483-Kubuntu-1204-3:~$

I've tried other solutions...
Code: [Select]
sudo apt-get install -f

Code: [Select]
sudo apt-get update
sudo apt-get autoclean
sudo apt-get clean
sudo apt-get autoremove

Anyone got any ideas what to try next to fix it.


« Last Edit: December 03, 2014, 06:33:53 am by pooky2483 »

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Unable to install Openshot
« Reply #1 on: November 26, 2014, 04:35:29 pm »
What error do you get with:
Code: [Select]
sudo apt-get install python-mlt3

Edit: By the look of the openshot error, that package may be broken as it refers to both python-mlt3 & python-mlt2

Edit 2: mlt2 is only available in lucid, and mlt3 is only available in precise. Try:

Code: [Select]
sudo apt-get install python-mlt

That's available in trusty, and may do the job...?
« Last Edit: November 26, 2014, 04:39:03 pm by chemicalfan »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18235
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #2 on: November 26, 2014, 08:06:47 pm »
I think in precise you have to install python-mlt3 before openshot .. so try:
Code: [Select]
sudo apt-get remove --purge openshot
then
Code: [Select]
sudo apt-get install python-mlt3
then
Code: [Select]
sudo apt-get install openshot
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #3 on: November 26, 2014, 11:14:35 pm »
Mark, I get to stage 2 and get this...
pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo apt-get remove --purge openshot
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libmovit2 python-pygoocanvas libvidstab1.0 recordmydesktop libmlt-data libmlt4
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED
  openshot*
0 to upgrade, 0 to newly install, 1 to remove and 0 not to upgrade.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 269240 files and directories currently installed.)
Removing openshot ...
Purging configuration files for openshot ...
pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo apt-get install python-mlt3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 python-mlt3 : Depends: libmlt++3 but it is not going to be installed                 
E: Unable to correct problems, you have held broken packages.                         
pooky2483@pooky2483-Kubuntu-1204-3:~$   

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #4 on: November 26, 2014, 11:20:08 pm »
I can install python-mlt but not mlt3

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18235
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #5 on: November 27, 2014, 12:18:20 am »
OK, as chemicalfan said .. try:
Code: [Select]
sudo apt-get install python-mlt
then:
Code: [Select]
sudo apt-get install openshot
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #6 on: November 27, 2014, 08:55:46 am »
Afraid that didn’t work...

pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo apt-get install python-mlt
[sudo] password for pooky2483:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-mlt is already the newest version.
The following packages were automatically installed and are no longer required:
  python-pygoocanvas recordmydesktop
Use 'apt-get autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo apt-get install openshot
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 openshot : Depends: python-mlt3 but it is not going to be installed or
                     python-mlt2 but it is not installable
E: Unable to correct problems, you have held broken packages.
pooky2483@pooky2483-Kubuntu-1204-3:~$

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Unable to install Openshot
« Reply #7 on: November 27, 2014, 09:06:35 am »
Can you run:
Code: [Select]
sudo apt-get install -f openshot

Hoping it might install the package regardless of the unmet dependency (as I think it's met by python-mlt, it's just the package info that's broken)

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #8 on: November 27, 2014, 01:57:03 pm »
Nope... I get;

pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo apt-get install -f openshot
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 openshot : Depends: python-mlt3 but it is not going to be installed or
                     python-mlt2 but it is not installable
E: Unable to correct problems, you have held broken packages.
pooky2483@pooky2483-Kubuntu-1204-3:~$

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Unable to install Openshot
« Reply #9 on: November 27, 2014, 02:55:22 pm »
There's a similar bug registered here - https://bugs.launchpad.net/ubuntu/+source/mlt/+bug/1009409
Hasn't been updated for a while, no mention of 14.04 but seems to still apply.

Try adding the Openshot PPA - http://openshot.org/ppa/ and then updating and trying to install it again

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #10 on: November 27, 2014, 04:09:25 pm »
That didn’t work, failed at the last command...

pooky2483@pooky2483-Kubuntu-1204-3:~$  sudo apt-get install openshot openshot-doc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 openshot : Depends: python-mlt5 but it is not installable or
                     python-mlt3 but it is not going to be installed or
                     python-mlt2 but it is not installable
E: Unable to correct problems, you have held broken packages.
pooky2483@pooky2483-Kubuntu-1204-3:~$

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
Re: Unable to install Openshot
« Reply #11 on: November 27, 2014, 04:25:45 pm »
I've been an idiot, I was sure you were running Kubuntu 14.04, not 12.04  :-[

Ok, so what happens if you run:
Code: [Select]
sudo apt-get install -f libmlt++3

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #12 on: November 27, 2014, 08:36:15 pm »
Still unable to install openshot...

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18235
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #13 on: November 27, 2014, 09:49:07 pm »
error messages will help ;)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #14 on: November 28, 2014, 05:12:02 pm »
Sorry Mark, just been getting the same errors as earlier.

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal