Author Topic: [SOLVED] Unable to install Openshot  (Read 9230 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #30 on: December 01, 2014, 03:23:07 pm »
What's the output from:
Code: [Select]
apt-cache policy libmlt6
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #31 on: December 01, 2014, 03:45:30 pm »
pooky2483@pooky2483-Kubuntu-1204-3:~$ apt-cache policy libmlt6
libmlt6:
  Installed: (none)
  Candidate: 0.9.3+git20140926.bbf724b6-0ubuntu0~sunab~precise1
  Version table:
     0.9.3+git20140926.bbf724b6-0ubuntu0~sunab~precise1 0
        500 http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
pooky2483@pooky2483-Kubuntu-1204-3:~$

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #32 on: December 01, 2014, 04:48:46 pm »
And therein lies the problem.

You've added a PPA (kdenlive) that has a more recent version of libmlt than the one in the default repos (and the one openshot is expecting to find).

So the only way to install openshot from the default repos would be to purge that PPA .. but that will break or remove kdenlive



[EDIT]

Your other option would be to try adding the openshot PPA and installing version 1.4.3 from there .. this seems to have dependencies that might match (it can handle mlt2, 3, and 5 .. whereas the default 12.04 version can only handle mlt2, and 3)

run:
Code: [Select]
sudo add-apt-repository ppa:openshot.developers/ppa
then
Code: [Select]
sudo apt-get update
then post the output from:
Code: [Select]
sudo aptitude install -s openshot
again
« Last Edit: December 01, 2014, 05:13:58 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #33 on: December 01, 2014, 05:06:09 pm »
Would I be able to roll back kdenlive and hopefully libmlt too then install openshot then do an update.
Or remove kdenlive, install openshot and then reinstall kdenlive?

Maybe the only way to find out is to try it...
What do you think, Mark?

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #34 on: December 01, 2014, 05:13:35 pm »
please see the edit in my last posting.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #35 on: December 01, 2014, 05:30:36 pm »
Seen it, followed it and not yet entered anything on the prompt

pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo aptitude install -s openshot
The following NEW packages will be installed:
  libmlt++3{a} libmlt6{ab} melt{a} openshot python-mlt3{a}
The following packages will be REMOVED:
  recordmydesktop{u}
0 packages upgraded, 5 newly installed, 1 to remove and 1 not upgraded.
Need to get 24.8 MB/25.5 MB of archives. After unpacking 64.1 MB will be used.
The following packages have unmet dependencies:
 libmlt6 : Conflicts: libmlt4 but 0.7.6+git20120204-2 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libmlt++3 [Not Installed]                         
2)     libmlt6 [Not Installed]                           
3)     melt [Not Installed]                               
4)     openshot [Not Installed]                           
5)     python-mlt3 [Not Installed]                       



Accept this solution? [Y/n/q/?]

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #36 on: December 01, 2014, 05:37:30 pm »
You can accept it, but you'll loose recordmydesktop
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #37 on: December 01, 2014, 05:51:10 pm »
That's OK as I've got Vokoscreen, which you recommended.

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #38 on: December 01, 2014, 05:52:08 pm »
I accepted it and got this;

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  libmovit2{u} libvidstab1.0{u} python-pygoocanvas{u} recordmydesktop{u}
0 packages upgraded, 0 newly installed, 4 to remove and 1 not upgraded.
Need to get 0 B of archives. After unpacking 1,641 kB will be freed.
Do you want to continue? [Y/n/?] y
Would download/install/remove packages.
pooky2483@pooky2483-Kubuntu-1204-3:~$

What does that mean???

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #39 on: December 01, 2014, 05:55:03 pm »
yeah just accept it .. the other packages are already orphaned.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #40 on: December 01, 2014, 05:57:07 pm »
I have done and got this at the end;

Do you want to continue? [Y/n/?] y
Would download/install/remove packages.
pooky2483@pooky2483-Kubuntu-1204-3:~$

It's confusing as I've already pressed 'y'

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #41 on: December 01, 2014, 06:07:58 pm »
Ooops sorry, we were running it in "simulated dry run" mode (-s option).
(where it tells you what WOULD be done if you ran it properly)

Run:
Code: [Select]
sudo aptitude install openshot
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to install Openshot
« Reply #42 on: December 01, 2014, 06:24:05 pm »
Done, but it doesn’t look like openshot has been installed, I've checked for it but it's not there. Is the next step to install?

pooky2483@pooky2483-Kubuntu-1204-3:~$ sudo aptitude install openshot
[sudo] password for pooky2483:
The following NEW packages will be installed:
  libmlt++3{a} libmlt6{ab} melt{a} openshot python-mlt3{a}
The following packages will be REMOVED:
  recordmydesktop{u}
0 packages upgraded, 5 newly installed, 1 to remove and 1 not upgraded.
Need to get 24.8 MB/25.5 MB of archives. After unpacking 64.1 MB will be used.
The following packages have unmet dependencies:
 libmlt6 : Conflicts: libmlt4 but 0.7.6+git20120204-2 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libmlt++3 [Not Installed]                         
2)     libmlt6 [Not Installed]                           
3)     melt [Not Installed]                               
4)     openshot [Not Installed]                           
5)     python-mlt3 [Not Installed]                       



Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  libmovit2{u} libvidstab1.0{u} python-pygoocanvas{u} recordmydesktop{u}
0 packages upgraded, 0 newly installed, 4 to remove and 1 not upgraded.
Need to get 0 B of archives. After unpacking 1,641 kB will be freed.
Do you want to continue? [Y/n/?] y
(Reading database ... 271918 files and directories currently installed.)
Removing libmovit2 ...
Removing libvidstab1.0 ...
Removing python-pygoocanvas ...
Removing recordmydesktop ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for man-db ...
                                         
pooky2483@pooky2483-Kubuntu-1204-3:~$

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Emegra

  • Guest
Re: Unable to install Openshot
« Reply #43 on: December 01, 2014, 06:28:24 pm »
Hi pooky

Have you tried opening Openshot from the terminal ?






Graeme

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to install Openshot
« Reply #44 on: December 01, 2014, 06:29:55 pm »
now what does:
Code: [Select]
sudo aptitude install -s openshot
report

[EDIT]

And what does:
Code: [Select]
sudo aptitude install -s libmlt6
report
« Last Edit: December 01, 2014, 06:32:39 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal