Author Topic: NTFS File Transfering Problems - Error splicing file: Value too large for define  (Read 6035 times)

0 Members and 1 Guest are viewing this topic.

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1691
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • Awards
Hoping someone can assist here.

When transferring files between both of my NTFS drives I keep getting this error:

Code: [Select]
Error splicing file: Value too large for defined data type fix

After looking into it, seems like it's a kernel/samba issue. I googled around, and found an old launchpad thread:

https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/455122

People have been able to get around this error by doing:

Code: [Select]
mount -t cifs -o user=me,pass=secret,nounix,noserverino //server/share /mount

however my drives aren't CIFS shares. I'm just transferring directly between drives.

Any possible way to change that command so it works with ntfs mounts?
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Offline chemicalfan

  • Hero Member
  • *****
  • Posts: 1166
  • Karma: 36
  • Gender: Male
  • I've been here a little while!
    • View Profile
    • Awards
That seems to be a bug in gcc when compiling - my guess is that you're using the file manager (Nautilus?), so the bug is probably there.

Is there anything unusual with these files? Are they large? Is either drive heavily fragmented? Can I be clear - both drives are NTFS?

The Linux Community Forum


Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1691
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • Awards
The files are pretty large yeah. In excess of 30GB.

Both drives are NTFS. Non are fragmented though.
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
How is Linux being loaded ? (liveCD ?)

How are these drives connected ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1691
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • Awards
From my Ubuntu installation. The other two drives are backup drives, no OSes on them.
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

The Linux Community Forum


Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
But how are they attached ? (USB / SATA)

and how are they mounted ? (FUSE or via fstab)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1691
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • Awards
They're connected via Sata of course. :)

I guess they're FSTAB? I'm not sure... They just mount when I click them in Nautilus.
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Reboot, then without doing anything else, post the uotput from:
Code: [Select]
mount
and the contents of:
Code: [Select]
gedit /etc/fstab
then click the drives in file manager to mount them .. and post the output from
Code: [Select]
mount
again
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal