Author Topic: External hard drive  (Read 1655 times)

0 Members and 1 Guest are viewing this topic.

Offline wishbone

  • Jr. Member
  • **
  • Posts: 84
  • Karma: 5
  • I've just joined!
    • View Profile
    • Awards
External hard drive
« on: December 02, 2015, 03:23:09 pm »
Hi all,

I have just got another external hard drive which has "gpt". I reformatted it to ext4, now when I try and add folders to it, it says I can`t because I do not have permissions to create it in the destination or "error copying file, permission denied" when trying to copy files.

It`s mounted at dev/sdb2. In GParted there`s a little key icon after dev/sdb2 under partition column. Any help appreciated.

Tony


Offline wishbone

  • Jr. Member
  • **
  • Posts: 84
  • Karma: 5
  • I've just joined!
    • View Profile
    • Awards
Re: External hard drive
« Reply #1 on: December 02, 2015, 04:10:22 pm »
Update.

I think I`ve found out how to do it by following this:

http://itsfoss.com/set-write-permission-ext4-partition-ubuntu-linux/

It seems to work OK for now!

The Linux Community Forum

Re: External hard drive
« Reply #1 on: December 02, 2015, 04:10:22 pm »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: External hard drive
« Reply #2 on: December 03, 2015, 12:52:19 am »
Another option would have been to use the "Disks" utility to take ownership of the file system.

.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline wishbone

  • Jr. Member
  • **
  • Posts: 84
  • Karma: 5
  • I've just joined!
    • View Profile
    • Awards
Re: External hard drive
« Reply #3 on: December 03, 2015, 07:29:04 pm »
Nice one Mark. Until you mentioned the disks utility, I had forgotten about it. Still, it`s all working OK so far. Bloody microsoft and their gpt and all things to do with them.  :o


 


SimplePortal 2.3.3 © 2008-2010, SimplePortal